]> git.pld-linux.org Git - packages/csync2.git/blob - csync2.spec
8f9eb6f0dd395cca610a61a46113d550e19b1734
[packages/csync2.git] / csync2.spec
1 Summary:        Cluster sync tool
2 Summary(pl.UTF-8):      Narzędzie do synchronizacji klastra
3 Name:           csync2
4 Version:        2.0
5 Release:        1
6 License:        GPL v2+
7 Group:          Daemons
8 Source0:        http://oss.linbit.com/csync2/%{name}-%{version}.tar.gz
9 # Source0-md5:  4e189ff02af441e588ceaa7791732162
10 Source1:        %{name}.init
11 Source2:        %{name}.inet
12 Source3:        %{name}.sysconfig
13 Patch0:         %{name}-fix-sonames.patch
14 URL:            http://oss.linbit.com/csync2/
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  gnutls-devel
18 BuildRequires:  librsync-devel
19 BuildRequires:  mysql-devel
20 BuildRequires:  openssl-devel
21 BuildRequires:  postgresql-devel
22 BuildRequires:  sqlite3-devel
23 BuildRequires:  texlive-format-pdflatex
24 Requires:       setup > 2.4.10-4
25 Suggests:       mysql-libs
26 Suggests:       postgresql-libs
27 Suggests:       sqlite3
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _sysconfdir     /etc/%{name}
31
32 %description
33 Csync2 is a cluster synchronization tool. It can be used to keep files
34 on multiple hosts in a cluster in sync. Csync2 can handle complex
35 setups with much more than just 2 hosts, handle file deletions and can
36 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
37 and server farms.
38
39 %description -l pl.UTF-8
40 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
41 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
42 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
43 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
44 klastrów HA, HPC, COW oraz farm serwerów.
45
46 %package -n csync2-inetd
47 Summary:        Files necessary to run csync2 in inetd service mode
48 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia csync2 w trybie usługi inetd
49 Group:          Networking/Daemons
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       rc-inetd
52 Provides:       csyncd
53 Provides:       csyncd-inetd
54 Obsoletes:      csyncd
55 Obsoletes:      csync2-standalone
56 Obsoletes:      csyncd-standalone
57
58 %description -n csync2-inetd
59 Csync2 is a cluster synchronization tool. It can be used to keep files
60 on multiple hosts in a cluster in sync. Csync2 can handle complex
61 setups with much more than just 2 hosts, handle file deletions and can
62 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
63 and server farms.
64
65 %description -n csync2-inetd -l pl.UTF-8
66 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
67 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
68 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
69 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
70 klastrów HA, HPC, COW oraz farm serwerów.
71
72 %package -n csync2-standalone
73 Summary:        Files necessary to run csync2 in standalone daemon mode
74 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia csync2 w trybie samodzielnego serwera
75 Group:          Networking/Daemons
76 Requires(post,preun):   /sbin/chkconfig
77 Requires:       %{name} = %{version}-%{release}
78 Provides:       csyncd
79 Provides:       csyncd-standalone
80 Obsoletes:      csyncd
81 Obsoletes:      csync2-inetd
82 Obsoletes:      csyncd-inetd
83
84 %description -n csync2-standalone
85 Csync2 is a cluster synchronization tool. It can be used to keep files
86 on multiple hosts in a cluster in sync. Csync2 can handle complex
87 setups with much more than just 2 hosts, handle file deletions and can
88 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
89 and server farms.
90
91 %description -n csync2-standalone -l pl.UTF-8
92 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
93 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
94 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
95 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
96 klastrów HA, HPC, COW oraz farm serwerów.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101
102 %build
103 %configure \
104         --enable-gnutls \
105         --enable-mysql \
106         --enable-postgres \
107         --enable-sqlite3
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{%{_var}/lib/csync2,/etc/{sysconfig/rc-inetd,rc.d/init.d}}
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
118 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/%{name}
119 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post -n csync2-inetd
125 %service -q rc-inetd reload
126
127 %postun -n csync2-inetd
128 if [ "$1" = "0" ]; then
129         %service -q rc-inetd reload
130 fi
131
132 %post -n csync2-standalone
133 /sbin/chkconfig --add csync2
134 %service csync2 restart "csync2 server"
135
136 %preun -n csync2-standalone
137 if [ "$1" = "0" ]; then
138         %service csync2 stop
139         /sbin/chkconfig --del csync2
140 fi
141
142 %files
143 %defattr(644,root,root,755)
144 %doc AUTHORS ChangeLog README csync2.xinetd doc/csync2_paper.pdf
145 %dir %{_sysconfdir}
146 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/csync2.cfg
147 %attr(755,root,root) %{_sbindir}/csync2
148 %attr(755,root,root) %{_sbindir}/csync2-compare
149 %dir %{_var}/lib/csync2
150 %{_mandir}/man1/*.1*
151
152 %files -n csync2-inetd
153 %defattr(644,root,root,755)
154 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/%{name}
155
156 %files -n csync2-standalone
157 %defattr(644,root,root,755)
158 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
159 %attr(754,root,root) /etc/rc.d/init.d/%{name}
This page took 0.090022 seconds and 3 git commands to generate.