]> git.pld-linux.org Git - packages/csboard.git/commitdiff
- initial pld release
authorJarosław Kruk <jareq@pld-linux.org>
Fri, 13 Oct 2006 17:16:10 +0000 (17:16 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    csboard-mono.patch -> 1.1
    csboard.desktop -> 1.1
    csboard.spec -> 1.1

csboard-mono.patch [new file with mode: 0644]
csboard.desktop [new file with mode: 0644]
csboard.spec [new file with mode: 0644]

diff --git a/csboard-mono.patch b/csboard-mono.patch
new file mode 100644 (file)
index 0000000..28bf601
--- /dev/null
@@ -0,0 +1,87 @@
+--- src/Window.cs      2006/07/28 06:50:49     1.2
++++ src/Window.cs      2006/09/23 15:18:12     1.3
+@@ -88,7 +88,7 @@
+                               }
+                               
+-                        } catch (Exception e) {
++                        } catch {
+                                 MessageDialog md =
+                                         new MessageDialog (null, 0, MessageType.Error,
+@@ -170,6 +170,10 @@
+                 }
++                public void on_quit_window_activate (System.Object b, DeleteEventArgs e) {
++                      on_quit_activate(b, null);
++                }
++
+                 public void on_quit_activate (System.Object b, EventArgs e) {
+                       App.session.SaveGeometry (csboardWindow);
+                         control.Shutdown ();
+@@ -365,7 +369,7 @@
+                         proc.StartInfo.UseShellExecute = true;
+                       try {
+                               proc.Start ();
+-                      } catch (Exception ex) {
++                      } catch {
+                         // do nothing
+                       }
+               }
+--- src/ICSClient.cs   2004/10/26 17:51:43     1.1
++++ src/ICSClient.cs   2006/09/23 15:18:12     1.2
+@@ -55,7 +55,7 @@
+                           client = new TcpClient (server, int.Parse(port));
+                           stream = client.GetStream ();
+                           streamWriter = new StreamWriter (stream);
+-                      } catch (SocketException e) {
++                      } catch {
+                               throw new ApplicationException (String.Format(Catalog.GetString("Can't connect to {0} port {1}"), server, port));
+                       }
+--- src/ICS.cs 2006/07/28 06:50:49     1.2
++++ src/ICS.cs 2006/09/23 15:18:12     1.3
+@@ -74,7 +74,7 @@
+                                       client.passwd = args [i+1];
+                                }
+                             }
+-                    } catch (Exception e) {   
++                    } catch { 
+                             throw new ApplicationException (Catalog.GetString("Can't parse command line"));
+                     }
+                     
+--- src/App.cs 2006/07/28 06:50:49     1.4
++++ src/App.cs 2006/09/23 15:18:12     1.5
+@@ -41,7 +41,6 @@
+                       } catch (ApplicationException) {
+                               return 1;
+                       } catch (System.Exception e) {  
+-
+                                try {
+                                        MessageDialog md =
+                                          new MessageDialog (null,
+@@ -57,10 +56,8 @@
+                                        md.Hide ();
+                                        md.Dispose ();
+     
+-                               } catch (Exception ex) {
+-
++                               } catch {
+                                        throw e;
+-
+                                }
+                       }
+                       
+
+--- resource/csboard.glade  2004/10/26 17:51:431.1
++++ resource/csboard.glade  2006/09/23 15:18:121.2
+@@ -16,7 +16,7 @@
+   <property name="skip_pager_hint">False</property>
+   <property name="type_hint">GDK_WINDOW_TYPE_HINT_NORMAL</property>
+   <property name="gravity">GDK_GRAVITY_NORTH_WEST</property>
+-  <signal name="delete_event" handler="on_quit_activate" last_modification_time="Sat, 01 May 2004 23:54:42 GMT"/>
++  <signal name="delete_event" handler="on_quit_window_activate" last_modification_time="Sat, 01 May 2004 23:54:42 GMT"/>
+   <child>
+     <widget class="GtkVBox" id="vbox">
diff --git a/csboard.desktop b/csboard.desktop
new file mode 100644 (file)
index 0000000..a3af58d
--- /dev/null
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=csboard
+Comment[pl]=Szachy
+Exec=csboard
+Icon=csboard.png
+Terminal=false
+Type=Application
+Categories=Game;BoardGame;
+# vi: encoding=utf-8
diff --git a/csboard.spec b/csboard.spec
new file mode 100644 (file)
index 0000000..76d99ea
--- /dev/null
@@ -0,0 +1,84 @@
+Summary:       CSBoard is a small GUI for gnuchess
+Summary(pl):   CSBoard jest ma³ym frontendem do gnuchess
+Name:          csboard
+Version:       0.6
+Release:       1
+License:       GPL
+Group:         X11/Applications/Games
+Source0:       http://download.berlios.de/csboard/%{name}-%{version}.tar.gz
+# Source0-md5: 2c02bca491192be19273266781b6f18b
+Source1:       %{name}.desktop
+Patch0:                %{name}-mono.patch
+URL:           http://csboard.berlios.de/
+BuildRequires: dotnet-gnome-sharp-devel
+BuildRequires: scrollkeeper
+Requires(post,postun): desktop-file-utils
+Requires(post,postun): scrollkeeper
+Requires(post,preun):  GConf2
+Requires:      gnuchess
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+CSBoard is a small GUI for gnuchess. It is written in C# and uses mono
+and gtk-sharp. It is simple, but allows you just play chess with SVG
+graphics and native look and desktop theme usage.
+
+CSBoard use gnuchess as playing engine, but you can also play with
+crafty of phalanx.
+
+%description -l pl
+CSBoard jest ma³ym frontendem do gnuchess. Zosta³ napisany w jêzyku C#
+i wykorzystuje mono i bibliotekê gtk-sharp. Jest prosty, ale pozwala
+na grê w szachy wykorzystuj±c grafikê wektorow± SVG,
+
+%prep
+%setup -q
+%patch0 -p0
+
+%build
+%configure \
+       --disable-schemas-install \
+       --disable-scrollkeeper
+%{__make}
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+cp -f data/csboard.png  $RPM_BUILD_ROOT%{_pixmapsdir}
+
+%find_lang %{name} --all-name --with-gnome
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%gconf_schema_install csboard.schemas
+%scrollkeeper_update_post
+%update_desktop_database_post
+
+%postun
+%scrollkeeper_update_postun
+%update_desktop_database_postun
+
+%preun
+%gconf_schema_uninstall csboard.schemas
+
+%files -f %{name}.lang
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/csboard
+%dir %{_datadir}/csboard
+%dir %{_datadir}/csboard/images
+%dir %{_datadir}/csboard/resource
+%{_datadir}/csboard/csboard.exe
+%{_datadir}/csboard/images/*
+%{_datadir}/csboard/resource/*
+%{_desktopdir}/*
+%{_omf_dest_dir}/%{name}
+%{_pixmapsdir}/*
+%{_sysconfdir}/gconf/schemas/csboard.schemas
This page took 0.112276 seconds and 4 git commands to generate.