]> git.pld-linux.org Git - packages/cryptsetup.git/commitdiff
- rel 3; adopt to kernel API changes; seems needed for all stable kernel lines (ie... auto/th/cryptsetup-1.7.0-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 21 Feb 2016 18:51:28 +0000 (19:51 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 21 Feb 2016 18:51:28 +0000 (19:51 +0100)
0001-Set-skcipher-key-before-accept-call-in-kernel-crypto.patch [new file with mode: 0644]
0002-Fix-kernel-crypto-backend-to-set-key-before-accept-c.patch [new file with mode: 0644]
cryptsetup.spec

diff --git a/0001-Set-skcipher-key-before-accept-call-in-kernel-crypto.patch b/0001-Set-skcipher-key-before-accept-call-in-kernel-crypto.patch
new file mode 100644 (file)
index 0000000..f79db42
--- /dev/null
@@ -0,0 +1,191 @@
+From 93ed401b7c1d298de0a3fe38ae45d96529a8511c Mon Sep 17 00:00:00 2001
+From: Milan Broz <gmazyland@gmail.com>
+Date: Sat, 2 Jan 2016 20:02:28 +0100
+Subject: [PATCH] Set skcipher key before accept() call in kernel crypto
+ backend.
+
+Also relax input errno checking to catch all errors.
+---
+ lib/crypto_backend/crypto_cipher_kernel.c | 56 ++++++++++++-------------------
+ lib/crypto_backend/crypto_kernel.c        | 35 ++++++++++++++-----
+ 2 files changed, 48 insertions(+), 43 deletions(-)
+
+diff --git a/lib/crypto_backend/crypto_cipher_kernel.c b/lib/crypto_backend/crypto_cipher_kernel.c
+index f7d2bcf..46e1f97 100644
+--- a/lib/crypto_backend/crypto_cipher_kernel.c
++++ b/lib/crypto_backend/crypto_cipher_kernel.c
+@@ -2,7 +2,7 @@
+  * Linux kernel userspace API crypto backend implementation (skcipher)
+  *
+  * Copyright (C) 2012, Red Hat, Inc. All rights reserved.
+- * Copyright (C) 2012-2014, Milan Broz
++ * Copyright (C) 2012-2016, Milan Broz
+  *
+  * This file is free software; you can redistribute it and/or
+  * modify it under the terms of the GNU Lesser General Public
+@@ -88,33 +88,8 @@ int crypt_cipher_blocksize(const char *name)
+       return ca ? ca->blocksize : -EINVAL;
+ }
+-/* Shared with hash kernel backend */
+-int crypt_kernel_socket_init(struct sockaddr_alg *sa, int *tfmfd, int *opfd);
+-
+-int crypt_kernel_socket_init(struct sockaddr_alg *sa, int *tfmfd, int *opfd)
+-{
+-      *tfmfd = socket(AF_ALG, SOCK_SEQPACKET, 0);
+-      if (*tfmfd == -1)
+-              return -ENOTSUP;
+-
+-      if (bind(*tfmfd, (struct sockaddr *)sa, sizeof(*sa)) == -1) {
+-              close(*tfmfd);
+-              *tfmfd = -1;
+-              return -ENOENT;
+-      }
+-
+-      *opfd = accept(*tfmfd, NULL, 0);
+-      if (*opfd == -1) {
+-              close(*tfmfd);
+-              *tfmfd = -1;
+-              return -EINVAL;
+-      }
+-
+-      return 0;
+-}
+-
+ /*
+- *ciphers
++ * ciphers
+  *
+  * ENOENT - algorithm not available
+  * ENOTSUP - AF_ALG family not available
+@@ -128,7 +103,6 @@ int crypt_cipher_init(struct crypt_cipher **ctx, const char *name,
+               .salg_family = AF_ALG,
+               .salg_type = "skcipher",
+       };
+-      int r;
+       h = malloc(sizeof(*h));
+       if (!h)
+@@ -137,14 +111,26 @@ int crypt_cipher_init(struct crypt_cipher **ctx, const char *name,
+       snprintf((char *)sa.salg_name, sizeof(sa.salg_name),
+                "%s(%s)", mode, name);
+-      r = crypt_kernel_socket_init(&sa, &h->tfmfd, &h->opfd);
+-      if (r < 0) {
+-              free(h);
+-              return r;
++      h->opfd = -1;
++      h->tfmfd = socket(AF_ALG, SOCK_SEQPACKET, 0);
++      if (h->tfmfd < 0) {
++              crypt_cipher_destroy(h);
++              return -ENOTSUP;
++      }
++
++      if (bind(h->tfmfd, (struct sockaddr *)&sa, sizeof(sa)) < 0) {
++              crypt_cipher_destroy(h);
++              return -ENOENT;
+       }
+       if (length && strcmp(name, "cipher_null") &&
+-          setsockopt(h->tfmfd, SOL_ALG, ALG_SET_KEY, buffer, length) == -1) {
++          setsockopt(h->tfmfd, SOL_ALG, ALG_SET_KEY, buffer, length) < 0) {
++              crypt_cipher_destroy(h);
++              return -EINVAL;
++      }
++
++      h->opfd = accept(h->tfmfd, NULL, 0);
++      if (h->opfd < 0) {
+               crypt_cipher_destroy(h);
+               return -EINVAL;
+       }
+@@ -239,9 +225,9 @@ int crypt_cipher_decrypt(struct crypt_cipher *ctx,
+ int crypt_cipher_destroy(struct crypt_cipher *ctx)
+ {
+-      if (ctx->tfmfd != -1)
++      if (ctx->tfmfd >= 0)
+               close(ctx->tfmfd);
+-      if (ctx->opfd != -1)
++      if (ctx->opfd >= 0)
+               close(ctx->opfd);
+       memset(ctx, 0, sizeof(*ctx));
+       free(ctx);
+diff --git a/lib/crypto_backend/crypto_kernel.c b/lib/crypto_backend/crypto_kernel.c
+index 45cff31..4fbc578 100644
+--- a/lib/crypto_backend/crypto_kernel.c
++++ b/lib/crypto_backend/crypto_kernel.c
+@@ -2,7 +2,7 @@
+  * Linux kernel userspace API crypto backend implementation
+  *
+  * Copyright (C) 2010-2012, Red Hat, Inc. All rights reserved.
+- * Copyright (C) 2010-2014, Milan Broz
++ * Copyright (C) 2010-2016, Milan Broz
+  *
+  * This file is free software; you can redistribute it and/or
+  * modify it under the terms of the GNU Lesser General Public
+@@ -68,8 +68,27 @@ struct crypt_hmac {
+       int hash_len;
+ };
+-/* Defined in crypt_kernel_ciphers.c */
+-extern int crypt_kernel_socket_init(struct sockaddr_alg *sa, int *tfmfd, int *opfd);
++static int crypt_kernel_socket_init(struct sockaddr_alg *sa, int *tfmfd, int *opfd)
++{
++      *tfmfd = socket(AF_ALG, SOCK_SEQPACKET, 0);
++      if (*tfmfd < 0)
++              return -ENOTSUP;
++
++      if (bind(*tfmfd, (struct sockaddr *)sa, sizeof(*sa)) < 0) {
++              close(*tfmfd);
++              *tfmfd = -1;
++              return -ENOENT;
++      }
++
++      *opfd = accept(*tfmfd, NULL, 0);
++      if (*opfd < 0) {
++              close(*tfmfd);
++              *tfmfd = -1;
++              return -EINVAL;
++      }
++
++      return 0;
++}
+ int crypt_backend_init(struct crypt_device *ctx)
+ {
+@@ -188,9 +207,9 @@ int crypt_hash_final(struct crypt_hash *ctx, char *buffer, size_t length)
+ int crypt_hash_destroy(struct crypt_hash *ctx)
+ {
+-      if (ctx->tfmfd != -1)
++      if (ctx->tfmfd >= 0)
+               close(ctx->tfmfd);
+-      if (ctx->opfd != -1)
++      if (ctx->opfd >= 0)
+               close(ctx->opfd);
+       memset(ctx, 0, sizeof(*ctx));
+       free(ctx);
+@@ -232,7 +251,7 @@ int crypt_hmac_init(struct crypt_hmac **ctx, const char *name,
+               return -EINVAL;
+       }
+-      if (setsockopt(h->tfmfd, SOL_ALG, ALG_SET_KEY, buffer, length) == -1) {
++      if (setsockopt(h->tfmfd, SOL_ALG, ALG_SET_KEY, buffer, length) < 0) {
+               crypt_hmac_destroy(h);
+               return -EINVAL;
+       }
+@@ -268,9 +287,9 @@ int crypt_hmac_final(struct crypt_hmac *ctx, char *buffer, size_t length)
+ int crypt_hmac_destroy(struct crypt_hmac *ctx)
+ {
+-      if (ctx->tfmfd != -1)
++      if (ctx->tfmfd >= 0)
+               close(ctx->tfmfd);
+-      if (ctx->opfd != -1)
++      if (ctx->opfd >= 0)
+               close(ctx->opfd);
+       memset(ctx, 0, sizeof(*ctx));
+       free(ctx);
+-- 
+2.7.1
+
diff --git a/0002-Fix-kernel-crypto-backend-to-set-key-before-accept-c.patch b/0002-Fix-kernel-crypto-backend-to-set-key-before-accept-c.patch
new file mode 100644 (file)
index 0000000..a896bee
--- /dev/null
@@ -0,0 +1,76 @@
+From 4dc88e8ffb6442ebba7ad8d14fa55691734371e0 Mon Sep 17 00:00:00 2001
+From: Milan Broz <gmazyland@gmail.com>
+Date: Mon, 4 Jan 2016 14:19:50 +0100
+Subject: [PATCH] Fix kernel crypto backend to set key before accept call even
+ for HMAC.
+
+---
+ lib/crypto_backend/crypto_kernel.c | 20 +++++++++++---------
+ 1 file changed, 11 insertions(+), 9 deletions(-)
+
+diff --git a/lib/crypto_backend/crypto_kernel.c b/lib/crypto_backend/crypto_kernel.c
+index 4fbc578..4d9d075 100644
+--- a/lib/crypto_backend/crypto_kernel.c
++++ b/lib/crypto_backend/crypto_kernel.c
+@@ -68,7 +68,8 @@ struct crypt_hmac {
+       int hash_len;
+ };
+-static int crypt_kernel_socket_init(struct sockaddr_alg *sa, int *tfmfd, int *opfd)
++static int crypt_kernel_socket_init(struct sockaddr_alg *sa, int *tfmfd, int *opfd,
++                                  const void *key, size_t key_length)
+ {
+       *tfmfd = socket(AF_ALG, SOCK_SEQPACKET, 0);
+       if (*tfmfd < 0)
+@@ -80,6 +81,12 @@ static int crypt_kernel_socket_init(struct sockaddr_alg *sa, int *tfmfd, int *op
+               return -ENOENT;
+       }
++      if (key && setsockopt(*tfmfd, SOL_ALG, ALG_SET_KEY, key, key_length) < 0) {
++              close(*tfmfd);
++              *tfmfd = -1;
++              return -EINVAL;
++      }
++
+       *opfd = accept(*tfmfd, NULL, 0);
+       if (*opfd < 0) {
+               close(*tfmfd);
+@@ -106,7 +113,7 @@ int crypt_backend_init(struct crypt_device *ctx)
+       if (uname(&uts) == -1 || strcmp(uts.sysname, "Linux"))
+               return -EINVAL;
+-      if (crypt_kernel_socket_init(&sa, &tfmfd, &opfd) < 0)
++      if (crypt_kernel_socket_init(&sa, &tfmfd, &opfd, NULL, 0) < 0)
+               return -EINVAL;
+       close(tfmfd);
+@@ -171,7 +178,7 @@ int crypt_hash_init(struct crypt_hash **ctx, const char *name)
+       strncpy((char *)sa.salg_name, ha->kernel_name, sizeof(sa.salg_name));
+-      if (crypt_kernel_socket_init(&sa, &h->tfmfd, &h->opfd) < 0) {
++      if (crypt_kernel_socket_init(&sa, &h->tfmfd, &h->opfd, NULL, 0) < 0) {
+               free(h);
+               return -EINVAL;
+       }
+@@ -246,16 +253,11 @@ int crypt_hmac_init(struct crypt_hmac **ctx, const char *name,
+       snprintf((char *)sa.salg_name, sizeof(sa.salg_name),
+                "hmac(%s)", ha->kernel_name);
+-      if (crypt_kernel_socket_init(&sa, &h->tfmfd, &h->opfd) < 0) {
++      if (crypt_kernel_socket_init(&sa, &h->tfmfd, &h->opfd, buffer, length) < 0) {
+               free(h);
+               return -EINVAL;
+       }
+-      if (setsockopt(h->tfmfd, SOL_ALG, ALG_SET_KEY, buffer, length) < 0) {
+-              crypt_hmac_destroy(h);
+-              return -EINVAL;
+-      }
+-
+       *ctx = h;
+       return 0;
+ }
+-- 
+2.7.1
+
index a55740e39e3f9773e86d344e66ba8df863b94087..93c41c8ffa2b6ab5105b77dbb6e3648234589e50 100644 (file)
@@ -11,12 +11,14 @@ Summary:    LUKS for dm-crypt implemented in cryptsetup
 Summary(pl.UTF-8):     LUKS dla dm-crypta zaimplementowany w cryptsetup
 Name:          cryptsetup
 Version:       1.7.0
-Release:       2
+Release:       3
 License:       GPL v2
 Group:         Base
 Source0:       https://www.kernel.org/pub/linux/utils/cryptsetup/v1.7/%{name}-%{version}.tar.xz
 # Source0-md5: 56c385fe87fc2b6873df4b7f89202d0f
 Patch0:                diet.patch
+Patch1:                0001-Set-skcipher-key-before-accept-call-in-kernel-crypto.patch
+Patch2:                0002-Fix-kernel-crypto-backend-to-set-key-before-accept-c.patch
 URL:           https://gitlab.com/cryptsetup/cryptsetup
 BuildRequires: autoconf >= 2.67
 BuildRequires: automake >= 1:1.12
@@ -154,6 +156,8 @@ cryptsetup - wersję statycznie zlinkowaną dla initrd.
 %prep
 %setup -q
 %{?with_diet:%patch0 -p1}
+%patch1 -p1
+%patch2 -p1
 
 %{__rm} po/stamp-po
 
This page took 0.133333 seconds and 4 git commands to generate.