]> git.pld-linux.org Git - packages/cryptsetup.git/commitdiff
- rel 2; dietlibc fixes auto/th/cryptsetup-luks-1_1_2-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 21 Jun 2010 09:32:38 +0000 (09:32 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cryptsetup.spec -> 1.48
    diet.patch -> 1.4

cryptsetup.spec
diet.patch [new file with mode: 0644]

index 831332ff8aa80468a0582ee5e4eedb2f6b363369..8a12bfb80623f02aeb16782bf6217183c9935a94 100644 (file)
@@ -8,7 +8,7 @@ Summary:        LUKS for dm-crypt implemented in cryptsetup
 Summary(pl.UTF-8):     LUKS dla dm-crypta zaimplementowany w cryptsetup
 Name:          cryptsetup-luks
 Version:       1.1.2
 Summary(pl.UTF-8):     LUKS dla dm-crypta zaimplementowany w cryptsetup
 Name:          cryptsetup-luks
 Version:       1.1.2
-Release:       1
+Release:       2
 License:       GPL v2
 Group:         Base
 Source0:       http://cryptsetup.googlecode.com/files/%{realname}-%{version}.tar.bz2
 License:       GPL v2
 Group:         Base
 Source0:       http://cryptsetup.googlecode.com/files/%{realname}-%{version}.tar.bz2
@@ -19,6 +19,7 @@ Source3:      %{name}-initramfs-root-local-top
 Source4:       %{name}-initramfs-passdev-hook
 Source5:       %{name}-initramfs-README
 Patch0:                %{name}-nostatic.patch
 Source4:       %{name}-initramfs-passdev-hook
 Source5:       %{name}-initramfs-README
 Patch0:                %{name}-nostatic.patch
+Patch1:                %{name}-diet.patch
 URL:           http://code.google.com/p/cryptsetup/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 URL:           http://code.google.com/p/cryptsetup/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
@@ -140,6 +141,7 @@ initramfs-tools.
 %prep
 %setup -q -n %{realname}-%{version}
 %patch0 -p1
 %prep
 %setup -q -n %{realname}-%{version}
 %patch0 -p1
+%patch1 -p1
 
 install %{SOURCE5} README.initramfs
 
 
 install %{SOURCE5} README.initramfs
 
@@ -170,7 +172,7 @@ install %{SOURCE5} README.initramfs
 %if %{with dietlibc}
 # we have to do it by hand cause libtool "know better" and forces
 # static libs from /usr/lib
 %if %{with dietlibc}
 # we have to do it by hand cause libtool "know better" and forces
 # static libs from /usr/lib
-diet %{__cc} %{rpmcflags} %{rpmldflags} -Os -I./lib -static \
+diet %{__cc} %{rpmcflags} %{rpmldflags} -Os -I. -I./lib -static \
        -o cryptsetup-initrd src/cryptsetup.c ./lib/.libs/libcryptsetup.a \
        -lpopt -lgcrypt -lgpg-error -ldevmapper -luuid -lcompat
 %else
        -o cryptsetup-initrd src/cryptsetup.c ./lib/.libs/libcryptsetup.a \
        -lpopt -lgcrypt -lgpg-error -ldevmapper -luuid -lcompat
 %else
diff --git a/diet.patch b/diet.patch
new file mode 100644 (file)
index 0000000..0d08bf4
--- /dev/null
@@ -0,0 +1,50 @@
+--- cryptsetup-1.1.2/luks/pbkdf.c~     2009-09-11 16:11:50.000000000 +0200
++++ cryptsetup-1.1.2/luks/pbkdf.c      2010-06-21 11:16:57.353421474 +0200
+@@ -174,7 +174,7 @@
+       if (gcry_md_setkey(prf, P, Plen))
+               goto out;
+-      for (i = 1; (uint) i <= l; i++) {
++      for (i = 1; (unsigned int) i <= l; i++) {
+               memset(T, 0, hLen);
+               for (u = 1; u <= c ; u++) {
+@@ -198,7 +198,7 @@
+                       memcpy(U, p, hLen);
+-                      for (k = 0; (uint) k < hLen; k++)
++                      for (k = 0; (unsigned int) k < hLen; k++)
+                               T[k] ^= U[k];
+                       if (perfcheck && __PBKDF2_performance) {
+@@ -210,7 +210,7 @@
+                               __PBKDF2_global_j++;
+               }
+-              memcpy(DK + (i - 1) * hLen, T, (uint) i == l ? r : hLen);
++              memcpy(DK + (i - 1) * hLen, T, (unsigned int) i == l ? r : hLen);
+       }
+       rc = 0;
+ out:
+--- cryptsetup-1.1.2/luks/keymanage.c.org      2010-06-21 11:25:41.010034880 +0200
++++ cryptsetup-1.1.2/luks/keymanage.c  2010-06-21 11:25:47.149697130 +0200
+@@ -20,6 +20,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
++#include <limits.h>
+ #include <linux/fs.h>
+ #include <netinet/in.h>
+ #include <fcntl.h>
+@@ -37,6 +38,10 @@
+ #include <uuid/uuid.h>
+ #include <../lib/internal.h>
++#ifndef UINT32_MAX
++#define UINT32_MAX UINT_MAX
++#endif
++
+ #define div_round_up(a,b) ({           \
+       typeof(a) __a = (a);          \
+       typeof(b) __b = (b);          \
This page took 0.134077 seconds and 4 git commands to generate.