]> git.pld-linux.org Git - packages/cryptsetup-luks.git/blob - cryptsetup-luks.spec
- conflicts also udev before the -core split
[packages/cryptsetup-luks.git] / cryptsetup-luks.spec
1 #
2 # Conditonal build:
3 %bcond_without  initrd  # don't build initrd version
4 #
5 %define realname        cryptsetup
6 Summary:        LUKS for dm-crypt implemented in cryptsetup
7 Summary(pl.UTF-8):      LUKS dla dm-crypta zaimplementowany w cryptsetup
8 Name:           cryptsetup-luks
9 Version:        1.0.6
10 Release:        7
11 License:        GPL v2
12 Group:          Base
13 Source0:        http://luks.endorphin.org/source/%{realname}-%{version}.tar.bz2
14 # Source0-md5:  00d452eb7a76e39f5749545d48934a10
15 Patch1:         %{name}-nostatic.patch
16 Patch2:         %{name}-udev.patch
17 URL:            http://luks.endorphin.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  device-mapper-devel
21 BuildRequires:  gettext-devel
22 BuildRequires:  libgcrypt-devel >= 1.1.42
23 BuildRequires:  libselinux-devel
24 BuildRequires:  libsepol-devel
25 BuildRequires:  libtool
26 BuildRequires:  libuuid-devel
27 BuildRequires:  popt-devel
28 %if %{with initrd}
29 BuildRequires:  device-mapper-static >= 1.02.07
30 BuildRequires:  libgcrypt-static >= 1.1.42
31 BuildRequires:  libgpg-error-static
32 BuildRequires:  libselinux-static
33 BuildRequires:  libsepol-static
34 BuildRequires:  libuuid-static
35 BuildRequires:  popt-static
36 %endif
37 Provides:       cryptsetup = %{version}
38 Obsoletes:      cryptsetup
39 Conflicts:      udev < 1:118-1
40 Conflicts:      udev-core < 1:115
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _sbindir        /sbin
44 %define         _noautoreqdep   libcryptsetup.so.0
45
46 %description
47 LUKS is the upcoming standard for Linux hard disk encryption. By
48 providing a standard on-disk-format, it does not only facilitate
49 compatibility among distributions, but also provide secure management
50 of multiple user passwords. In contrast to existing solution, LUKS
51 stores all setup necessary setup information in the partition header,
52 enabling the user to transport or migrate his data seamlessly.
53
54 This package contains implementation of LUKS for dm-crypt implemented
55 in cryptsetup.
56
57 %description -l pl.UTF-8
58 LUKS to nadchodzący standard linuksowego szyfrowania twardego dysku.
59 Dostarczając standardowy format danych na dysku nie tylko ułatwia
60 utrzymanie kompatybilności między dystrybucjami, ale także dostarcza
61 bezpieczne zarządzanie wieloma hasłami użytkowników. W przeciwieństwie
62 do istniejącego rozwiązania LUKS przechowuje wszystkie potrzebne
63 informacje o konfiguracji w nagłówku partycji, pozwalając
64 użytkownikowi przenosić lub migrować dane w sposób przezroczysty.
65
66 Ten pakiet zawiera implementację LUKS dla dm-crytpa zaimplementowaną w
67 cryptsetup.
68
69 %package devel
70 Summary:        Header files for cryptsetup library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cryptsetup
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       device-mapper-devel
75 Requires:       libgcrypt-devel >= 1.1.42
76 Obsoletes:      cryptsetup-devel
77
78 %description devel
79 Header files for cryptsetup library.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki cryptsetup.
83
84 %package static
85 Summary:        Static cryptsetup library
86 Summary(pl.UTF-8):      Statyczna biblioteka cryptsetup
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Obsoletes:      cryptsetup-static
90
91 %description static
92 Static version of cryptsetup library.
93
94 %description static -l pl.UTF-8
95 Statyczna wersja biblioteki cryptsetup.
96
97 %package initrd
98 Summary:        LUKS for dm-crypt implemented in cryptsetup - initrd version
99 Group:          Base
100 Requires:       udev-initrd >= 1:115
101
102 %description initrd
103 This package contains implementation of LUKS for dm-crypt implemented
104 in cryptsetup - staticaly linked for initrd.
105
106 %prep
107 %setup -q -n %{realname}-%{version}
108 %patch1 -p1
109 %patch2 -p1
110
111 %build
112 %{__gettextize}
113 %{__libtoolize}
114 %{__aclocal} -I m4
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118
119 %if %{with initrd}
120 %configure \
121         --disable-shared-library \
122         --enable-static \
123         --enable-static-cryptsetup \
124         --disable-nls
125 %{__make}
126 mv src/cryptsetup cryptsetup-initrd
127 %{__make} clean
128 %endif
129
130 %configure \
131         --enable-static
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 install -d $RPM_BUILD_ROOT/%{_lib}
141 mv -f $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so.* $RPM_BUILD_ROOT/%{_lib}
142 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcryptsetup.so.*.*.*) \
143         $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so
144
145 %if %{with initrd}
146 install cryptsetup-initrd $RPM_BUILD_ROOT%{_sbindir}
147 %endif
148
149 %find_lang %{realname}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %files -f %{realname}.lang
158 %defattr(644,root,root,755)
159 %doc AUTHORS ChangeLog TODO
160 %attr(755,root,root) %{_sbindir}/cryptsetup
161 %attr(755,root,root) /%{_lib}/libcryptsetup.so.*.*.*
162 %attr(755,root,root) %ghost /%{_lib}/libcryptsetup.so.0
163 %{_mandir}/man8/cryptsetup.8*
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libcryptsetup.so
168 %{_libdir}/libcryptsetup.la
169 %{_includedir}/libcryptsetup.h
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/libcryptsetup.a
174
175 %if %{with initrd}
176 %files initrd
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_sbindir}/cryptsetup-initrd
179 %endif
This page took 0.139838 seconds and 3 git commands to generate.