]> git.pld-linux.org Git - packages/cryptsetup-luks.git/blob - cryptsetup-luks.spec
- added BRs for dynamic version
[packages/cryptsetup-luks.git] / cryptsetup-luks.spec
1 #
2 # Conditonal build:
3 %bcond_with     static  # link cryptsetup statically
4 #
5 Summary:        LUKS for dm-crypt implemented in cryptsetup
6 Summary(pl):    LUKS dla dm-crypta zaimplementowany w cryptsetup
7 Name:           cryptsetup-luks
8 Version:        1.0.3
9 Release:        1
10 License:        GPL
11 Group:          Base
12 Source0:        http://luks.endorphin.org/source/%{name}-%{version}.tar.bz2
13 # Source0-md5:  e134b82b4706a28ba1d73b9176d5ad0c
14 Patch0:         %{name}-sepol.patch
15 Patch1:         %{name}-nostatic.patch
16 URL:            http://luks.endorphin.org/about
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  device-mapper-devel
20 BuildRequires:  gettext-devel
21 BuildRequires:  libgcrypt-devel >= 1.1.42
22 BuildRequires:  libselinux-devel
23 BuildRequires:  libsepol-devel
24 BuildRequires:  libuuid-devel
25 BuildRequires:  popt-devel
26 %if %{with static}
27 BuildRequires:  device-mapper-static >= 1.02.07
28 BuildRequires:  libgcrypt-static >= 1.1.42
29 BuildRequires:  libgpg-error-static
30 BuildRequires:  libselinux-static
31 BuildRequires:  libsepol-static
32 BuildRequires:  libuuid-static
33 BuildRequires:  popt-static
34 %endif
35 Provides:       cryptsetup = 0.2-1.pre1.8
36 Obsoletes:      cryptsetup
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _sbindir        /sbin
40
41 %description
42 LUKS is the upcoming standard for Linux hard disk encryption. By
43 providing a standard on-disk-format, it does not only facilitate
44 compatibility among distributions, but also provide secure management
45 of multiple user passwords. In contrast to existing solution, LUKS
46 stores all setup necessary setup information in the partition header,
47 enabling the user to transport or migrate his data seamlessly.
48
49 This package contains implementation of LUKS for dm-crypt implemented
50 in cryptsetup.
51
52 %description -l pl
53 LUKS to nadchodz±cy standard linuksowego szyfrowania twardego dysku.
54 Dostarczaj±c standardowy format danych na dysku nie tylko u³atwia
55 utrzymanie kompatybilno¶ci miêdzy dystrybucjami, ale tak¿e dostarcza
56 bezpieczne zarz±dzanie wieloma has³ami u¿ytkowników. W przeciwieñstwie
57 do istniej±cego rozwi±zania LUKS przechowuje wszystkie potrzebne
58 informacje o konfiguracji w nag³ówku partycji, pozwalaj±c
59 u¿ytkownikowi przenosiæ lub migrowaæ dane w sposób przezroczysty.
60
61 Ten pakiet zawiera implementacjê LUKS dla dm-crytpa zaimplementowan± w
62 cryptsetup.
63
64 %package devel
65 Summary:        Header files for cryptsetup library
66 Summary(pl):    Pliki nag³ówkowe biblioteki cryptsetup
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       device-mapper-devel
70 Requires:       libgcrypt-devel >= 1.1.42
71 Provides:       cryptsetup-devel
72 Obsoletes:      cryptsetup-devel
73
74 %description devel
75 Header files for cryptsetup library.
76
77 %description devel -l pl
78 Pliki nag³ówkowe biblioteki cryptsetup.
79
80 %package static
81 Summary:        Static cryptsetup library
82 Summary(pl):    Statyczna biblioteka cryptsetup
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85 Provides:       cryptsetup-static
86 Obsoletes:      cryptsetup-static
87
88 %description static
89 Static version of cryptsetup library.
90
91 %description static -l pl
92 Statyczna wersja biblioteki cryptsetup.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97 %patch1 -p1
98
99 %build
100 %{__gettextize}
101 %{__autoheader}
102 %{__aclocal} -I m4
103 %{__autoconf}
104 %{__automake}
105 %configure \
106         --enable-static \
107         %{?with_static:--enable-static-cryptsetup}
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 install -d $RPM_BUILD_ROOT/%{_lib}
117 mv -f $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so.*.*.* $RPM_BUILD_ROOT/%{_lib}
118 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo libcryptsetup.so.*.*.*) \
119         $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so
120
121 %find_lang %{name}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc ChangeLog
132 %attr(755,root,root) %{_sbindir}/cryptsetup
133 %attr(755,root,root) /%{_lib}/libcryptsetup.so.*.*.*
134 %{_mandir}/man8/*
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libcryptsetup.so
139 %{_libdir}/libcryptsetup.la
140 %{_includedir}/*.h
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libcryptsetup.a
This page took 0.051256 seconds and 3 git commands to generate.