]> git.pld-linux.org Git - packages/cryptsetup-luks.git/blob - cryptsetup-luks.spec
- added initramfs support files to package
[packages/cryptsetup-luks.git] / cryptsetup-luks.spec
1 #
2 # Conditonal build:
3 %bcond_without  initrd  # don't build initrd version
4 #
5 %define realname        cryptsetup
6 Summary:        LUKS for dm-crypt implemented in cryptsetup
7 Summary(pl.UTF-8):      LUKS dla dm-crypta zaimplementowany w cryptsetup
8 Name:           cryptsetup-luks
9 Version:        1.0.6
10 Release:        7
11 License:        GPL v2
12 Group:          Base
13 Source0:        http://luks.endorphin.org/source/%{realname}-%{version}.tar.bz2
14 # Source0-md5:  00d452eb7a76e39f5749545d48934a10
15 Source3:        %{name}-initramfs-root-conf
16 Source4:        %{name}-initramfs-root-hook
17 Source5:        %{name}-initramfs-root-local-top
18 Source1:        %{name}-initramfs-passdev-hook
19 Source2:        %{name}-initramfs-README
20 Patch1:         %{name}-nostatic.patch
21 Patch2:         %{name}-udev.patch
22 URL:            http://luks.endorphin.org/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  device-mapper-devel
26 BuildRequires:  gettext-devel
27 BuildRequires:  libgcrypt-devel >= 1.1.42
28 BuildRequires:  libselinux-devel
29 BuildRequires:  libsepol-devel
30 BuildRequires:  libtool
31 BuildRequires:  libuuid-devel
32 BuildRequires:  popt-devel
33 %if %{with initrd}
34 BuildRequires:  device-mapper-static >= 1.02.07
35 BuildRequires:  libgcrypt-static >= 1.1.42
36 BuildRequires:  libgpg-error-static
37 BuildRequires:  libselinux-static
38 BuildRequires:  libsepol-static
39 BuildRequires:  libuuid-static
40 BuildRequires:  popt-static
41 %endif
42 Provides:       cryptsetup = %{version}
43 Obsoletes:      cryptsetup
44 Conflicts:      udev < 1:118-1
45 Conflicts:      udev-core < 1:115
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _sbindir        /sbin
49 %define         _noautoreqdep   libcryptsetup.so.0
50
51 %description
52 LUKS is the upcoming standard for Linux hard disk encryption. By
53 providing a standard on-disk-format, it does not only facilitate
54 compatibility among distributions, but also provide secure management
55 of multiple user passwords. In contrast to existing solution, LUKS
56 stores all setup necessary setup information in the partition header,
57 enabling the user to transport or migrate his data seamlessly.
58
59 This package contains implementation of LUKS for dm-crypt implemented
60 in cryptsetup.
61
62 %description -l pl.UTF-8
63 LUKS to nadchodzący standard linuksowego szyfrowania twardego dysku.
64 Dostarczając standardowy format danych na dysku nie tylko ułatwia
65 utrzymanie kompatybilności między dystrybucjami, ale także dostarcza
66 bezpieczne zarządzanie wieloma hasłami użytkowników. W przeciwieństwie
67 do istniejącego rozwiązania LUKS przechowuje wszystkie potrzebne
68 informacje o konfiguracji w nagłówku partycji, pozwalając
69 użytkownikowi przenosić lub migrować dane w sposób przezroczysty.
70
71 Ten pakiet zawiera implementację LUKS dla dm-crytpa zaimplementowaną w
72 cryptsetup.
73
74 %package devel
75 Summary:        Header files for cryptsetup library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cryptsetup
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       device-mapper-devel
80 Requires:       libgcrypt-devel >= 1.1.42
81 Obsoletes:      cryptsetup-devel
82
83 %description devel
84 Header files for cryptsetup library.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki cryptsetup.
88
89 %package static
90 Summary:        Static cryptsetup library
91 Summary(pl.UTF-8):      Statyczna biblioteka cryptsetup
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94 Obsoletes:      cryptsetup-static
95
96 %description static
97 Static version of cryptsetup library.
98
99 %description static -l pl.UTF-8
100 Statyczna wersja biblioteki cryptsetup.
101
102 %package initrd
103 Summary:        LUKS for dm-crypt implemented in cryptsetup - initrd version
104 Group:          Base
105 Requires:       udev-initrd >= 1:115
106
107 %description initrd
108 This package contains implementation of LUKS for dm-crypt implemented
109 in cryptsetup - staticaly linked for initrd.
110
111 %prep
112 %setup -q -n %{realname}-%{version}
113 %patch1 -p1
114 %patch2 -p1
115
116 %build
117 %{__gettextize}
118 %{__libtoolize}
119 %{__aclocal} -I m4
120 %{__autoconf}
121 %{__autoheader}
122 %{__automake}
123
124 %if %{with initrd}
125 %configure \
126         --disable-shared-library \
127         --enable-static \
128         --enable-static-cryptsetup \
129         --disable-nls
130 %{__make}
131 mv src/cryptsetup cryptsetup-initrd
132 %{__make} clean
133 %endif
134
135 %configure \
136         --enable-static
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 install -d $RPM_BUILD_ROOT/%{_lib}
146 mv -f $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so.* $RPM_BUILD_ROOT/%{_lib}
147 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcryptsetup.so.*.*.*) \
148         $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so
149
150 %if %{with initrd}
151 install cryptsetup-initrd $RPM_BUILD_ROOT%{_sbindir}
152 %endif
153
154 %find_lang %{realname}
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post   -p /sbin/ldconfig
160 %postun -p /sbin/ldconfig
161
162 %files -f %{realname}.lang
163 %defattr(644,root,root,755)
164 %doc AUTHORS ChangeLog TODO
165 %attr(755,root,root) %{_sbindir}/cryptsetup
166 %attr(755,root,root) /%{_lib}/libcryptsetup.so.*.*.*
167 %attr(755,root,root) %ghost /%{_lib}/libcryptsetup.so.0
168 %{_mandir}/man8/cryptsetup.8*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libcryptsetup.so
173 %{_libdir}/libcryptsetup.la
174 %{_includedir}/libcryptsetup.h
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libcryptsetup.a
179
180 %if %{with initrd}
181 %files initrd
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_sbindir}/cryptsetup-initrd
184 %endif
This page took 0.095177 seconds and 3 git commands to generate.