]> git.pld-linux.org Git - packages/cryptopp.git/blobdiff - cryptopp.spec
- updated to 5.6.5 (fixes CVE-2016-3995)
[packages/cryptopp.git] / cryptopp.spec
index 15876d150ebacc4e6e79b16379a95af49204d6f4..807c1961410b076c0b722f79422ca52d724b2278 100644 (file)
@@ -1,22 +1,20 @@
 #
 # Conditional build:
-%bcond_without asm             # disable x86 assembly code
 %bcond_without tests           # build without tests
 
-%define                orig_ver        564
 Summary:       Cryptopp Library - a free C++ class library of cryptographic schemes
 Summary(pl.UTF-8):     Cryptopp - biblioteka klas C++ dostarczająca narzędzia do kryptografii
 Name:          cryptopp
-Version:       5.6.4
+Version:       5.6.5
+%define         f_ver  %(echo %{version} | tr -d .)
 Release:       1
 License:       Boost v1.0 (BSD-like)
 Group:         Libraries
-Source0:       http://downloads.sourceforge.net/cryptopp/%{name}%{orig_ver}.zip
-# Source0-md5: 4ee7e5cdd4a45a14756c169eaf2a77fc
+Source0:       http://downloads.sourceforge.net/cryptopp/%{name}%{f_ver}.zip
+# Source0-md5: 839aa27c70fa70037185ae7be8d8d24d
 Source1:       %{name}.pc
-Patch0:                %{name}-libdir.patch
+Patch0:                %{name}-opt.patch
 URL:           http://www.cryptopp.com/
-BuildRequires: cmake >= 2.8.5
 BuildRequires: libstdc++-devel
 BuildRequires: unzip
 Obsoletes:     cryptopp-progs
@@ -58,22 +56,21 @@ Statyczna biblioteka Cryptopp.
 %patch0 -p1
 
 %build
-install -d build
-cd build
-%cmake .. \
-       %{!?with_asm:-DDISABLE_ASM=ON}
-
-%{__make}
+CXXFLAGS="%{rpmcxxflags}" \
+%{__make} shared static %{?with_tests:cryptest.exe} \
+       CXX="%{__cxx}"
 
 %if %{with tests}
-ctest -V
+%{__make} test
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} -C build install \
-       DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       PREFIX=%{_prefix} \
+       LIBDIR=%{_libdir}
 
 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
 sed -e "
@@ -92,17 +89,21 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
+%triggerpostun -- cryptopp < 5.6.5
+rm -f %{_libdir}/libcryptopp.so.5.6
+/sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %doc License.txt Readme.txt
-%attr(755,root,root) %{_libdir}/libcryptopp.so.5.6
+%attr(755,root,root) %{_libdir}/libcryptopp.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libcryptopp.so.5.6
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libcryptopp.so
 %{_includedir}/cryptopp
 %{_pkgconfigdir}/cryptopp.pc
-%{_libdir}/cmake/cryptopp
 
 %files static
 %defattr(644,root,root,755)
This page took 0.103297 seconds and 4 git commands to generate.