]> git.pld-linux.org Git - packages/cryptopp.git/blob - cryptopp.spec
feb171b8ade451ed614585c77573a4b3e531084e
[packages/cryptopp.git] / cryptopp.spec
1 #
2 # Conditional build:
3 %bcond_without  asm             # disable x86 assembly code
4 %bcond_without  tests           # build without tests
5
6 %ifarch x32
7 %undefine       with_asm
8 %endif
9
10 %define         orig_ver        561
11 Summary:        Cryptopp Library - a free C++ class library of cryptographic schemes
12 Summary(pl.UTF-8):      Cryptopp - biblioteka klas C++ dostarczająca narzędzia do kryptografii
13 Name:           cryptopp
14 Version:        5.6.1
15 Release:        3
16 License:        BSD-like
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/cryptopp/%{name}%{orig_ver}.zip
19 # Source0-md5:  96cbeba0907562b077e26bcffb483828
20 Patch0:         %{name}-autotools.patch
21 Patch1:         cxx.patch
22 URL:            http://www.cryptopp.com/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool >= 2:1.5
27 BuildRequires:  unzip
28 Obsoletes:      cryptopp-progs
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Cryptopp Library is a free C++ class library of cryptographic schemes.
33
34 %description -l pl.UTF-8
35 Cryptopp jest biblioteką klas C++ dostarczającą narzędzia do
36 kryptografii.
37
38 %package devel
39 Summary:        Files for development of applications which will use Cryptopp
40 Summary(pl.UTF-8):      Pliki do tworzenia aplikacji używających Cryptopp
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Files for development of applications which will use Cryptopp.
46
47 %description devel -l pl.UTF-8
48 Pliki do tworzenia aplikacji używających Cryptopp.
49
50 %package static
51 Summary:        Static Cryptopp library
52 Summary(pl.UTF-8):      Statyczna biblioteka Cryptopp
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static Cryptopp library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka Cryptopp.
61
62 %prep
63 %setup -q -c
64 %patch0 -p1
65 %patch1 -p0
66
67 %build
68 %{__libtoolize}
69 %{__aclocal}
70 %{__autoconf}
71 %{__autoheader}
72 %{__automake}
73
74 %if %{without asm}
75 CFLAGS="%{rpmcflags} -DCRYPTOPP_DISABLE_X86ASM"
76 CXXFLAGS="%{rpmcxxflags} -DCRYPTOPP_DISABLE_X86ASM"
77 %endif
78 %configure
79 %{__make}
80
81 %if %{with tests}
82 ./cryptest v
83 %endif
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 %{__make} install \
88         INSTALL="install -p -c " \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %{__rm} $RPM_BUILD_ROOT%{_bindir}/cryptest
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc License.txt Readme.txt
102 %attr(755,root,root) %{_libdir}/libcryptopp.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libcryptopp.so.4
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libcryptopp.so
108 %{_libdir}/libcryptopp.la
109 %{_includedir}/cryptopp
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libcryptopp.a
This page took 0.07262 seconds and 3 git commands to generate.