]> git.pld-linux.org Git - packages/cryptopp.git/blame - cryptopp.spec
- disable asm code on x32
[packages/cryptopp.git] / cryptopp.spec
CommitLineData
72a0958d
JR
1#
2# Conditional build:
3%bcond_without asm # disable x86 assembly code
4#
5%ifarch x32
6%undefine with_asm
7%endif
8
472a31a8 9%define orig_ver 561
1e862315 10Summary: Cryptopp Library - a free C++ class library of cryptographic schemes
6081e9d5 11Summary(pl.UTF-8): Cryptopp - biblioteka klas C++ dostarczająca narzędzia do kryptografii
1e862315 12Name: cryptopp
472a31a8 13Version: 5.6.1
72a0958d 14Release: 3
4c7740b9 15License: BSD-like
1e862315 16Group: Libraries
4c7740b9 17Source0: http://downloads.sourceforge.net/cryptopp/%{name}%{orig_ver}.zip
472a31a8 18# Source0-md5: 96cbeba0907562b077e26bcffb483828
0114b496 19Patch0: %{name}-autotools.patch
472a31a8 20Patch1: cxx.patch
1e862315 21URL: http://www.cryptopp.com/
0114b496 22BuildRequires: autoconf
23BuildRequires: automake
1e862315 24BuildRequires: libstdc++-devel
4c7740b9 25BuildRequires: libtool >= 2:1.5
1e862315 26BuildRequires: unzip
98033b6e 27Obsoletes: cryptopp-progs
ff61087a 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Cryptopp Library is a free C++ class library of cryptographic schemes.
32
92858504 33%description -l pl.UTF-8
4c7740b9
JB
34Cryptopp jest biblioteką klas C++ dostarczającą narzędzia do
35kryptografii.
ff61087a 36
37%package devel
1e862315 38Summary: Files for development of applications which will use Cryptopp
e414df15 39Summary(pl.UTF-8): Pliki do tworzenia aplikacji używających Cryptopp
1e862315
JB
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
ff61087a 42
43%description devel
1e862315 44Files for development of applications which will use Cryptopp.
ff61087a 45
92858504
JR
46%description devel -l pl.UTF-8
47Pliki do tworzenia aplikacji używających Cryptopp.
ff61087a 48
1e862315
JB
49%package static
50Summary: Static Cryptopp library
e414df15 51Summary(pl.UTF-8): Statyczna biblioteka Cryptopp
1e862315
JB
52Group: Development/Libraries
53Requires: %{name}-devel = %{version}-%{release}
ff61087a 54
1e862315
JB
55%description static
56Static Cryptopp library.
ff61087a 57
92858504 58%description static -l pl.UTF-8
1e862315 59Statyczna biblioteka Cryptopp.
ff61087a 60
ff61087a 61%prep
1e862315 62%setup -q -c
0fcd268d 63%patch0 -p1
472a31a8 64%patch1 -p0
ff61087a 65
66%build
0114b496 67%{__libtoolize}
68%{__aclocal}
69%{__autoconf}
70%{__autoheader}
71%{__automake}
72
72a0958d
JR
73%if %{without asm}
74CFLAGS="%{rpmcflags} -DCRYPTOPP_DISABLE_X86ASM"
75CXXFLAGS="%{rpmcxxflags} -DCRYPTOPP_DISABLE_X86ASM"
76%endif
4c7740b9 77%configure
472a31a8 78
ff61087a 79%{__make}
80
472a31a8
PS
81./cryptest v
82
ff61087a 83%install
1e862315 84rm -rf $RPM_BUILD_ROOT
ff61087a 85
472a31a8
PS
86%{__make} install \
87 DESTDIR=$RPM_BUILD_ROOT
ff61087a 88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
1e862315
JB
92%post -p /sbin/ldconfig
93%postun -p /sbin/ldconfig
94
ff61087a 95%files
1e862315 96%defattr(644,root,root,755)
ff61087a 97%doc License.txt Readme.txt
1e862315 98%attr(755,root,root) %{_libdir}/libcryptopp.so.*.*.*
4c7740b9 99%attr(755,root,root) %ghost %{_libdir}/libcryptopp.so.4
ff61087a 100
101%files devel
1e862315 102%defattr(644,root,root,755)
6081e9d5 103%attr(755,root,root) %{_libdir}/libcryptopp.so
4c7740b9
JB
104%{_libdir}/libcryptopp.la
105%{_includedir}/cryptopp
1e862315
JB
106
107%files static
108%defattr(644,root,root,755)
109%{_libdir}/libcryptopp.a
This page took 0.119027 seconds and 4 git commands to generate.