]> git.pld-linux.org Git - packages/cryptix.git/blob - cryptix.spec
b9e7037714d1b16e9ac908aa7d6d543ac73bd85a
[packages/cryptix.git] / cryptix.spec
1 %define         snapshot        20001002
2
3 Summary:        Java crypto package
4 Summary(pl):    Pakiet kryptograficzny Javy
5 Name:           cryptix
6 Version:        3.2.0
7 Release:        1
8 License:        BSD-like
9 Group:          Development/Languages/Java
10 Source0:        http://www.cryptix.org/dist/%{name}32-%{snapshot}-r%{version}.zip
11 # Source0-md5:  7a3545ede3fff5c89eba601fea03791a
12 Source1:        %{name}.build.xml
13 URL:            http://www.cryptix.org
14 BuildRequires:  jakarta-ant >= 1.5
15 Requires:       jre >= 1.1
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _javalibdir     %{_datadir}/java
20
21 %description
22 Cryptix 3 is a cleanroom implementation of Sun's Java Cryptography
23 Extensions (JCE) version 1.1. In addition to that it contains the
24 Cryptix Provider which delivers a wide range of algorithms and support
25 for PGP 2.x. Cryptix 3 runs on both JDK 1.1 and JDK 1.2 (Java 2).
26
27 %description -l pl
28 Cryptix 3 to implementacja standardu JCE (Java Cryptography
29 Extensions) Suna w wersji 1.1. Pakiet dodatkowo zawiera Cryptix
30 Provider, dostarczaj±cy szeroki zakres algorytmów oraz wsparcie dla
31 PGP 2.x. Cryptix 3 dzia³a zarówno na JDK 1.1 jak i JDK 1.2 (Java 2).
32
33 %prep
34 %setup -q -c
35 cp %{SOURCE1} build.xml
36 find . -name "*.jar" -exec rm -f {} \;
37
38 %build
39 ant jar
40 ant javadoc
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{_javalibdir}
45 cp build/lib/%{name}.jar $RPM_BUILD_ROOT%{_javalibdir}
46 ln -sf %{name}.jar $RPM_BUILD_ROOT/%{_javalibdir}/%{name}-%{version}.jar
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc LICENCE.TXT README.TXT build/api
54 %{_javalibdir}/*.jar
This page took 0.093637 seconds and 3 git commands to generate.