]> git.pld-linux.org Git - packages/crosssparc-gcc.git/blob - crosssparc-gcc.spec
- md5.
[packages/crosssparc-gcc.git] / crosssparc-gcc.spec
1 Summary:        Cross SPARC GNU binary utility development utilities - gcc
2 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - SPARC gcc
3 Summary(fr):    Utilitaires de développement binaire de GNU - SPARC gcc
4 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla SPARC - gcc
5 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - SPARC gcc
6 Summary(tr):    GNU geliþtirme araçlarý - SPARC gcc
7 Name:           crosssparc-gcc
8 Version:        4.0.1
9 %define         _snap   20050514
10 Release:        0.%{_snap}.1
11 Epoch:          1
12 License:        GPL
13 Group:          Development/Languages
14 #Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
15 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/4.0-%{_snap}/gcc-4.0-%{_snap}.tar.bz2
16 # Source0-md5:  25e147473b14c4bb43cdc53299c3524c
17 Patch0:         gcc-pr21454.patch
18 URL:            http://gcc.gnu.org/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  bison
22 BuildRequires:  crosssparc-binutils
23 BuildRequires:  fileutils >= 4.1.41
24 BuildRequires:  flex
25 BuildRequires:  texinfo >= 4.1
26 Requires:       crosssparc-binutils
27 Requires:       gcc-dirs
28 ExcludeArch:    sparc sparcv9
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         target          sparc-pld-linux
32 %define         arch            %{_prefix}/%{target}
33 %define         gccarch         %{_libdir}/gcc/%{target}
34 %define         gcclib          %{gccarch}/%{version}
35
36 %define         _noautostrip    .*/libgc.*\\.a
37
38 %description
39 This package contains a cross-gcc which allows the creation of
40 binaries to be run on SPARC Linux on other machines.
41
42 %description -l de
43 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
44 anderem Rechner Code für SPARC Linux zu generieren.
45
46 %description -l pl
47 Ten pakiet zawiera skro¶ny gcc pozwalaj±cy na robienie na innych
48 maszynach binariów do uruchamiania na Linuksie SPARC.
49
50 %package c++
51 Summary:        C++ support for crosssparc-gcc
52 Summary(pl):    Obs³uga C++ dla crosssparc-gcc
53 Group:          Development/Languages
54 Requires:       %{name} = %{epoch}:%{version}-%{release}
55
56 %description c++
57 This package adds C++ support to the GNU Compiler Collection for SPARC.
58
59 %description c++ -l pl
60 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc dla SPARC.
61
62 %prep
63 #setup -q -n gcc-%{version}
64 %setup -q -n gcc-4.0-%{_snap}
65 %patch0 -p1
66
67 %build
68 cp -f /usr/share/automake/config.* .
69 rm -rf obj-%{target}
70 install -d obj-%{target}
71 cd obj-%{target}
72
73 CFLAGS="%{rpmcflags}" \
74 CXXFLAGS="%{rpmcflags}" \
75 TEXCONFIG=false \
76 ../configure \
77         --prefix=%{_prefix} \
78         --infodir=%{_infodir} \
79         --mandir=%{_mandir} \
80         --bindir=%{_bindir} \
81         --libdir=%{_libdir} \
82         --libexecdir=%{_libdir} \
83         --disable-shared \
84         --disable-threads \
85         --enable-languages="c,c++" \
86         --enable-c99 \
87         --enable-long-long \
88         --disable-nls \
89         --with-gnu-as \
90         --with-gnu-ld \
91         --with-mangler-in-ld \
92         --with-system-zlib \
93         --enable-multilib \
94         --without-headers \
95         --without-x \
96         --target=%{target} \
97         --host=%{_target_platform} \
98         --build=%{_target_platform}
99
100 %{__make} all-gcc
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} -C obj-%{target} install-gcc \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 install obj-%{target}/gcc/specs $RPM_BUILD_ROOT%{gcclib}
109
110 # don't want this here
111 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
112
113 # include/ contains install-tools/include/* and headers that were fixed up
114 # by fixincludes, we don't want former
115 gccdir=$RPM_BUILD_ROOT%{gcclib}
116 mkdir   $gccdir/tmp
117 # we have to save these however
118 mv -f   $gccdir/include/syslimits.h $gccdir/tmp
119 rm -rf  $gccdir/include
120 mv -f   $gccdir/tmp $gccdir/include
121 cp -f   $gccdir/install-tools/include/*.h $gccdir/include
122 # but we don't want anything more from install-tools
123 rm -rf  $gccdir/install-tools
124
125 %if 0%{!?debug:1}
126 %{target}-strip -g -R.note -R.comment $RPM_BUILD_ROOT%{gcclib}/libgcc.a
127 %{target}-strip -g -R.note -R.comment $RPM_BUILD_ROOT%{gcclib}/libgcov.a
128 %endif
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/%{target}-cpp
136 %attr(755,root,root) %{_bindir}/%{target}-gcc
137 %dir %{gccarch}
138 %dir %{gcclib}
139 %attr(755,root,root) %{gcclib}/cc1
140 %attr(755,root,root) %{gcclib}/collect2
141 %{gcclib}/crt*.o
142 %{gcclib}/libgcc.a
143 %{gcclib}/specs*
144 %dir %{gcclib}/include
145 %{gcclib}/include/*.h
146 %{_mandir}/man1/%{target}-cpp.1*
147 %{_mandir}/man1/%{target}-gcc.1*
148
149 %files c++
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/%{target}-g++
152 %attr(755,root,root) %{gcclib}/cc1plus
153 %{_mandir}/man1/%{target}-g++.1*
This page took 0.071661 seconds and 4 git commands to generate.