]> git.pld-linux.org Git - packages/crosssparc-gcc.git/blob - crosssparc-gcc.spec
- updated to 4.0.1-20050521.
[packages/crosssparc-gcc.git] / crosssparc-gcc.spec
1 Summary:        Cross SPARC GNU binary utility development utilities - gcc
2 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - SPARC gcc
3 Summary(fr):    Utilitaires de développement binaire de GNU - SPARC gcc
4 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla SPARC - gcc
5 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - SPARC gcc
6 Summary(tr):    GNU geliþtirme araçlarý - SPARC gcc
7 Name:           crosssparc-gcc
8 Version:        4.0.1
9 %define         _snap   20050521
10 Release:        0.%{_snap}.1
11 Epoch:          1
12 License:        GPL
13 Group:          Development/Languages
14 #Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
15 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/4.0-%{_snap}/gcc-4.0-%{_snap}.tar.bz2
16 # Source0-md5:  7f45e29a00590ce57a001a9294e8184e
17 URL:            http://gcc.gnu.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  bison
21 BuildRequires:  crosssparc-binutils
22 BuildRequires:  fileutils >= 4.1.41
23 BuildRequires:  flex
24 BuildRequires:  texinfo >= 4.1
25 Requires:       crosssparc-binutils
26 Requires:       gcc-dirs
27 ExcludeArch:    sparc sparcv9
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         target          sparc-pld-linux
31 %define         arch            %{_prefix}/%{target}
32 %define         gccarch         %{_libdir}/gcc/%{target}
33 %define         gcclib          %{gccarch}/%{version}
34
35 %define         _noautostrip    .*/libgc.*\\.a
36
37 %description
38 This package contains a cross-gcc which allows the creation of
39 binaries to be run on SPARC Linux on other machines.
40
41 %description -l de
42 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
43 anderem Rechner Code für SPARC Linux zu generieren.
44
45 %description -l pl
46 Ten pakiet zawiera skro¶ny gcc pozwalaj±cy na robienie na innych
47 maszynach binariów do uruchamiania na Linuksie SPARC.
48
49 %package c++
50 Summary:        C++ support for crosssparc-gcc
51 Summary(pl):    Obs³uga C++ dla crosssparc-gcc
52 Group:          Development/Languages
53 Requires:       %{name} = %{epoch}:%{version}-%{release}
54
55 %description c++
56 This package adds C++ support to the GNU Compiler Collection for SPARC.
57
58 %description c++ -l pl
59 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc dla SPARC.
60
61 %prep
62 #setup -q -n gcc-%{version}
63 %setup -q -n gcc-4.0-%{_snap}
64
65 %build
66 cp -f /usr/share/automake/config.* .
67 rm -rf obj-%{target}
68 install -d obj-%{target}
69 cd obj-%{target}
70
71 CFLAGS="%{rpmcflags}" \
72 CXXFLAGS="%{rpmcflags}" \
73 TEXCONFIG=false \
74 ../configure \
75         --prefix=%{_prefix} \
76         --infodir=%{_infodir} \
77         --mandir=%{_mandir} \
78         --bindir=%{_bindir} \
79         --libdir=%{_libdir} \
80         --libexecdir=%{_libdir} \
81         --disable-shared \
82         --disable-threads \
83         --enable-languages="c,c++" \
84         --enable-c99 \
85         --enable-long-long \
86         --disable-nls \
87         --with-gnu-as \
88         --with-gnu-ld \
89         --with-mangler-in-ld \
90         --with-system-zlib \
91         --enable-multilib \
92         --without-headers \
93         --without-x \
94         --target=%{target} \
95         --host=%{_target_platform} \
96         --build=%{_target_platform}
97
98 %{__make} all-gcc
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} -C obj-%{target} install-gcc \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 install obj-%{target}/gcc/specs $RPM_BUILD_ROOT%{gcclib}
107
108 # don't want this here
109 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
110
111 # include/ contains install-tools/include/* and headers that were fixed up
112 # by fixincludes, we don't want former
113 gccdir=$RPM_BUILD_ROOT%{gcclib}
114 mkdir   $gccdir/tmp
115 # we have to save these however
116 mv -f   $gccdir/include/syslimits.h $gccdir/tmp
117 rm -rf  $gccdir/include
118 mv -f   $gccdir/tmp $gccdir/include
119 cp -f   $gccdir/install-tools/include/*.h $gccdir/include
120 # but we don't want anything more from install-tools
121 rm -rf  $gccdir/install-tools
122
123 %if 0%{!?debug:1}
124 %{target}-strip -g -R.note -R.comment $RPM_BUILD_ROOT%{gcclib}/libgcc.a
125 %{target}-strip -g -R.note -R.comment $RPM_BUILD_ROOT%{gcclib}/libgcov.a
126 %endif
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_bindir}/%{target}-cpp
134 %attr(755,root,root) %{_bindir}/%{target}-gcc
135 %dir %{gccarch}
136 %dir %{gcclib}
137 %attr(755,root,root) %{gcclib}/cc1
138 %attr(755,root,root) %{gcclib}/collect2
139 %{gcclib}/crt*.o
140 %{gcclib}/libgcc.a
141 %{gcclib}/specs*
142 %dir %{gcclib}/include
143 %{gcclib}/include/*.h
144 %{_mandir}/man1/%{target}-cpp.1*
145 %{_mandir}/man1/%{target}-gcc.1*
146
147 %files c++
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_bindir}/%{target}-g++
150 %attr(755,root,root) %{gcclib}/cc1plus
151 %{_mandir}/man1/%{target}-g++.1*
This page took 0.035266 seconds and 4 git commands to generate.