]> git.pld-linux.org Git - packages/crossppc-gcc.git/commitdiff
- moved to head. GCC_4
authorPaweł Sikora <pluto@pld-linux.org>
Thu, 28 Apr 2005 22:44:12 +0000 (22:44 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gcc-ada-link.patch -> 1.3.4.6
    gcc-alpha-ada_fix.patch -> 1.3.2.2
    gcc-info.patch -> 1.7.2.6.2.4
    gcc-nodebug.patch -> 1.1.6.2
    gcc-nolocalefiles.patch -> 1.2.2.1.4.2

gcc-ada-link.patch [deleted file]
gcc-alpha-ada_fix.patch [deleted file]
gcc-info.patch [deleted file]
gcc-nodebug.patch [deleted file]
gcc-nolocalefiles.patch [deleted file]

diff --git a/gcc-ada-link.patch b/gcc-ada-link.patch
deleted file mode 100644 (file)
index 21fb2a6..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
---- gcc-4.0-20040919/gcc/ada/link.c.orig       2004-09-13 12:18:40.000000000 +0200
-+++ gcc-4.0-20040919/gcc/ada/link.c    2004-09-26 12:24:29.079704096 +0200
-@@ -164,9 +164,9 @@
- #elif defined (linux)
- const char *__gnat_object_file_option = "";
--const char *__gnat_run_path_option = "-Wl,-rpath,";
--char __gnat_shared_libgnat_default = STATIC;
--int __gnat_link_max = 8192;
-+const char *__gnat_run_path_option = "";
-+char __gnat_shared_libgnat_default = SHARED;
-+int __gnat_link_max = 131072;
- unsigned char __gnat_objlist_file_supported = 1;
- unsigned char __gnat_using_gnu_linker = 1;
- const char *__gnat_object_library_extension = ".a";
---- gcc-4.0-20040919/gcc/ada/Makefile.in.orig  2004-09-26 11:40:30.000000000 +0200
-+++ gcc-4.0-20040919/gcc/ada/Makefile.in       2004-09-26 12:29:16.913946640 +0200
-@@ -139,7 +139,7 @@
- objext = .o
- exeext =
- arext  = .a
--soext  = .so
-+soext  = .so.1
- shext  =
- hyphen = -
-@@ -1413,6 +1413,31 @@
-   LIBRARY_VERSION := $(LIB_VERSION)
- endif
-+ifeq ($(strip $(filter-out sparc% linux%,$(arch) $(osys))),)
-+  LIBGNAT_TARGET_PAIRS = \
-+  a-intnam.ads<a-intnam-linux.ads \
-+  s-inmaop.adb<s-inmaop-posix.adb \
-+  s-intman.adb<s-intman-posix.adb \
-+  s-osinte.adb<s-osinte-posix.adb \
-+  s-osinte.ads<s-osinte-linux.ads \
-+  s-osprim.adb<s-osprim-posix.adb \
-+  s-taprop.adb<s-taprop-linux.adb \
-+  s-taspri.ads<s-taspri-linux.ads \
-+  s-tpopsp.adb<s-tpopsp-posix-foreign.adb \
-+  s-parame.adb<s-parame-linux.adb \
-+  system.ads<system-linux-sparc.ads
-+
-+  TOOLS_TARGET_PAIRS =  \
-+    mlib-tgt.adb<mlib-tgt-linux.adb \
-+    indepsw.adb<indepsw-linux.adb
-+
-+  THREADSLIB = -lpthread
-+  GNATLIB_SHARED = gnatlib-shared-dual
-+  GMEM_LIB = gmemlib
-+  PREFIX_OBJS = $(PREFIX_REAL_OBJS)
-+  LIBRARY_VERSION := $(LIB_VERSION)
-+endif
-+
- ifeq ($(strip $(filter-out powerpc darwin%,$(arch) $(osys))),)
-   LIBGNAT_TARGET_PAIRS = \
-   a-intnam.ads<a-intnam-darwin.ads \
-@@ -1784,6 +1784,9 @@
- # is guaranteed to overflow the buffer.
- gnatlib: ../stamp-gnatlib1 ../stamp-gnatlib2
-+      $(RMDIR) save
-+      $(MKDIR) save
-+      $(MV) *.o save/
-       $(MAKE) -C rts CC="../../xgcc -B../../" \
-               INCLUDES="$(INCLUDES_FOR_SUBDIR) -I./../.." \
-                 CFLAGS="$(GNATLIBCFLAGS_FOR_C)" \
-@@ -1796,6 +1799,8 @@
-               srcdir=$(fsrcdir) \
-               -f ../Makefile \
-               $(GNATRTL_OBJS)
-+      $(MV) save/*.o .
-+      $(RMDIR) save
-       $(RM) rts/libgnat$(arext) rts/libgnarl$(arext)
-       $(AR) $(AR_FLAGS) rts/libgnat$(arext) \
-          $(addprefix rts/,$(GNATRTL_NONTASKING_OBJS) $(LIBGNAT_OBJS))
-@@ -1821,7 +1826,7 @@
-            THREAD_KIND="$(THREAD_KIND)" \
-              gnatlib
-       $(RM) rts/libgna*$(soext)
--      cd rts; ../../xgcc -B../../ -shared $(TARGET_LIBGCC2_CFLAGS) \
-+      cd rts; ../../xgcc -B../../ -shared -shared-libgcc $(TARGET_LIBGCC2_CFLAGS) \
-               -o libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
-               $(GNATRTL_NONTASKING_OBJS) $(LIBGNAT_OBJS) \
-               $(SO_OPTS)libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
-@@ -1830,7 +1835,8 @@
-               -o libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
-               $(GNATRTL_TASKING_OBJS) \
-               $(SO_OPTS)libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
--              $(THREADSLIB)
-+              $(THREADSLIB) \
-+              ./libgnat-$(LIBRARY_VERSION)$(soext)
-       cd rts; $(LN_S) libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
-               libgnat$(soext)
-       cd rts; $(LN_S) libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
diff --git a/gcc-alpha-ada_fix.patch b/gcc-alpha-ada_fix.patch
deleted file mode 100644 (file)
index 976a2cd..0000000
+++ /dev/null
@@ -1,127 +0,0 @@
---- gcc/gcc/ada/Makefile.in~   2005-02-21 18:18:29.000000000 +0000
-+++ gcc/gcc/ada/Makefile.in    2005-02-25 00:21:36.000000000 +0000
-@@ -1602,67 +1602,67 @@
-            ../../vxaddr2line$(exeext)
- ../../gnatchop$(exeext): ../stamp-tools
--      $(GNATMAKE) -c $(ADA_INCLUDES) gnatchop --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c $(ADA_INCLUDES) gnatchop.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) gnatchop 
-       $(GNATLINK) -v gnatchop -o $@ --GCC=$(GCC_LINK) $(TOOLS_LIBS)
- ../../gnat$(exeext): ../stamp-tools
--      $(GNATMAKE) -c $(ADA_INCLUDES) gnatcmd --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c $(ADA_INCLUDES) gnatcmd.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) gnatcmd 
-       $(GNATLINK) -v gnatcmd -o $@ --GCC=$(GCC_LINK) $(TOOLS_LIBS)
- ../../gnatkr$(exeext): ../stamp-tools
--      $(GNATMAKE) -c $(ADA_INCLUDES) gnatkr --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c $(ADA_INCLUDES) gnatkr.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) gnatkr 
-       $(GNATLINK) -v gnatkr -o $@ --GCC=$(GCC_LINK) $(TOOLS_LIBS)
- ../../gnatls$(exeext): ../stamp-tools
--      $(GNATMAKE) -c $(ADA_INCLUDES) gnatls --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c $(ADA_INCLUDES) gnatls.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) gnatls 
-       $(GNATLINK) -v gnatls -o $@ --GCC=$(GCC_LINK) $(TOOLS_LIBS)
- ../../gnatname$(exeext): ../stamp-tools
--      $(GNATMAKE) -c $(ADA_INCLUDES) gnatname --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c $(ADA_INCLUDES) gnatname.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) gnatname 
-       $(GNATLINK) -v gnatname -o $@ --GCC=$(GCC_LINK) $(TOOLS_LIBS)
- ../../gprmake$(exeext): ../stamp-tools
--      $(GNATMAKE) -c $(ADA_INCLUDES) gprmake --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c $(ADA_INCLUDES) gprmake.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) gprmake
-       $(GNATLINK) -v gprmake -o $@ --GCC=$(GCC_LINK) $(TOOLS_LIBS)
- ../../gnatprep$(exeext): ../stamp-tools
--      $(GNATMAKE) -c $(ADA_INCLUDES) gnatprep --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c $(ADA_INCLUDES) gnatprep.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) gnatprep 
-       $(GNATLINK) -v gnatprep -o $@ --GCC=$(GCC_LINK) $(TOOLS_LIBS)
- ../../gnatxref$(exeext): ../stamp-tools
--      $(GNATMAKE) -c $(ADA_INCLUDES) gnatxref --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c $(ADA_INCLUDES) gnatxref.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) gnatxref 
-       $(GNATLINK) -v gnatxref -o $@ --GCC=$(GCC_LINK) $(TOOLS_LIBS)
- ../../gnatfind$(exeext): ../stamp-tools
--      $(GNATMAKE) -c $(ADA_INCLUDES) gnatfind --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c $(ADA_INCLUDES) gnatfind.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) gnatfind 
-       $(GNATLINK) -v gnatfind -o $@ --GCC=$(GCC_LINK) $(TOOLS_LIBS)
- ../../gnatclean$(exeext): ../stamp-tools
--      $(GNATMAKE) -c $(ADA_INCLUDES) gnatclean --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c $(ADA_INCLUDES) gnatclean.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) gnatclean
-       $(GNATLINK) -v gnatclean -o $@ --GCC=$(GCC_LINK) $(TOOLS_LIBS)
- ../../gnatsym$(exeext): ../stamp-tools
--      $(GNATMAKE) -c $(ADA_INCLUDES) gnatsym --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c $(ADA_INCLUDES) gnatsym.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) gnatsym
-       $(GNATLINK) -v gnatsym -o $@ --GCC=$(GCC_LINK) $(TOOLS_LIBS)
- ../../gnatdll$(exeext): ../stamp-tools
--      $(GNATMAKE) -c $(ADA_INCLUDES) gnatdll --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c $(ADA_INCLUDES) gnatdll.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) $(GNATBIND_FLAGS) gnatdll
-       $(GNATLINK) -v gnatdll -o $@ --GCC=$(GCC_LINK) $(TOOLS_LIBS)
- ../../vxaddr2line$(exeext): ../stamp-tools
--      $(GNATMAKE) -c  $(ADA_INCLUDES) vxaddr2line --GCC="$(CC) $(ALL_ADAFLAGS)"
-+      $(GNATMAKE) -c  $(ADA_INCLUDES) vxaddr2line.adb --GCC="$(CC) $(ALL_ADAFLAGS)"
-       $(GNATBIND) $(ADA_INCLUDES) $(GNATBIND_FLAGS) vxaddr2line 
-       $(GNATLINK) -v vxaddr2line -o $@ --GCC=$(GCC_LINK) $(CLIB)
---- gcc/gcc/ada/Make-lang.in~  2005-03-02 18:52:34.000000000 +0000
-+++ gcc/gcc/ada/Make-lang.in   2005-03-02 19:07:26.000000000 +0000
-@@ -367,7 +367,7 @@
- ada/doctools/xgnatugn$(build_exeext): ada/xgnatugn.adb
-       -$(MKDIR) ada/doctools
-       $(CP) $^ ada/doctools
--      cd ada/doctools && gnatmake -q xgnatugn -a0../rts
-+      cd ada/doctools && gnatmake -q xgnatugn.adb -a0../rts
- # Note that gnat_ugn_unw.texi does not depend on xgnatugn 
- # being built so we can distribute a pregenerated gnat_ugn_unw.info
-@@ -880,27 +880,27 @@
- ada/treeprs.ads : ada/treeprs.adt ada/sinfo.ads ada/xtreeprs.adb
-       -$(MKDIR) ada/bldtools/treeprs
-       $(CP) $^ ada/bldtools/treeprs
--      (cd ada/bldtools/treeprs; gnatmake -q xtreeprs ; ./xtreeprs ../../treeprs.ads )
-+      (cd ada/bldtools/treeprs; gnatmake -q xtreeprs.adb ; ./xtreeprs ../../treeprs.ads )
- ada/einfo.h : ada/einfo.ads ada/einfo.adb ada/xeinfo.adb
-       -$(MKDIR) ada/bldtools/einfo
-       $(CP) $^ ada/bldtools/einfo
--      (cd ada/bldtools/einfo; gnatmake -q xeinfo ; ./xeinfo ../../einfo.h )
-+      (cd ada/bldtools/einfo; gnatmake -q xeinfo.adb ; ./xeinfo ../../einfo.h )
- ada/sinfo.h : ada/sinfo.ads ada/xsinfo.adb
-       -$(MKDIR) ada/bldtools/sinfo
-       $(CP) $^ ada/bldtools/sinfo
--      (cd ada/bldtools/sinfo; gnatmake -q xsinfo ; ./xsinfo ../../sinfo.h )
-+      (cd ada/bldtools/sinfo; gnatmake -q xsinfo.adb ; ./xsinfo ../../sinfo.h )
- ada/nmake.adb : ada/sinfo.ads ada/nmake.adt ada/xnmake.adb
-       -$(MKDIR) ada/bldtools/nmake_b
-       $(CP) $^ ada/bldtools/nmake_b
--      (cd ada/bldtools/nmake_b; gnatmake -q xnmake ; ./xnmake -b ../../nmake.adb )
-+      (cd ada/bldtools/nmake_b; gnatmake -q xnmake.adb ; ./xnmake -b ../../nmake.adb )
- ada/nmake.ads :  ada/sinfo.ads ada/nmake.adt ada/xnmake.adb ada/nmake.adb
-       -$(MKDIR) ada/bldtools/nmake_s
-       $(CP) $^ ada/bldtools/nmake_s
--      (cd ada/bldtools/nmake_s; gnatmake -q xnmake ; ./xnmake -s ../../nmake.ads )
-+      (cd ada/bldtools/nmake_s; gnatmake -q xnmake.adb ; ./xnmake -s ../../nmake.ads )
- update-sources : ada/treeprs.ads ada/einfo.h ada/sinfo.h ada/nmake.adb \
-       ada/nmake.ads
diff --git a/gcc-info.patch b/gcc-info.patch
deleted file mode 100644 (file)
index fd3fb09..0000000
+++ /dev/null
@@ -1,251 +0,0 @@
---- gcc-4.0-20040919.orig/gcc/doc/cpp.texi     2004-09-17 10:22:36.000000000 +0200
-+++ gcc-4.0-20040919/gcc/doc/cpp.texi  2004-09-26 10:58:58.166721432 +0200
-@@ -52,9 +52,9 @@
- @set cppmanual
- @ifinfo
--@dircategory Programming
-+@dircategory Programming Languages
- @direntry
--* Cpp: (cpp).                The GNU C preprocessor.
-+* Cpp: (cpp).                         The GNU C preprocessor.
- @end direntry
- @end ifinfo
---- gcc-4.0-20040919.orig/gcc/doc/cppinternals.texi    2004-07-03 01:57:11.000000000 +0200
-+++ gcc-4.0-20040919/gcc/doc/cppinternals.texi 2004-09-26 10:58:58.208715048 +0200
-@@ -3,9 +3,9 @@
- @settitle The GNU C Preprocessor Internals
- @ifinfo
--@dircategory Programming
-+@dircategory Programming Languages
- @direntry
--* Cpplib: (cppinternals).      Cpplib internals.
-+* Cpplib: (cppinternals).                     Cpplib internals.
- @end direntry
- @end ifinfo
---- gcc-4.0-20040919.orig/gcc/doc/gcc.texi     2004-07-22 22:12:20.000000000 +0200
-+++ gcc-4.0-20040919/gcc/doc/gcc.texi  2004-09-26 10:58:58.218713528 +0200
-@@ -62,9 +62,9 @@
-      funds for GNU development.
- @end copying
- @ifnottex
--@dircategory Programming
-+@dircategory Programming Languages:
- @direntry
--* gcc: (gcc).                  The GNU Compiler Collection.
-+* gcc: (gcc).                         The GNU Compiler Collection
- @end direntry
- This file documents the use of the GNU compilers.
- @sp 1
---- gcc-4.0-20040919.orig/gcc/doc/gccint.texi  2004-05-24 00:54:29.000000000 +0200
-+++ gcc-4.0-20040919/gcc/doc/gccint.texi       2004-09-26 10:58:58.222712920 +0200
-@@ -46,9 +46,9 @@
-      funds for GNU development.
- @end copying
- @ifnottex
--@dircategory Programming
-+@dircategory Programming Languages:
- @direntry
--* gccint: (gccint).            Internals of the GNU Compiler Collection.
-+* gccint: (gccint).                   Internals of the GNU Compiler Collection
- @end direntry
- This file documents the internals of the GNU compilers.
- @sp 1
---- gcc-4.0-20040919.orig/gcc/ada/gnat-style.texi      2004-09-01 13:51:52.000000000 +0200
-+++ gcc-4.0-20040919/gcc/ada/gnat-style.texi   2004-09-26 10:58:58.342694680 +0200
-@@ -28,9 +28,9 @@
- @setchapternewpage odd
--@dircategory Programming
-+@dircategory Programming Languages
- @direntry
--* gnat-style: (gnat-style).      GNAT Coding Style
-+* gnat-style: (gnat-style).           GNAT Coding Style
- @end direntry
- @macro syntax{element}
---- gcc-4.0-20040919.orig/gcc/ada/gnat_ugn.texi        2004-09-13 12:18:41.000000000 +0200
-+++ gcc-4.0-20040919/gcc/ada/gnat_ugn.texi     2004-09-26 10:58:58.509669296 +0200
-@@ -124,6 +124,11 @@
- ``GNU Free Documentation License''.
- @end copying
-+@dircategory Programming Languages:
-+@direntry
-+* gnat_ug: (gnat_ug).                   GNAT User's Guide
-+@end direntry
-+
- @titlepage
- @title @value{EDITION} User's Guide
---- gcc-4.0-20040919.orig/gcc/fortran/gfortran.texi    2004-09-16 15:13:39.000000000 +0200
-+++ gcc-4.0-20040919/gcc/fortran/gfortran.texi 2004-09-26 11:05:50.258074024 +0200
-@@ -62,9 +62,9 @@
- @end copying
- @ifinfo
--@dircategory Programming
-+@dircategory Programming Languages:
- @direntry
--* gfortran: (gfortran).                  The GNU Fortran 95 Compiler.
-+* gfortran: (gfortran).                       The GNU Fortran 95 Compiler.
- @end direntry
- This file documents the use and the internals of
- the GNU Fortran 95 compiler, (@command{gfortran}).
---- gcc-4.0-20050102/gcc/java/gcj.texi.orig    2004-12-06 18:59:57.000000000 +0100
-+++ gcc-4.0-20050102/gcc/java/gcj.texi 2005-01-09 22:17:46.968983608 +0100
-@@ -50,28 +50,21 @@
- @ifinfo
- @format
--@dircategory Programming
-+@dircategory Programming Languages:
- @direntry
--* Gcj: (gcj).               Ahead-of-time compiler for the Java language
-+* Gcj: (gcj).                         Ahead-of-time compiler for the Java language
- @end direntry
--@dircategory Individual utilities
-+@dircategory Programming tools:
- @direntry
--* gcjh: (gcj)Invoking gcjh.
--                            Generate header files from Java class files
--* jv-scan: (gcj)Invoking jv-scan.
--                            Print information about Java source files
--* jcf-dump: (gcj)Invoking jcf-dump.
--                            Print information about Java class files
--* gij: (gcj)Invoking gij.   GNU interpreter for Java bytecode
--* gcj-dbtool: (gcj)Invoking gcj-dbtool.
--                            Tool for manipulating class file databases.
--* jv-convert: (gcj)Invoking jv-convert.
--                            Convert file from one encoding to another
--* grmic: (gcj)Invoking grmic.
--                            Generate stubs for Remote Method Invocation.
--* grmiregistry: (gcj)Invoking grmiregistry.
--                            The remote object registry.
-+* gcjh: (gcj)gcjh.                    Generate header files from Java class files
-+* jv-scan: (gcj)jv-scan.              Print information about Java source files
-+* jcf-dump: (gcj)jcf-dump.            Print information about Java class files
-+* gij: (gcj)gij.                      GNU interpreter for Java bytecode
-+* jv-convert: (gcj)jv-convert.                Convert file from one encoding to another
-+* gcj-dbtool: (gcj)gcj-dbtool.                Db tool.
-+* grmic: (gcj)grmic.                  Generate stubs for Remote Method Invocation.
-+* grmiregistry: (gcj)grmiregistry.    The remote object registry.
- @end direntry
- @end format
-@@ -105,19 +98,19 @@
- @file{.class} files.
- @menu
--* Copying::            The GNU General Public License
-+* Copying::           The GNU General Public License
- * GNU Free Documentation License::
-                       How you can share and copy this manual
--* Invoking gcj::      Compiler options supported by @command{gcj}
-+* gcj::                       Compiler options supported by @command{gcj}
- * Compatibility::     Compatibility between gcj and other tools for Java
--* Invoking gcjh::       Generate header files from class files
--* Invoking jv-scan::    Print information about source files
--* Invoking jcf-dump::   Print information about class files
--* Invoking gij::      Interpreting Java bytecodes
--* Invoking gcj-dbtool:: Tool for manipulating class file databases.
--* Invoking jv-convert:: Converting from one encoding to another
--* Invoking grmic::      Generate stubs for Remote Method Invocation.
--* Invoking grmiregistry:: The remote object registry.
-+* gcjh::              Generate header files from class files
-+* jv-scan::           Print information about source files
-+* jcf-dump::          Print information about class files
-+* gij::                       Interpreting Java bytecodes
-+* jv-convert::                Converting from one encoding to another
-+* gcj-dbtool::                Db tool.
-+* grmic::             Generate stubs for Remote Method Invocation.
-+* grmiregistry::      The remote object registry.
- * About CNI::           Description of the Compiled Native Interface
- * System properties::   Modifying runtime behavior of the libgcj library
- * Resources::         Where to look for more information
-@@ -129,7 +122,7 @@
- @include fdl.texi
--@node Invoking gcj
-+@node gcj
- @chapter Invoking gcj
- @c man title gcj Ahead-of-time compiler for the Java language
-@@ -656,7 +649,7 @@
- @end itemize
--@node Invoking gcjh
-+@node gcjh
- @chapter Invoking gcjh
- @c man title gcjh generate header files from Java class files
-@@ -757,7 +750,7 @@
- @c man end
--@node Invoking jv-scan
-+@node jv-scan
- @chapter Invoking jv-scan
- @c man title jv-scan print information about Java source file
-@@ -820,7 +813,7 @@
- @c man end
--@node Invoking jcf-dump
-+@node jcf-dump
- @chapter Invoking jcf-dump
- @c man title jcf-dump print information about Java class files
-@@ -880,7 +873,7 @@
- @c man end
--@node Invoking gij
-+@node gij
- @chapter Invoking gij
- @c man title gij GNU interpreter for Java bytecode
-@@ -981,7 +974,7 @@
- @c man end
--@node Invoking gcj-dbtool
-+@node gcj-dbtool
- @chapter Invoking gcj-dbtool.
- @c man title gcj-dbtool Manipulate class file mapping databases for libgcj
-@@ -1050,7 +1043,7 @@
- @c man end
--@node Invoking jv-convert
-+@node jv-convert
- @chapter Invoking jv-convert
- @c man title jv-convert Convert file from one encoding to another
-@@ -1109,7 +1102,7 @@
- @c man end
--@node Invoking grmic
-+@node grmic
- @chapter Invoking grmic
- @c man title grmic Generate stubs for Remote Method Invocation
-@@ -1188,7 +1181,7 @@
- @c man end
--@node Invoking grmiregistry
-+@node grmiregistry
- @chapter Invoking grmiregistry
- @c man title grmiregistry Remote object registry
diff --git a/gcc-nodebug.patch b/gcc-nodebug.patch
deleted file mode 100644 (file)
index 759e911..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
---- gcc-4.0-20040919/gcc/Makefile.in.orig      2004-09-18 03:07:21.000000000 +0200
-+++ gcc-4.0-20040919/gcc/Makefile.in   2004-09-26 11:38:24.071049304 +0200
-@@ -141,10 +141,10 @@
- # TCFLAGS is used for compilations with the GCC just built.
- XCFLAGS =
- TCFLAGS =
--CFLAGS = -g
--STAGE1_CFLAGS = -g @stage1_cflags@
-+CFLAGS =
-+STAGE1_CFLAGS = @stage1_cflags@
- STAGE1_CHECKING = -DENABLE_CHECKING -DENABLE_ASSERT_CHECKING
--BOOT_CFLAGS = -g -O2
-+BOOT_CFLAGS = -O2
- # Flags to determine code coverage. When coverage is disabled, this will
- # contain the optimization flags, as you normally want code coverage
-@@ -511,7 +511,7 @@
- # Options to use when compiling libgcc2.a.
- #
--LIBGCC2_DEBUG_CFLAGS = -g
-+LIBGCC2_DEBUG_CFLAGS =
- LIBGCC2_CFLAGS = -O2 $(LIBGCC2_INCLUDES) $(GCC_CFLAGS) $(TARGET_LIBGCC2_CFLAGS) $(LIBGCC2_DEBUG_CFLAGS) $(GTHREAD_FLAGS) -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED @inhibit_libc@
- # Additional options to use when compiling libgcc2.a.
---- gcc-4.0-20040919/gcc/ada/Makefile.in.orig  2004-09-13 12:18:40.000000000 +0200
-+++ gcc-4.0-20040919/gcc/ada/Makefile.in       2004-09-26 11:40:30.070894416 +0200
-@@ -73,7 +73,7 @@
- # to the stage2 and stage3 compilations
- # XCFLAGS is used for most compilations but not when using the GCC just built.
- XCFLAGS =
--CFLAGS = -g
-+CFLAGS =
- BOOT_CFLAGS = -O $(CFLAGS)
- # These exists to be overridden by the x-* and t-* files, respectively.
- X_CFLAGS =
-@@ -118,9 +118,9 @@
- ADA_CFLAGS =
- ADAFLAGS = -W -Wall -gnatpg -gnata
- SOME_ADAFLAGS =-gnata
--FORCE_DEBUG_ADAFLAGS = -g
-+FORCE_DEBUG_ADAFLAGS =
- GNATLIBFLAGS = -gnatpg -nostdinc
--GNATLIBCFLAGS = -g -O2
-+GNATLIBCFLAGS = -O2
- GNATLIBCFLAGS_FOR_C = $(GNATLIBCFLAGS) $(TARGET_LIBGCC2_CFLAGS) -fexceptions \
-       -DIN_RTS
- ALL_ADA_CFLAGS = $(X_ADA_CFLAGS) $(T_ADA_CFLAGS) $(ADA_CFLAGS)
---- gcc-4.0-20040919/libffi/Makefile.am.orig   2004-08-30 17:42:59.000000000 +0200
-+++ gcc-4.0-20040919/libffi/Makefile.am        2004-09-26 11:44:10.789340112 +0200
-@@ -138,7 +138,7 @@
- libffi_convenience_la_SOURCES = $(libffi_la_SOURCES)
- nodist_libffi_convenience_la_SOURCES = $(nodist_libffi_la_SOURCES)
--AM_CFLAGS = -Wall -g -fexceptions
-+AM_CFLAGS = -Wall -fexceptions
- libffi_la_LDFLAGS = -version-info `grep -v '^\#' $(srcdir)/libtool-version`
---- gcc-4.0-20040919/libffi/Makefile.in.orig   2004-09-19 19:47:04.000000000 +0200
-+++ gcc-4.0-20040919/libffi/Makefile.in        2004-09-26 11:44:17.253357432 +0200
-@@ -385,7 +385,7 @@
- nodist_libffi_la_SOURCES = $(am__append_1) $(am__append_2) $(am__append_3) $(am__append_4) $(am__append_5) $(am__append_6) $(am__append_7) $(am__append_8) $(am__append_9) $(am__append_10) $(am__append_11) $(am__append_12) $(am__append_13) $(am__append_14) $(am__append_15) $(am__append_16) $(am__append_17) $(am__append_18)
- libffi_convenience_la_SOURCES = $(libffi_la_SOURCES)
- nodist_libffi_convenience_la_SOURCES = $(nodist_libffi_la_SOURCES)
--AM_CFLAGS = -Wall -g -fexceptions
-+AM_CFLAGS = -Wall -fexceptions
- libffi_la_LDFLAGS = -version-info `grep -v '^\#' $(srcdir)/libtool-version`
- AM_CPPFLAGS = -I. -I$(top_srcdir)/include -Iinclude -I$(top_srcdir)/src
- AM_CCASFLAGS = $(AM_CPPFLAGS)
---- gcc-4.0-20040919/libjava/Makefile.am.orig  2004-09-10 10:22:58.000000000 +0200
-+++ gcc-4.0-20040919/libjava/Makefile.am       2004-09-26 11:46:24.041082768 +0200
-@@ -179,7 +179,7 @@
- ## Extra CFLAGS used for JNI C sources shared with GNU Classpath.
- PEDANTIC_CFLAGS = -ansi -pedantic -Wall -Wno-long-long
--JCFLAGS = -g
-+JCFLAGS =
- JC1FLAGS = @LIBGCJ_JAVAFLAGS@ $(GCJFLAGS)
- LIBFFIINCS = @LIBFFIINCS@
---- gcc-4.0-20040919/libjava/Makefile.in.orig  2004-09-19 19:47:04.000000000 +0200
-+++ gcc-4.0-20040919/libjava/Makefile.in       2004-09-26 11:47:02.431246576 +0200
-@@ -4167,7 +4167,7 @@
- @USING_GCC_FALSE@AM_CFLAGS = @LIBGCJ_CFLAGS@
- @USING_GCC_TRUE@AM_CFLAGS = @LIBGCJ_CFLAGS@ $(WARNINGS)
- PEDANTIC_CFLAGS = -ansi -pedantic -Wall -Wno-long-long
--JCFLAGS = -g
-+JCFLAGS =
- JC1FLAGS = @LIBGCJ_JAVAFLAGS@ $(GCJFLAGS)
- AM_CPPFLAGS = -I$(top_srcdir) -Iinclude -I$(top_srcdir)/include \
-       $(GCINCS) $(THREADINCS) $(INCLTDL) \
diff --git a/gcc-nolocalefiles.patch b/gcc-nolocalefiles.patch
deleted file mode 100644 (file)
index 1d63e1d..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- gcc-4.0-20040919/libstdc++-v3/configure.orig       2004-09-03 20:09:37.000000000 +0200
-+++ gcc-4.0-20040919/libstdc++-v3/configure    2004-09-26 11:29:06.830762704 +0200
-@@ -5752,7 +5752,7 @@
-               int j;
-               __locale_t        loc;
-                __locale_t        loc_dup;
--              loc = __newlocale(1 << LC_ALL, "de_DE", 0);
-+              loc = __newlocale(1 << LC_ALL, "C", 0);
-               loc_dup = __duplocale(loc);
-               i = __strcoll_l(__one, __two, loc);
-               j = __strcoll_l(__one, __two, loc_dup);
This page took 0.112803 seconds and 4 git commands to generate.