]> git.pld-linux.org Git - packages/crossppc-binutils.git/commitdiff
- up to 2.20.51.0.3 (sync with binutils package) auto/th/crossppc-binutils-2_20_51_0_3-1
authorsparky <sparky@pld-linux.org>
Sun, 20 Dec 2009 02:17:51 +0000 (02:17 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    binutils-gasp.patch -> 1.21
    binutils-pt_pax_flags.patch -> 1.13
    crossppc-binutils.spec -> 1.35

binutils-gasp.patch
binutils-pt_pax_flags.patch
crossppc-binutils.spec

index 818aab4185b9b936547ea85acd167240f232de9f..8ce5130ab9f7ad12f64297606ae81049f43fc296 100644 (file)
  EXPECT = expect
  RUNTEST = runtest
  RUNTESTFLAGS=
-@@ -2282,6 +2282,8 @@
- write.o: write.c $(INCDIR)/alloca-conf.h subsegs.h \
-   $(INCDIR)/obstack.h output-file.h dwarf2dbg.h $(BFDDIR)/libbfd.h \
-   $(INCDIR)/hashtab.h
-+gasp.o: gasp.c $(INCDIR)/getopt.h $(INCDIR)/safe-ctype.h \
-+  sb.h macro.h $(INCDIR)/xregex.h $(INCDIR)/xregex2.h
- itbl-ops.o: itbl-ops.c $(INCDIR)/alloca-conf.h itbl-ops.h
- cgen.o: cgen.c $(INCDIR)/alloca-conf.h cgen-desc.h \
-   subsegs.h $(INCDIR)/obstack.h cgen.h dwarf2dbg.h struc-symbol.h
+@@ -682,6 +682,9 @@
+ itbl-lex.o: itbl-lex.c itbl-parse.h $(srcdir)/itbl-lex.h
+       $(COMPILE) -c $< $(NO_WERROR)
++gasp.o:gasp.c $(INCDIR)/getopt.h $(INCDIR)/safe-ctype.h \
++      sb.h macro.h $(INCDIR)/xregex.h $(INCDIR)/xregex2.h
++
+ # Disable -Werror, if it has been enabled, since old versions of bison/
+ # yacc will produce working code which contain compile time warnings.
+ itbl-parse.o: itbl-parse.c itbl-parse.h $(srcdir)/itbl-ops.h $(srcdir)/itbl-lex.h
 --- binutils-2.17.50.0.13/gas/doc/Makefile.am.orig     2007-03-16 16:48:29.000000000 +0100
 +++ binutils-2.17.50.0.13/gas/doc/Makefile.am  2007-03-16 20:27:05.810679469 +0100
 @@ -15,7 +15,7 @@
 +int do_scrub_chars (int (*get) (char*, int), char *tostart, int tolen) {}
 --- binutils-2.16.91.0.2.org/gas/macro.c       2005-05-10 22:46:44.000000000 +0000
 +++ binutils-2.16.91.0.2/gas/macro.c   2005-07-21 18:31:04.000000000 +0000
-@@ -41,8 +41,8 @@
- static int get_apost_token (int, sb *, sb *, int);
- static int sub_actual (int, sb *, sb *, struct hash_control *, int, sb *, int);
- static const char *macro_expand_body
--  (sb *, sb *, formal_entry *, struct hash_control *, const macro_entry *);
--static const char *macro_expand (int, sb *, macro_entry *, sb *);
-+  (sb *, sb *, formal_entry *, struct hash_control *, const macro_entry *, int);
-+static const char *macro_expand (int, sb *, macro_entry *, sb *, int);
- static void free_macro(macro_entry *);
- #define ISWHITE(x) ((x) == ' ' || (x) == '\t')
 @@ -754,7 +754,7 @@
  
  static const char *
index 60256963ea3ba46966db4eebc17d4ace9c89acbe..c9942a1edbc56b46ef173a61ef345598a396393b 100644 (file)
  
 --- binutils-2.15.94.0.2.2.orig/include/elf/common.h   2004-11-22 21:33:32.000000000 +0100
 +++ binutils-2.15.94.0.2.2/include/elf/common.h        2005-02-20 13:13:17.482539960 +0100
-@@ -307,12 +307,27 @@
+@@ -423,6 +423,7 @@
  #define PT_GNU_STACK  (PT_LOOS + 0x474e551) /* Stack flags */
  #define PT_GNU_RELRO  (PT_LOOS + 0x474e552) /* Read-only after relocation */
  #define PT_GNU_SHR    (PT_LOOS + 0x474e554) /* Sharable segment */
-+#define PT_PAX_FLAGS  (PT_LOOS + 0x5041580) /* PaX flags */
++#define PT_PAX_FLAGS   (PT_LOOS + 0x5041580) /* PaX flags */
  
  /* Program segment permissions, in program header p_flags field.  */
  
- #define PF_X          (1 << 0)        /* Segment is executable */
- #define PF_W          (1 << 1)        /* Segment is writable */
- #define PF_R          (1 << 2)        /* Segment is readable */
-+
-+#define PF_PAGEEXEC   (1 << 4)        /* Enable  PAGEEXEC */
-+#define PF_NOPAGEEXEC (1 << 5)        /* Disable PAGEEXEC */
-+#define PF_SEGMEXEC   (1 << 6)        /* Enable  SEGMEXEC */
-+#define PF_NOSEGMEXEC (1 << 7)        /* Disable SEGMEXEC */
-+#define PF_MPROTECT   (1 << 8)        /* Enable  MPROTECT */
-+#define PF_NOMPROTECT (1 << 9)        /* Disable MPROTECT */
-+#define PF_RANDEXEC   (1 << 10)       /* Enable  RANDEXEC */
-+#define PF_NORANDEXEC (1 << 11)       /* Disable RANDEXEC */
-+#define PF_EMUTRAMP   (1 << 12)       /* Enable  EMUTRAMP */
-+#define PF_NOEMUTRAMP (1 << 13)       /* Disable EMUTRAMP */
-+#define PF_RANDMMAP   (1 << 14)       /* Enable  RANDMMAP */
-+#define PF_NORANDMMAP (1 << 15)       /* Disable RANDMMAP */
-+
- /* #define PF_MASKOS  0x0F000000    *//* OS-specific reserved bits */
+@@ -433,6 +434,19 @@
  #define PF_MASKOS     0x0FF00000      /* New value, Oct 4, 1999 Draft */
  #define PF_MASKPROC   0xF0000000      /* Processor-specific reserved bits */
++#define PF_PAGEEXEC        (1 << 4)    /* Enable  PAGEEXEC */
++#define PF_NOPAGEEXEC  (1 << 5)    /* Disable PAGEEXEC */
++#define PF_SEGMEXEC        (1 << 6)    /* Enable  SEGMEXEC */
++#define PF_NOSEGMEXEC  (1 << 7)    /* Disable SEGMEXEC */
++#define PF_MPROTECT        (1 << 8)    /* Enable  MPROTECT */
++#define PF_NOMPROTECT  (1 << 9)    /* Disable MPROTECT */
++#define PF_RANDEXEC        (1 << 10)   /* Enable  RANDEXEC */
++#define PF_NORANDEXEC  (1 << 11)   /* Disable RANDEXEC */
++#define PF_EMUTRAMP        (1 << 12)   /* Enable  EMUTRAMP */
++#define PF_NOEMUTRAMP  (1 << 13)   /* Disable EMUTRAMP */
++#define PF_RANDMMAP        (1 << 14)   /* Enable  RANDMMAP */
++#define PF_NORANDMMAP  (1 << 15)   /* Disable RANDMMAP */
++
+ /* Values for section header, sh_type field.  */
+ #define SHT_NULL      0               /* Section header table entry unused */
 --- binutils-2.18.50.0.1/ld/emultempl/elf32.em.orig    2007-09-08 19:34:12.000000000 +0200
 +++ binutils-2.18.50.0.1/ld/emultempl/elf32.em 2007-09-15 21:41:35.688212063 +0200
 @@ -2139,6 +2139,16 @@
index c8dbc1b3c855ab07c9b9b4b2670c77f2589b5e03..08cfb829d825384b4179dedad77cc3200f1832ac 100644 (file)
@@ -1,6 +1,4 @@
 #
-# Conditional build:
-%bcond_with    gold            # enable gold (gnu ld successor) on supported archs (x86/sparc)
 
 Summary:       Cross PPC GNU binary utility development utilities - binutils
 Summary(es.UTF-8):     Utilitarios para desarrollo de binarios de la GNU - PPC binutils
@@ -9,19 +7,18 @@ Summary(pl.UTF-8):    Skrośne narzędzia programistyczne GNU dla PPC - binutils
 Summary(pt_BR.UTF-8):  Utilitários para desenvolvimento de binários da GNU - PPC binutils
 Summary(tr.UTF-8):     GNU geliştirme araçları - PPC binutils
 Name:          crossppc-binutils
-Version:       2.19.51.0.4
+Version:       2.20.51.0.3
 Release:       1
 License:       GPL v3+
 Group:         Development/Tools
 Source0:       ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
-# Source0-md5: 7b0d5a4fd434237922aeeab0409f146d
+# Source0-md5: 4d5cdcfa054e697ba92a37f55b125080
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/binutils-non-english-man-pages.tar.bz2
 # Source1-md5: a717d9707ec77d82acb6ec9078c472d6
 Patch0:                binutils-gasp.patch
 Patch1:                binutils-info.patch
 Patch2:                binutils-libtool-relink.patch
 Patch3:                binutils-pt_pax_flags.patch
-Patch4:                binutils-mips-relocs.patch
 Patch5:                binutils-flex.patch
 Patch6:                binutils-discarded.patch
 Patch7:                binutils-absolute-gnu_debuglink-path.patch
@@ -29,14 +26,12 @@ Patch8:             binutils-libtool-m.patch
 Patch9:                binutils-build-id.patch
 Patch10:       binutils-tooldir.patch
 URL:           http://sources.redhat.com/binutils/
-BuildRequires: autoconf >= 2.60
-BuildRequires: automake >= 1:1.8.2
+BuildRequires: autoconf >= 2.64
+BuildRequires: automake >= 1:1.11
 BuildRequires: bison
 BuildRequires: flex
 BuildRequires: gettext-devel
-%if %{with gold}
 BuildRequires: libstdc++-devel >= 6:4.0-1
-%endif
 BuildRequires: perl-tools-pod
 %ifarch sparc sparc32
 BuildRequires: sparc32
@@ -79,7 +74,6 @@ Ten pakiet zawiera wersję skrośną generującą kod dla PPC.
 %patch1 -p1
 %patch2 -p1
 %{?with_pax:%patch3 -p1}
-%patch4 -p0
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
@@ -98,10 +92,10 @@ rm config/override.m4
 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
 for dir in gas bfd; do
        cd $dir || exit 1
-       aclocal -I .. -I ../config -I ../bfd
-       automake --cygnus Makefile
-       automake --cygnus doc/Makefile
-       autoconf
+       %{__aclocal} -I .. -I ../config -I ../bfd
+       %{__automake} Makefile
+       %{__automake} doc/Makefile
+       %{__autoconf}
        cd ..
 done
 
@@ -123,7 +117,7 @@ sparc32 \
        --infodir=%{_infodir} \
        --mandir=%{_mandir} \
        --with-tooldir=%{arch} \
-       %{?with_gold:--enable-gold} \
+       --enable-gold=both \
        --target=%{target}
 
 %{__make}
@@ -135,6 +129,8 @@ install -d $RPM_BUILD_ROOT%{_prefix}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+rm $RPM_BUILD_ROOT%{_infodir}/standards.info*
+
 # remove these man pages unless we cross-build for win*/netware platforms.
 # however, this should be done in Makefiles.
 rm $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
@@ -149,8 +145,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{arch}
 %dir %{arch}/bin
 %attr(755,root,root) %{arch}/bin/*
-%if %{without gold}
 %dir %{arch}/lib
 %{arch}/lib/ldscripts
-%endif
 %{_mandir}/man?/%{target}-*
This page took 0.060047 seconds and 4 git commands to generate.