]> git.pld-linux.org Git - packages/crossnacl-newlib.git/commitdiff
up to git 6a104f4 matching chromium 25.0.1364.97 auto/th/crossnacl-newlib-1.20.0-3.git6a104f4
authorElan Ruusamäe <glen@delfi.ee>
Tue, 26 Feb 2013 23:18:16 +0000 (01:18 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 26 Feb 2013 23:18:16 +0000 (01:18 +0200)
adds nacl mprotect syscall and some other changes

crossnacl-newlib.spec
pthread.h

index bd8a2a9492f6f560137c0eb4ef433d0f0952f3b1..63019ffc9a3fcfab10ffd08d87fedeb188c7776f 100644 (file)
@@ -1,4 +1,4 @@
-%define                gitver 51a8366
+%define                gitver 6a104f4
 Summary:       C library intended for use on embedded systems
 Name:          crossnacl-newlib
 Version:       1.20.0
@@ -6,9 +6,9 @@ Release:        3.git%{gitver}
 License:       BSD and MIT and LGPL v2+
 Group:         Libraries
 Source0:       nacl-newlib-%{version}-git%{gitver}.tar.xz
-# Source0-md5: e3bfa762283d0ecda5fc198781c92c37
-Source1:       nacl-headers-23.0.1271.64.tar.xz
-# Source1-md5: ab7b7b3dfd91f3f98969e5312941d6d2
+# Source0-md5: 243d91de902d660e6eaccab36b576956
+Source1:       nacl-headers-25.0.1364.97.tar.xz
+# Source1-md5: c8f3144e90e713f9fbfe767dbf898017
 Source2:       newlib-libc-script
 Source3:       pthread.h
 Source4:       get-source.sh
index 3f751cde98881c0a4dfbc3c2d222a8dce1c58d94..70c551f5ad3dbe3383cd482210dcc9e9b76d8374 100644 (file)
--- a/pthread.h
+++ b/pthread.h
@@ -62,8 +62,11 @@ enum {
  * opaque record; the names of the fields can change anytime.
  */
 typedef struct {
-  /** Initialization token **/
-  int token;
+  /*
+   * mutex_state is either UNLOCKED (0), LOCKED_WITHOUT_WAITERS (1) or
+   * LOCKED_WITH_WAITERS (2).  See "enum MutexState".
+   */
+  int mutex_state;
 
   /**
    * The kind of mutex:
@@ -78,8 +81,12 @@ typedef struct {
   /** Recursion depth counter for recursive mutexes */
   uint32_t recursion_counter;
 
-  /** Handle to the system-side mutex */
-  int mutex_handle;
+  /*
+   * Padding is for compatibility with libraries (newlib etc.) that
+   * were built before libpthread switched to using futexes, and to
+   * match _LOCK_T in newlib's newlib/libc/include/sys/lock.h.
+   */
+  int unused_padding;
 } pthread_mutex_t;
 
 /**
@@ -100,11 +107,14 @@ typedef struct {
  * opaque record; the names of the fields can change anytime.
  */
 typedef struct {
-  /** Initialization token **/
-  int token;
+  /* This is incremented on each pthread_cond_signal/broadcast() call. */
+  int sequence_number;
 
-  /**< Handle to the system-side condition variable */
-  int handle;
+  /*
+   * Padding is for compatibility with libraries (newlib etc.) that
+   * were built before libpthread switched to using futexes.
+   */
+  int unused_padding;
 } pthread_cond_t;
 
 /**
@@ -408,7 +418,7 @@ typedef struct {
 */
 extern int pthread_create(pthread_t *thread_id,
                           const pthread_attr_t *attr,
-                          void *(*start_routine) (void *p),
+                          void *(*start_routine)(void *p),
                           void *arg);
 
 /** @nqPosix
This page took 0.07783 seconds and 4 git commands to generate.