]> git.pld-linux.org Git - packages/crossnacl-gcc.git/commitdiff
up to git 3937565 auto/th/crossnacl-gcc-4.4.3-6.git3937565
authorElan Ruusamäe <glen@delfi.ee>
Wed, 1 Aug 2012 17:32:16 +0000 (20:32 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 1 Aug 2012 17:32:16 +0000 (20:32 +0300)
crossnacl-gcc.spec
get-source.sh [changed mode: 0644->0755]

index ee2acc278179a3cc7fca86adb8302fd97caf7c52..93436dbc996c00b02de072903186a994a0f6950d 100644 (file)
@@ -1,25 +1,16 @@
 #
 # Conditional build:
-%bcond_with    bootstrap               # build without nacl newlib package dependency (without c++ package)
+%bcond_with    bootstrap               # build without NaCL newlib package dependency (without c++ package)
 
-%define                gitver  c69a5b7
-Summary:       Various compilers (C, C++) for nacl
+%define                gitver  3937565
+Summary:       Various compilers (C, C++) for NaCl
 Name:          crossnacl-gcc
 Version:       4.4.3
-Release:       5.git%{gitver}
-# Generated from git
-# git clone http://git.chromium.org/native_client/nacl-gcc.git
-# (Checkout ID taken from chromium-15.0.874.106/native_client/tools/REVISIONS)
-# cd nacl-gcc
-# git checkout cff9ac884908ba53ae16149e7c7d19c336aa4895
-# cd ..
-# For gcc version, echo gcc/BASE-VER
-# mv nacl-gcc nacl-gcc-4.4.3-gitcff9ac88
-# tar cfj nacl-gcc-4.4.3-gitcff9ac88.tar.bz2 nacl-gcc-4.4.3-gitcff9ac88
+Release:       6.git%{gitver}
 License:       GPL v3+ and GPL v3+ with exceptions and GPL v2+ with exceptions
 Group:         Development/Languages
 Source0:       nacl-gcc-%{version}-git%{gitver}.tar.bz2
-# Source0-md5: 50e316936d59c7951b91cff8124c0b30
+# Source0-md5: fcdfdd30b82d8ad8fa6e39e7e32cee64
 Source1:       get-source.sh
 URL:           http://sourceware.org/gcc/
 BuildRequires: cloog-ppl-devel
old mode 100644 (file)
new mode 100755 (executable)
index 51460c6..e79adf0
@@ -1,7 +1,6 @@
 #!/bin/sh
 # Make snapshot of nacl-binutils
 # Author: Elan Ruusamäe <glen@pld-linux.org>
-# $Id$
 set -e
 
 # Generated from git
@@ -16,12 +15,19 @@ set -e
 
 package=nacl-gcc
 repo_url=http://git.chromium.org/native_client/$package.git
+nacl_trunk=http://src.chromium.org/native_client/trunk
+omahaproxy_url=https://omahaproxy.appspot.com
 specfile=crossnacl-gcc.spec
 
-chrome_version=20.0.1132.47
+# if you get errors that sha1 hash not found, try increasing depth
+# fatal: Path 'gcc/BASE-VER' does not exist in 'c69a5b7252d2f073d0f526800e4fca3b63cd1fab'
+depth=5
 
-chrome_revision=$(curl -s https://omahaproxy.appspot.com/revision?version=$chrome_version)
+chrome_channel=stable
+chrome_version=$(curl -s "$omahaproxy_url/?os=linux&channel=$chrome_channel" | awk -F, 'NR > 1{print $3}')
+chrome_revision=$(curl -s $omahaproxy_url/revision?version=$chrome_version)
 chrome_branch=$(IFS=.; set -- $chrome_version; echo $3)
+
 test -e DEPS.py || svn cat http://src.chromium.org/chrome/branches/$chrome_branch/src/DEPS@$chrome_revision > DEPS.py
 nacl_revision=$(awk -F'"' '/nacl_revision.:/{print $4}' DEPS.py)
 
@@ -31,13 +37,13 @@ if [ ! -d $package ]; then
        install -d $package
        git init
        git remote add origin $repo_url
-       git fetch --depth 1 origin refs/heads/master:refs/remotes/origin/master
+       git fetch --depth $depth origin refs/heads/master:refs/remotes/origin/master
 else
        git fetch origin refs/heads/master:refs/remotes/origin/master
 fi
 
 # get src/native_client/tools/REVISIONS directly from svn
-test -e NACL_REVISIONS.sh || svn cat https://src.chromium.org/native_client/trunk/src/native_client/tools/REVISIONS@$nacl_revision > NACL_REVISIONS.sh
+test -e NACL_REVISIONS.sh || svn cat $nacl_trunk/src/native_client/tools/REVISIONS@$nacl_revision > NACL_REVISIONS.sh
 
 if grep -Ev '^(#|(LINUX_HEADERS_FOR_NACL|NACL_(BINUTILS|GCC|GDB|GLIBC|NEWLIB))_COMMIT=[0-9a-f]+$|)' NACL_REVISIONS.sh >&2; then
        echo >&2 "I refuse to execute grabbed file for security concerns"
@@ -52,6 +58,7 @@ prefix=$package-$version-git$shorthash
 
 if [ -f $prefix.tar.bz2 ]; then
        echo "Tarball $prefix.tar.bz2 already exists at $shorthash"
+       rm -f NACL_REVISIONS.sh DEPS.py
        exit 0
 fi
 
This page took 0.070883 seconds and 4 git commands to generate.