]> git.pld-linux.org Git - packages/crossnacl-binutils.git/commitdiff
- added perl patch (fix man pages build with recent perl) auto/th/crossnacl-binutils-2.24-0.git7dc2f25.2
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 29 Jul 2018 14:40:48 +0000 (16:40 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 29 Jul 2018 14:40:48 +0000 (16:40 +0200)
- drop some secondary native targets (this package isn't meant as replacement for native binutils)
- rel 2

binutils-perl.patch [new file with mode: 0644]
crossnacl-binutils.spec

diff --git a/binutils-perl.patch b/binutils-perl.patch
new file mode 100644 (file)
index 0000000..101d194
--- /dev/null
@@ -0,0 +1,11 @@
+--- nacl-binutils-2.24-git7dc2f25/etc/texi2pod.pl.orig 2013-12-02 18:13:52.000000000 +0100
++++ nacl-binutils-2.24-git7dc2f25/etc/texi2pod.pl      2018-07-29 16:19:06.069358300 +0200
+@@ -311,7 +311,7 @@
+       @columns = ();
+       for $column (split (/\s*\@tab\s*/, $1)) {
+           # @strong{...} is used a @headitem work-alike
+-          $column =~ s/^\@strong{(.*)}$/$1/;
++          $column =~ s/^\@strong\{(.*)\}$/$1/;
+           push @columns, $column;
+       }
+       $_ = "\n=item ".join (" : ", @columns)."\n";
index abc6539535617a2f15ea008c70cf63c851744a27..44f1af28904d989d5cb91728b0ac53c8efeca447 100644 (file)
@@ -1,19 +1,21 @@
-%define                rel             1
+%define                rel     2
 %define                gitver  7dc2f25
 Summary:       Cross NaCL GNU binary utility development utilities - binutils
 Name:          crossnacl-binutils
 Version:       2.24
 Release:       0.git%{gitver}.%{rel}
-License:       GPL
+License:       GPL v3+
 Group:         Development/Tools
 Source0:       nacl-binutils-%{version}-git%{gitver}.tar.xz
 # Source0-md5: 62c1372814f7873be066fe316fbe1c9c
 Source1:       get-source.sh
+Patch0:                binutils-perl.patch
 URL:           https://chromium.googlesource.com/native_client/nacl-binutils/
 BuildRequires: bash
 BuildRequires: bison
 BuildRequires: flex
 BuildRequires: fslint
+BuildRequires: perl-base
 BuildRequires: python-modules
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
@@ -21,7 +23,9 @@ ExclusiveArch:        %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                target          x86_64-nacl
-%define                arch            %{_prefix}/%{target}
+%define                archprefix      %{_prefix}/%{target}
+%define                archbindir      %{archprefix}/bin
+%define                archlibdir      %{archprefix}/lib
 
 %description
 Binutils is a collection of binary utilities, including:
@@ -34,8 +38,7 @@ Binutils is a collection of binary utilities, including:
 - strings - list printable strings from files,
 - strip - discard symbols,
 - c++filt - a filter for demangling encoded C++ symbols,
-- addr2line - convert addresses to file and line,
-- nlmconv - convert object code into an NLM.
+- addr2line - convert addresses to file and line.
 
 This package contains the cross version for NaCL.
 
@@ -49,6 +52,7 @@ Ten pakiet zawiera wersję skrośną generującą kod dla NaCl.
 
 %prep
 %setup -q -n nacl-binutils-%{version}-git%{gitver}
+%patch0 -p1
 
 %build
 # ldscripts won't be generated properly if SHELL is not bash...
@@ -59,23 +63,17 @@ CONFIG_SHELL="/bin/bash" \
        --build=%{_target_platform} \
        --host=%{_target_platform} \
        --target=%{target} \
+       --prefix=%{_prefix} \
+       --libdir=%{_libdir} \
+       --mandir=%{_mandir} \
+       --infodir=%{_infodir} \
        --enable-targets=%{_host} \
-%ifarch ia64
-       --enable-targets=i386-linux \
-%endif
-%ifarch ppc ppc64
-       --enable-targets=spu \
-%endif
-%ifarch %{ix86} sparc sparc64 ppc ppc64 s390 sh arm
+%ifarch %{ix86} sparc sparc64 ppc ppc64 s390 sh %{arm}
        --enable-64-bit-bfd \
 %endif
        --disable-shared \
        --disable-nls \
        --disable-werror \
-       --prefix=%{_prefix} \
-       --libdir=%{_libdir} \
-       --mandir=%{_mandir} \
-       --infodir=%{_infodir} \
        --enable-plugins
 
 %{__make} all \
@@ -96,22 +94,58 @@ findup -m $RPM_BUILD_ROOT
 
 # remove these man pages unless we cross-build for win*/netware platforms.
 # however, this should be done in Makefiles.
-%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windmc,*windres}.1
 
 # packaged in base binutils
-%{__rm} -rv $RPM_BUILD_ROOT%{_infodir}
+%{__rm} -r $RPM_BUILD_ROOT%{_infodir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README
-%attr(755,root,root) %{_bindir}/%{target}-*
-%dir %{arch}
-%dir %{arch}/bin
-%attr(755,root,root) %{arch}/bin/*
-%dir %{arch}/lib
-%dir %{arch}/lib/*
-%{arch}/lib/ldscripts/*
-%{_mandir}/man1/%{target}-*.1*
+%doc README binutils/NEWS
+%attr(755,root,root) %{_bindir}/%{target}-addr2line
+%attr(755,root,root) %{_bindir}/%{target}-ar
+%attr(755,root,root) %{_bindir}/%{target}-as
+%attr(755,root,root) %{_bindir}/%{target}-c++filt
+%attr(755,root,root) %{_bindir}/%{target}-elfedit
+%attr(755,root,root) %{_bindir}/%{target}-gprof
+%attr(755,root,root) %{_bindir}/%{target}-ld
+%attr(755,root,root) %{_bindir}/%{target}-ld.bfd
+%attr(755,root,root) %{_bindir}/%{target}-nm
+%attr(755,root,root) %{_bindir}/%{target}-objcopy
+%attr(755,root,root) %{_bindir}/%{target}-objdump
+%attr(755,root,root) %{_bindir}/%{target}-ranlib
+%attr(755,root,root) %{_bindir}/%{target}-readelf
+%attr(755,root,root) %{_bindir}/%{target}-size
+%attr(755,root,root) %{_bindir}/%{target}-strings
+%attr(755,root,root) %{_bindir}/%{target}-strip
+%dir %{archprefix}
+%dir %{archbindir}
+%attr(755,root,root) %{archbindir}/ar
+%attr(755,root,root) %{archbindir}/as
+%attr(755,root,root) %{archbindir}/ld
+%attr(755,root,root) %{archbindir}/ld.bfd
+%attr(755,root,root) %{archbindir}/nm
+%attr(755,root,root) %{archbindir}/objcopy
+%attr(755,root,root) %{archbindir}/objdump
+%attr(755,root,root) %{archbindir}/ranlib
+%attr(755,root,root) %{archbindir}/strip
+%dir %{archlibdir}
+%{archlibdir}/ldscripts
+%{_mandir}/man1/%{target}-addr2line.1*
+%{_mandir}/man1/%{target}-ar.1*
+%{_mandir}/man1/%{target}-as.1*
+%{_mandir}/man1/%{target}-c++filt.1*
+%{_mandir}/man1/%{target}-elfedit.1*
+%{_mandir}/man1/%{target}-gprof.1*
+%{_mandir}/man1/%{target}-ld.1*
+%{_mandir}/man1/%{target}-nm.1*
+%{_mandir}/man1/%{target}-objcopy.1*
+%{_mandir}/man1/%{target}-objdump.1*
+%{_mandir}/man1/%{target}-ranlib.1*
+%{_mandir}/man1/%{target}-readelf.1*
+%{_mandir}/man1/%{target}-size.1*
+%{_mandir}/man1/%{target}-strings.1*
+%{_mandir}/man1/%{target}-strip.1*
This page took 0.08228 seconds and 4 git commands to generate.