]> git.pld-linux.org Git - packages/crossnacl-binutils.git/blame - crossnacl-binutils.spec
up to bd55408, clang fixes
[packages/crossnacl-binutils.git] / crossnacl-binutils.spec
CommitLineData
8ae7830d 1%define gitver bd55408
42dfad3e
ER
2Summary: Cross NaCL GNU binary utility development utilities - binutils
3Name: crossnacl-binutils
4Version: 2.20.1
8ae7830d 5Release: 4.git%{gitver}.1
42dfad3e
ER
6License: GPL
7Group: Development/Tools
d5197b4c 8Source0: nacl-binutils-%{version}-git%{gitver}.tar.xz
8ae7830d 9# Source0-md5: 6970752492880c59be545c39f433edeb
fff4bba7 10Source1: get-source.sh
656f9f48 11URL: http://git.chromium.org/gitweb/?p=native_client/nacl-binutils.git
42dfad3e
ER
12BuildRequires: bash
13BuildRequires: bison
14BuildRequires: flex
28ec7b79 15BuildRequires: fslint
733e3a52 16BuildRequires: python-modules
d5197b4c
ER
17BuildRequires: tar >= 1:1.22
18BuildRequires: xz
42dfad3e
ER
19ExclusiveArch: %{ix86} %{x8664}
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%define target x86_64-nacl
23%define arch %{_prefix}/%{target}
24
25%description
26Binutils is a collection of binary utilities, including:
27- ar - create, modify and extract from archives,
28- nm - lists symbols from object files,
29- objcopy - copy and translate object files,
30- objdump - display information from object files,
31- ranlib - generate an index for the contents of an archive,
32- size - list the section sizes of an object or archive file,
33- strings - list printable strings from files,
34- strip - discard symbols,
35- c++filt - a filter for demangling encoded C++ symbols,
36- addr2line - convert addresses to file and line,
37- nlmconv - convert object code into an NLM.
38
28ec7b79 39This package contains the cross version for NaCL.
42dfad3e
ER
40
41%description -l pl.UTF-8
42Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
43programów. Znajdują się tutaj między innymi assembler, konsolidator
44(linker), a także inne narzędzia do manipulowania binarnymi plikami
45programów i bibliotek.
46
28ec7b79 47Ten pakiet zawiera wersję skrośną generującą kod dla NaCl.
42dfad3e
ER
48
49%prep
50%setup -q -n nacl-binutils-%{version}-git%{gitver}
51
52%build
53# ldscripts won't be generated properly if SHELL is not bash...
54CFLAGS="%{rpmcflags} -fno-strict-aliasing" \
55LDFLAGS="%{rpmldflags}" \
56CONFIG_SHELL="/bin/bash" \
57./configure \
58 --build=%{_target_platform} \
59 --host=%{_target_platform} \
60 --target=%{target} \
61 --enable-targets=%{_host} \
62%ifarch ia64
63 --enable-targets=i386-linux \
64%endif
65%ifarch ppc ppc64
66 --enable-targets=spu \
67%endif
68%ifarch %{ix86} sparc sparc64 ppc ppc64 s390 sh arm
69 --enable-64-bit-bfd \
70%endif
71 --disable-shared \
72 --disable-nls \
73 --disable-werror \
74 --prefix=%{_prefix} \
75 --libdir=%{_libdir} \
76 --mandir=%{_mandir} \
77 --infodir=%{_infodir} \
78 --enable-plugins
79
80%{__make} all \
81 tooldir=%{_prefix} \
82 EXEEXT=""
83
84%install
85rm -rf $RPM_BUILD_ROOT
86install -d $RPM_BUILD_ROOT%{_prefix}
42dfad3e
ER
87%{__make} install \
88 prefix=$RPM_BUILD_ROOT%{_prefix} \
89 mandir=$RPM_BUILD_ROOT%{_mandir} \
90 infodir=$RPM_BUILD_ROOT%{_infodir} \
91 libdir=$RPM_BUILD_ROOT%{_libdir}
92
28ec7b79
ER
93# fix copies to be hardlinks (maybe should symlink in the future)
94findup -m $RPM_BUILD_ROOT
95
42dfad3e
ER
96# remove these man pages unless we cross-build for win*/netware platforms.
97# however, this should be done in Makefiles.
98%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
99
100# don't want this here
101%{__rm} $RPM_BUILD_ROOT%{_libdir}/libiberty.a
102
103# packaged in base binutils
104%{__rm} -r $RPM_BUILD_ROOT%{_infodir}
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%files
110%defattr(644,root,root,755)
111%doc README
112%attr(755,root,root) %{_bindir}/%{target}-*
113%dir %{arch}
114%dir %{arch}/bin
115%attr(755,root,root) %{arch}/bin/*
116%dir %{arch}/lib
117%dir %{arch}/lib/*
118%{arch}/lib/ldscripts/*
8ae7830d 119%{_mandir}/man1/%{target}-*.1*
This page took 0.095944 seconds and 4 git commands to generate.