]> git.pld-linux.org Git - packages/crossmingw64-binutils.git/blob - crossmingw64-binutils.spec
a2430d3538b32af539f64c4d06362db59a334e9f
[packages/crossmingw64-binutils.git] / crossmingw64-binutils.spec
1 Summary:        Cross MinGW-W64 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW-W64 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW-W64 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW-W64 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW-W64 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW-W64 binutils
7 Name:           crossmingw64-binutils
8 Version:        2.31
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.lz
13 # Source0-md5:  1ea8ddd13bd6fdcab1fe6cf377894476
14 Patch0:         binutils-libdir.patch
15 URL:            http://sources.redhat.com/binutils/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  bash
19 BuildRequires:  bison
20 BuildRequires:  flex
21 BuildRequires:  gettext-tools
22 BuildRequires:  lzip
23 BuildRequires:  perl-tools-pod
24 BuildRequires:  tar >= 1:1.22
25 # not necessary unless we patch .texi docs; but they are not packaged here anyway
26 #BuildRequires: texinfo >= 4.2
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # mingw-w64 project uses x86_64-w64-mingw32 triplet for 64-bit Windows
30 # and (i?86-w64-mingw32 for 32-bit Windows)
31 %define         target          x86_64-w64-mingw32
32 %define         arch            %{_prefix}/%{target}
33
34 %description
35 crossmingw64 is a complete cross-compiling development system for
36 building stand-alone Microsoft Windows applications under Linux using
37 the MinGW64 build libraries. This includes a binutils, gcc with g++
38 and objc, and libstdc++, all cross targeted to x86_64-w64-mingw32,
39 along with supporting Win64 libraries in 'coff' format from free
40 sources.
41
42 This package contains cross targeted binutils.
43
44 %description -l pl.UTF-8
45 crossmingw64 jest kompletnym systemem do kroskompilacji, pozwalającym
46 budować aplikacje MS Windows pod Linuksem używając bibliotek mingw64.
47 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
48 generujące kod dla platformy x86_64-w64-mingw32, oraz z bibliotek
49 Win64 w formacie COFF.
50
51 Ten pakiet zawiera binutils generujące skrośnie binaria dla
52 64-bitowych Windows.
53
54 %prep
55 %setup -q -n binutils-%{version}
56 %patch0 -p1
57
58 # file contains hacks for ac 2.64 only
59 %{__rm} config/override.m4
60 %{__sed} -i '/^m4_include(config\/override\.m4/d' configure.ac
61
62 %build
63 cp -f /usr/share/automake/config.* .
64 %{__aclocal}
65 %{__autoconf}
66
67 # non-standard regeneration (needed because of libdir patch)
68 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
69 for dir in gas bfd; do
70         cd $dir || exit 1
71         %{__aclocal} -I .. -I ../config -I ../bfd
72         %{__automake} Makefile
73         %{__automake} doc/Makefile
74         %{__autoconf}
75         cd ..
76 done
77
78 # We don't install libbfd (nor use shared binutils libraries) to avoid
79 # conflict with native binutils.
80
81 # ldscripts won't be generated properly if SHELL is not bash...
82 CFLAGS="%{rpmcflags}" \
83 LDFLAGS="%{rpmldflags}" \
84 CONFIG_SHELL="/bin/bash" \
85 ./configure \
86         --disable-nls \
87         --disable-shared \
88         --prefix=%{_prefix} \
89         --libdir=%{_libdir} \
90         --mandir=%{_mandir} \
91         --infodir=%{_infodir} \
92         --host=%{_target_platform} \
93         --build=%{_target_platform} \
94         --target=%{target}
95
96 %{__make} all \
97         tooldir=%{_prefix}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         INSTALL='$$s/install-sh -c' \
104         prefix=$RPM_BUILD_ROOT%{_prefix} \
105         mandir=$RPM_BUILD_ROOT%{_mandir} \
106         infodir=$RPM_BUILD_ROOT%{_infodir} \
107         libdir=$RPM_BUILD_ROOT%{_libdir}
108
109 # not prefixed, keep infos only from native packages
110 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
111
112 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
113 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %doc README
121 # mingw64 directory tree
122 %dir %{arch}
123 %dir %{arch}/lib
124 %dir %{arch}/lib/pkgconfig
125 %dir %{arch}/bin
126 # binutils files
127 %attr(755,root,root) %{arch}/bin/ar
128 %attr(755,root,root) %{arch}/bin/as
129 %attr(755,root,root) %{arch}/bin/dlltool
130 %attr(755,root,root) %{arch}/bin/ld
131 %attr(755,root,root) %{arch}/bin/ld.bfd
132 %attr(755,root,root) %{arch}/bin/nm
133 %attr(755,root,root) %{arch}/bin/objcopy
134 %attr(755,root,root) %{arch}/bin/objdump
135 %attr(755,root,root) %{arch}/bin/ranlib
136 %attr(755,root,root) %{arch}/bin/readelf
137 %attr(755,root,root) %{arch}/bin/strip
138 %{arch}/lib/ldscripts
139 %attr(755,root,root) %{_bindir}/%{target}-addr2line
140 %attr(755,root,root) %{_bindir}/%{target}-ar
141 %attr(755,root,root) %{_bindir}/%{target}-as
142 %attr(755,root,root) %{_bindir}/%{target}-c++filt
143 %attr(755,root,root) %{_bindir}/%{target}-dlltool
144 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
145 %attr(755,root,root) %{_bindir}/%{target}-elfedit
146 %attr(755,root,root) %{_bindir}/%{target}-gprof
147 %attr(755,root,root) %{_bindir}/%{target}-ld
148 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
149 %attr(755,root,root) %{_bindir}/%{target}-nm
150 %attr(755,root,root) %{_bindir}/%{target}-objcopy
151 %attr(755,root,root) %{_bindir}/%{target}-objdump
152 %attr(755,root,root) %{_bindir}/%{target}-ranlib
153 %attr(755,root,root) %{_bindir}/%{target}-readelf
154 %attr(755,root,root) %{_bindir}/%{target}-size
155 %attr(755,root,root) %{_bindir}/%{target}-strings
156 %attr(755,root,root) %{_bindir}/%{target}-strip
157 %attr(755,root,root) %{_bindir}/%{target}-windmc
158 %attr(755,root,root) %{_bindir}/%{target}-windres
159 %{_mandir}/man1/%{target}-addr2line.1*
160 %{_mandir}/man1/%{target}-ar.1*
161 %{_mandir}/man1/%{target}-as.1*
162 %{_mandir}/man1/%{target}-c++filt.1*
163 %{_mandir}/man1/%{target}-dlltool.1*
164 %{_mandir}/man1/%{target}-elfedit.1*
165 %{_mandir}/man1/%{target}-gprof.1*
166 %{_mandir}/man1/%{target}-ld.1*
167 %{_mandir}/man1/%{target}-nm.1*
168 %{_mandir}/man1/%{target}-objcopy.1*
169 %{_mandir}/man1/%{target}-objdump.1*
170 %{_mandir}/man1/%{target}-ranlib.1*
171 %{_mandir}/man1/%{target}-readelf.1*
172 %{_mandir}/man1/%{target}-size.1*
173 %{_mandir}/man1/%{target}-strings.1*
174 %{_mandir}/man1/%{target}-strip.1*
175 %{_mandir}/man1/%{target}-windmc.1*
176 %{_mandir}/man1/%{target}-windres.1*
This page took 0.07955 seconds and 2 git commands to generate.