]> git.pld-linux.org Git - packages/crossmingw64-binutils.git/blame_incremental - crossmingw64-binutils.spec
- updated to 3.37
[packages/crossmingw64-binutils.git] / crossmingw64-binutils.spec
... / ...
CommitLineData
1Summary: Cross MinGW-W64 GNU binary utility development utilities - binutils
2Summary(es.UTF-8): Utilitarios para desarrollo de binarios de la GNU - MinGW-W64 binutils
3Summary(fr.UTF-8): Utilitaires de développement binaire de GNU - MinGW-W64 binutils
4Summary(pl.UTF-8): Skrośne narzędzia programistyczne GNU dla MinGW-W64 - binutils
5Summary(pt_BR.UTF-8): Utilitários para desenvolvimento de binários da GNU - MinGW-W64 binutils
6Summary(tr.UTF-8): GNU geliştirme araçları - MinGW-W64 binutils
7Name: crossmingw64-binutils
8Version: 2.37
9Release: 1
10License: GPL v3+
11Group: Development/Tools
12Source0: https://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.lz
13# Source0-md5: a030c64f442d224aa3baa04a11f8cf34
14URL: http://www.sourceware.org/binutils/
15BuildRequires: autoconf >= 2.69
16BuildRequires: automake >= 1:1.11
17BuildRequires: bash
18BuildRequires: bison
19BuildRequires: flex
20BuildRequires: gettext-tools
21BuildRequires: lzip
22BuildRequires: perl-tools-pod
23BuildRequires: tar >= 1:1.22
24# not necessary unless we patch .texi docs; but they are not packaged here anyway
25#BuildRequires: texinfo >= 4.2
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28# mingw-w64 project uses x86_64-w64-mingw32 triplet for 64-bit Windows
29# and (i?86-w64-mingw32 for 32-bit Windows)
30%define target x86_64-w64-mingw32
31%define arch %{_prefix}/%{target}
32
33%description
34crossmingw64 is a complete cross-compiling development system for
35building stand-alone Microsoft Windows applications under Linux using
36the MinGW64 build libraries. This includes a binutils, gcc with g++
37and objc, and libstdc++, all cross targeted to x86_64-w64-mingw32,
38along with supporting Win64 libraries in 'coff' format from free
39sources.
40
41This package contains cross targeted binutils.
42
43%description -l pl.UTF-8
44crossmingw64 jest kompletnym systemem do kroskompilacji, pozwalającym
45budować aplikacje MS Windows pod Linuksem używając bibliotek mingw64.
46System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
47generujące kod dla platformy x86_64-w64-mingw32, oraz z bibliotek
48Win64 w formacie COFF.
49
50Ten pakiet zawiera binutils generujące skrośnie binaria dla
5164-bitowych Windows.
52
53%prep
54%setup -q -n binutils-%{version}
55
56# file contains hacks for ac 2.69 only
57%{__rm} config/override.m4
58%{__sed} -i '/^m4_include(config\/override\.m4/d' configure.ac
59
60%build
61cp -f /usr/share/automake/config.* .
62%{__aclocal}
63%{__autoconf}
64
65# non-standard regeneration (needed because of libdir patch)
66# AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
67for dir in gas bfd; do
68 cd $dir || exit 1
69 %{__aclocal} -I .. -I ../config -I ../bfd
70 %{__automake} Makefile
71 %{__automake} doc/Makefile
72 %{__autoconf}
73 cd ..
74done
75
76# We don't install libbfd (nor use shared binutils libraries) to avoid
77# conflict with native binutils.
78
79# ldscripts won't be generated properly if SHELL is not bash...
80CFLAGS="%{rpmcflags}" \
81LDFLAGS="%{rpmldflags}" \
82CONFIG_SHELL="/bin/bash" \
83./configure \
84 --disable-nls \
85 --disable-shared \
86 --prefix=%{_prefix} \
87 --libdir=%{_libdir} \
88 --mandir=%{_mandir} \
89 --infodir=%{_infodir} \
90 --host=%{_target_platform} \
91 --build=%{_target_platform} \
92 --target=%{target}
93
94%{__make} all \
95 tooldir=%{_prefix}
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100%{__make} install \
101 INSTALL='$$s/install-sh -c' \
102 prefix=$RPM_BUILD_ROOT%{_prefix} \
103 mandir=$RPM_BUILD_ROOT%{_mandir} \
104 infodir=$RPM_BUILD_ROOT%{_infodir} \
105 libdir=$RPM_BUILD_ROOT%{_libdir}
106
107%{__rm} $RPM_BUILD_ROOT%{_libdir}/bfd-plugins/*.a
108
109# not prefixed, keep infos only from native packages
110%{__rm} -r $RPM_BUILD_ROOT%{_infodir}
111
112# "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
113install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files
119%defattr(644,root,root,755)
120%doc README
121# mingw64 directory tree
122%dir %{arch}
123%dir %{arch}/lib
124%dir %{arch}/lib/pkgconfig
125%dir %{arch}/bin
126# binutils files
127%attr(755,root,root) %{arch}/bin/ar
128%attr(755,root,root) %{arch}/bin/as
129%attr(755,root,root) %{arch}/bin/dlltool
130%attr(755,root,root) %{arch}/bin/ld
131%attr(755,root,root) %{arch}/bin/ld.bfd
132%attr(755,root,root) %{arch}/bin/nm
133%attr(755,root,root) %{arch}/bin/objcopy
134%attr(755,root,root) %{arch}/bin/objdump
135%attr(755,root,root) %{arch}/bin/ranlib
136%attr(755,root,root) %{arch}/bin/readelf
137%attr(755,root,root) %{arch}/bin/strip
138%{arch}/lib/ldscripts
139%attr(755,root,root) %{_bindir}/%{target}-addr2line
140%attr(755,root,root) %{_bindir}/%{target}-ar
141%attr(755,root,root) %{_bindir}/%{target}-as
142%attr(755,root,root) %{_bindir}/%{target}-c++filt
143%attr(755,root,root) %{_bindir}/%{target}-dlltool
144%attr(755,root,root) %{_bindir}/%{target}-dllwrap
145%attr(755,root,root) %{_bindir}/%{target}-elfedit
146%attr(755,root,root) %{_bindir}/%{target}-gprof
147%attr(755,root,root) %{_bindir}/%{target}-ld
148%attr(755,root,root) %{_bindir}/%{target}-ld.bfd
149%attr(755,root,root) %{_bindir}/%{target}-nm
150%attr(755,root,root) %{_bindir}/%{target}-objcopy
151%attr(755,root,root) %{_bindir}/%{target}-objdump
152%attr(755,root,root) %{_bindir}/%{target}-ranlib
153%attr(755,root,root) %{_bindir}/%{target}-readelf
154%attr(755,root,root) %{_bindir}/%{target}-size
155%attr(755,root,root) %{_bindir}/%{target}-strings
156%attr(755,root,root) %{_bindir}/%{target}-strip
157%attr(755,root,root) %{_bindir}/%{target}-windmc
158%attr(755,root,root) %{_bindir}/%{target}-windres
159%{_mandir}/man1/%{target}-addr2line.1*
160%{_mandir}/man1/%{target}-ar.1*
161%{_mandir}/man1/%{target}-as.1*
162%{_mandir}/man1/%{target}-c++filt.1*
163%{_mandir}/man1/%{target}-dlltool.1*
164%{_mandir}/man1/%{target}-elfedit.1*
165%{_mandir}/man1/%{target}-gprof.1*
166%{_mandir}/man1/%{target}-ld.1*
167%{_mandir}/man1/%{target}-nm.1*
168%{_mandir}/man1/%{target}-objcopy.1*
169%{_mandir}/man1/%{target}-objdump.1*
170%{_mandir}/man1/%{target}-ranlib.1*
171%{_mandir}/man1/%{target}-readelf.1*
172%{_mandir}/man1/%{target}-size.1*
173%{_mandir}/man1/%{target}-strings.1*
174%{_mandir}/man1/%{target}-strip.1*
175%{_mandir}/man1/%{target}-windmc.1*
176%{_mandir}/man1/%{target}-windres.1*
This page took 0.03315 seconds and 4 git commands to generate.