]> git.pld-linux.org Git - packages/crossmingw32-w32api.git/blob - crossmingw32-w32api.spec
71541c41ea30e5be20d6aa8f90a4e28f8c35886b
[packages/crossmingw32-w32api.git] / crossmingw32-w32api.spec
1 Summary:        Mingw32 Binary Utility Development Utilities - Win32 API libraries
2 Summary(pl):    Zestaw narzêdzi mingw32 - biblioteki API Win32
3 Name:           crossmingw32-w32api
4 Version:        2.5
5 %define apiver  %{version}
6 %define apisrc  w32api-%{apiver}
7 %define runver  3.3
8 %define runsrc  mingw-runtime-%{runver}
9 Release:        5
10 Epoch:          1
11 License:        Free
12 Group:          Development/Libraries
13 Source0:        http://dl.sourceforge.net/mingw/%{apisrc}-src.tar.gz
14 # Source0-md5:  395369c2c0c67394e54855f7516de3d3
15 # only for headers
16 Source1:        http://dl.sourceforge.net/mingw/%{runsrc}-src.tar.gz
17 # Source1-md5:  21e9970d7c828eabd380132aa806dd41
18 Source2:        http://oss.sgi.com/projects/ogl-sample/ABI/glext.h
19 # NoSource2-md5:        a5738dcfa20119fa3e06ce479ca94acf
20 URL:            http://www.mingw.org/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  crossmingw32-gcc
24 Requires:       crossmingw32-binutils >= 2.14.90.0.4.1-2
25 Obsoletes:      crossmingw32-platform
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         target          i386-mingw32
29 %define         target_platform i386-pc-mingw32
30 %define         _prefix         /usr/%{target}
31 %define         _libdir         %{_prefix}/lib
32
33 # strip fails on static COFF files
34 %define         no_install_post_strip 1
35
36 %ifarch alpha sparc sparc64 sparcv9
37 # alpha's -mieee and sparc's -mtune=* are not valid for target's gcc
38 %define         optflags        -O2
39 %endif
40
41 %description
42 crossmingw32 is a complete cross-compiling development system for
43 building stand-alone Microsoft Windows applications under Linux using
44 the Mingw32 build libraries. This includes a binutils, gcc with g++
45 and objc, and libstdc++, all cross targeted to i386-mingw32, along
46 with supporting Win32 libraries in 'coff' format from free sources.
47
48 This package contains Win32 API includes and libraries.
49
50 %description -l pl
51 crossmingw32 jest kompletnym systemem do kompilacji skro¶nej,
52 pozwalaj±cym budowaæ aplikacje MS Windows pod Linuksem u¿ywaj±c
53 bibliotek mingw32. System sk³ada siê z binutils, gcc z g++ i objc,
54 libstdc++ - wszystkie generuj±ce kod dla platformy i386-mingw32, oraz
55 z bibliotek w formacie COFF.
56
57 Ten pakiet zawiera pliki nag³ówkowe i biblioteki Win32 API.
58
59 %package dx
60 Summary:        DirectX from MinGW Win32 API
61 Summary(pl):    DirectX z API Win32 dla MinGW
62 Group:          Development/Libraries
63 Requires:       %{name} = %{epoch}:%{version}-%{release}
64
65 %description dx
66 DirectX from MinGW Win32 API.
67
68 %description dx -l pl
69 DirectX z API Win32 dla MinGW.
70
71 %prep
72 %setup -q -n w32api-%{version} -a1
73
74 %build
75 cp /usr/share/automake/config.sub .
76 %{__autoconf}
77 ./configure \
78         --prefix=%{_prefix} \
79         --host=%{target} \
80         --build=%{_target_platform} \
81         CFLAGS="-I`pwd`/%{runsrc}/include %{rpmcflags}"
82
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         inst_libdir=$RPM_BUILD_ROOT%{_libdir} \
90         inst_includedir=$RPM_BUILD_ROOT%{_includedir}
91
92 %{!?debug:%{target}-strip -g $RPM_BUILD_ROOT%{_libdir}/*.a}
93
94 install %{SOURCE2} $RPM_BUILD_ROOT%{_includedir}/GL
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(644,root,root,755)
101 %dir %{_includedir}
102 %{_includedir}/*
103 %{_libdir}/lib[!d]*.a
104 %{_libdir}/libdlcapi.a
105 %{_libdir}/libdxapi.a
106 %exclude %{_libdir}/libglut.a
107
108 %files dx
109 %defattr(644,root,root,755)
110 %{_libdir}/libd[!lx]*.a
111 %{_libdir}/libdxguid.a
This page took 0.063209 seconds and 2 git commands to generate.