]> git.pld-linux.org Git - packages/crossmingw32-std-threads.git/commitdiff
- added include patch (mutex header needs <cstdio>) auto/th/crossmingw32-std-threads-0-0.20160317.1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 25 Jun 2016 07:40:37 +0000 (09:40 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 25 Jun 2016 07:40:37 +0000 (09:40 +0200)
crossmingw32-std-threads.spec
mingw-std-threads-include.patch [new file with mode: 0644]

index f452ea9ad65b568ba82e664a51160d2443e9907a..48a3db904bd53bdd8446d072090ada3bffcda6d2 100644 (file)
@@ -9,8 +9,11 @@ License:       BSD
 Group:         Development/Libraries
 Source0:       https://github.com/meganz/mingw-std-threads/archive/%{gitref}/mingw-std-threads-%{snap}.tar.gz
 # Source0-md5: e5f0fcdb69d99ab493f45e65767f9346
+Patch0:                mingw-std-threads-include.patch
 URL:           https://github.com/meganz/mingw-std-threads
 Requires:      crossmingw32-gcc-c++ >= 1:4.7
+Requires:      crossmingw32-runtime
+Requires:      crossmingw32-w32api
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                no_install_post_strip   1
@@ -33,6 +36,7 @@ brakujÄ…cych w GCC dla MinGW.
 
 %prep
 %setup -q -n mingw-std-threads-%{gitref}
+%patch0 -p1
 
 %install
 rm -rf $RPM_BUILD_ROOT
diff --git a/mingw-std-threads-include.patch b/mingw-std-threads-include.patch
new file mode 100644 (file)
index 0000000..ddbce84
--- /dev/null
@@ -0,0 +1,19 @@
+--- mingw-std-threads-b7e670d91d33b7ce5836c6255d37e69f17eb3687/mingw.mutex.h.orig      2016-03-16 15:05:58.000000000 +0100
++++ mingw-std-threads-b7e670d91d33b7ce5836c6255d37e69f17eb3687/mingw.mutex.h   2016-06-25 09:17:48.884289745 +0200
+@@ -41,6 +41,7 @@
\r
+ #include <windows.h>\r
+ #include <chrono>\r
++#include <cstdio>\r
+ #include <system_error>\r
\r
+ #ifndef EPROTO\r
+@@ -105,7 +106,7 @@
+         DWORD self = GetCurrentThreadId();\r
+         if (mOwnerThread == self)\r
+         {\r
+-            fprintf(stderr, "FATAL: Recursive locking or non-recursive mutex detected. Throwing sysetm exception\n");\r
++            fprintf(stderr, "FATAL: Recursive locking or non-recursive mutex detected. Throwing system exception\n");\r
+             fflush(stderr);\r
+             throw system_error(EDEADLK, generic_category());\r
+         }\r
This page took 0.060511 seconds and 4 git commands to generate.