]> git.pld-linux.org Git - packages/crossmingw32-runtime.git/blob - crossmingw32-runtime.spec
9f869e74bdb64e6fab10ba789349d7a2a0fd08ee
[packages/crossmingw32-runtime.git] / crossmingw32-runtime.spec
1 Summary:        Mingw32 Binary Utility Development Utilities - runtime libraries
2 Summary(pl.UTF-8):      Zestaw narzędzi mingw32 - biblioteki uruchomieniowe
3 Name:           crossmingw32-runtime
4 Version:        3.11
5 %define runver  %{version}
6 %define runsrc  mingw-runtime-%{runver}
7 Release:        1
8 Epoch:          1
9 License:        Free
10 Group:          Development/Libraries
11 Source0:        http://dl.sourceforge.net/mingw/%{runsrc}-src.tar.gz
12 # Source0-md5:  642a9619b32fbf20602a6c8517b578df
13 Patch0:         %{name}-stdinc.patch
14 Patch1:         %{name}-configure.patch
15 URL:            http://www.mingw.org/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  crossmingw32-binutils
19 BuildRequires:  crossmingw32-gcc
20 BuildRequires:  crossmingw32-w32api
21 BuildRequires:  dos2unix
22 Requires:       crossmingw32-binutils >= 2.15.91.0.2-2
23 Requires:       crossmingw32-w32api >= 3.1
24 Obsoletes:      crossmingw32-platform
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29 %define         _prefix                 /usr/%{target}
30 %define         _libdir                 %{_prefix}/lib
31
32 # strip fails on static COFF files
33 %define         no_install_post_strip 1
34
35 %description
36 crossmingw32 is a complete cross-compiling development system for
37 building stand-alone Microsoft Windows applications under Linux using
38 the Mingw32 build libraries. This includes a binutils, gcc with g++
39 and objc, and libstdc++, all cross targeted to i386-mingw32, along
40 with supporting Win32 libraries in 'coff' format from free sources.
41
42 This package contains MinGW32 runtime includes and libraries.
43
44 %description -l pl.UTF-8
45 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
46 pozwalającym budować aplikacje MS Windows pod Linuksem używając
47 bibliotek mingw32. System składa się z binutils, gcc z g++ i objc,
48 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
49 z bibliotek w formacie COFF.
50
51 Ten pakiet zawiera pliki nagłówkowe i biblioteki uruchomieniowe
52 MinGW32.
53
54 %prep
55 %setup -q -n %{runsrc}
56 dos2unix Makefile.in configure.in mkinstalldirs */Makefile.in */configure.in
57 %patch0 -p1 
58 %patch1 -p1
59
60 %build
61 cp /usr/share/automake/config.sub .
62 %{__autoconf}
63 cd mingwex
64 cp /usr/share/automake/config.sub .
65 %{__autoconf}
66 cd ../profile
67 cp /usr/share/automake/config.sub .
68 %{__autoconf}
69 cd ..
70 ./configure \
71         --prefix=%{_prefix} \
72         --host=%{target} \
73         --build=%{_target_platform}
74 %{__make} -C mingwex
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         prefix=$RPM_BUILD_ROOT%{_prefix}
82
83 %if %{!?debug:1}0
84 %{target}-strip $RPM_BUILD_ROOT%{_bindir}/*.dll
85 %{target}-strip -g $RPM_BUILD_ROOT%{_libdir}/*.a
86 %endif
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc CONTRIBUTORS ChangeLog DISCLAIMER README TODO readme.txt
94 %{_bindir}/*
95 %{_includedir}/*
96 %{_libdir}/*
This page took 0.534687 seconds and 2 git commands to generate.