]> git.pld-linux.org Git - packages/crossmingw32-pcre.git/blame - crossmingw32-pcre.spec
- added filterout_c
[packages/crossmingw32-pcre.git] / crossmingw32-pcre.spec
CommitLineData
2876ab7f 1%define realname pcre
d9829e32
JB
2Summary: Perl-Compatible Regular Expression library - MinGW32 cross version
3Summary(pl.UTF-8): Biblioteka perlowych wyrażeń regularnych - wersja skrośna dla MinGW32
2876ab7f 4Name: crossmingw32-%{realname}
28f67091 5Version: 8.31
c09a8252 6Release: 1
b7e23f90 7License: BSD (see LICENCE)
24089856 8Group: Development/Libraries
2876ab7f 9Source0: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{realname}-%{version}.tar.bz2
28f67091 10# Source0-md5: 1c9a276af932b5599157f96e945391f0
a8625b8f 11URL: http://www.pcre.org/
07565286 12BuildRequires: autoconf >= 2.57
2876ab7f 13BuildRequires: automake
c09a8252 14BuildRequires: crossmingw32-gcc-c++
2876ab7f 15BuildRequires: crossmingw32-w32api
efbabe07 16BuildRequires: libtool >= 2:1.5
c09a8252 17Requires: crossmingw32-runtime
2876ab7f 18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%define no_install_post_strip 1
21
22%define target i386-mingw32
23%define target_platform i386-pc-mingw32
24089856
JB
24
25%define _prefix /usr/%{target}
2f7fb64a 26%define _libdir %{_prefix}/lib
24089856
JB
27%define _pkgconfigdir %{_prefix}/lib/pkgconfig
28%define _dlldir /usr/share/wine/windows/system
2876ab7f 29
30%define __cc %{target}-gcc
31%define __cxx %{target}-g++
32
e810adc9
JB
33%ifnarch %{ix86}
34# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
1bb0a7f6 35%define optflags -O2
36%endif
38b25bc4 37# -z options are invalid for mingw linker, most of -f options are Linux-specific
e810adc9 38%define filterout_ld -Wl,-z,.*
38b25bc4 39%define filterout_c -f[-a-z0-9=]*
1bb0a7f6 40
2876ab7f 41%description
42PCRE stands for the Perl Compatible Regular Expression library. It
43contains routines to match text against regular expressions similar to
44Perl's. It also contains a POSIX compatibility library.
45
3dc1d236
JR
46%description -l pl.UTF-8
47PCRE (Perl-Compatible Regular Expression) oznacza bibliotekę wyrażeń
48regularnych kompatybilnych z perlowymi. Zawiera funkcje dopasowujące
49tekst do wyrażeń regularnych podobnych do tych znanych z Perla.
50Zawiera także bibliotekę kompatybilną z POSIX.
2876ab7f 51
24089856 52%package static
d9829e32
JB
53Summary: Static PCRE libraries (cross MinGW32 version)
54Summary(pl.UTF-8): Statyczne biblioteki PCRE (wersja skrośna MinGW32)
24089856
JB
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57
58%description static
d9829e32 59Static PCRE libraries (cross MinGW32 version).
24089856
JB
60
61%description static -l pl.UTF-8
d9829e32 62Statyczne biblioteki PCRE (wersja skrośna MinGW32).
24089856 63
2876ab7f 64%package dll
481ebdca 65Summary: %{realname} - DLL libraries for Windows
627f2614 66Summary(pl.UTF-8): %{realname} - biblioteki DLL dla Windows
2876ab7f 67Group: Applications/Emulators
24089856 68Requires: wine
2876ab7f 69
70%description dll
481ebdca 71%{realname} - DLL libraries for Windows.
2876ab7f 72
3dc1d236 73%description dll -l pl.UTF-8
481ebdca 74%{realname} - biblioteki DLL dla Windows.
2876ab7f 75
76%prep
77%setup -q -n %{realname}-%{version}
2876ab7f 78
79%build
2876ab7f 80%{__libtoolize}
81%{__aclocal}
82%{__autoconf}
24089856
JB
83%{__autoheader}
84%{__automake}
2876ab7f 85%configure \
24089856 86 --host=%{target} \
1bb0a7f6 87 --target=%{target} \
efbabe07
JB
88 --enable-jit \
89 --enable-pcre16 \
24089856
JB
90 --enable-unicode-properties \
91 --enable-utf8
92
93%{__make}
94
95%install
96rm -rf $RPM_BUILD_ROOT
2876ab7f 97
24089856
JB
98%{__make} install \
99 DESTDIR=$RPM_BUILD_ROOT
1bb0a7f6 100
24089856
JB
101install -d $RPM_BUILD_ROOT%{_dlldir}
102mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
2876ab7f 103
104%if 0%{!?debug:1}
24089856
JB
105%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
106%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
2876ab7f 107%endif
108
efbabe07 109%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{doc,man}
2876ab7f 110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%files
115%defattr(644,root,root,755)
24089856
JB
116%doc AUTHORS ChangeLog LICENCE NEWS NON-UNIX-USE README
117%{_libdir}/libpcre.dll.a
efbabe07 118%{_libdir}/libpcre16.dll.a
24089856
JB
119%{_libdir}/libpcrecpp.dll.a
120%{_libdir}/libpcreposix.dll.a
121%{_libdir}/libpcre.la
efbabe07 122%{_libdir}/libpcre16.la
24089856
JB
123%{_libdir}/libpcrecpp.la
124%{_libdir}/libpcreposix.la
125%{_includedir}/pcre*.h
126%{_pkgconfigdir}/libpcre.pc
efbabe07 127%{_pkgconfigdir}/libpcre16.pc
24089856 128%{_pkgconfigdir}/libpcrecpp.pc
59b8d627 129%{_pkgconfigdir}/libpcreposix.pc
24089856
JB
130
131%files static
132%defattr(644,root,root,755)
133%{_libdir}/libpcre.a
efbabe07 134%{_libdir}/libpcre16.a
24089856
JB
135%{_libdir}/libpcrecpp.a
136%{_libdir}/libpcreposix.a
2876ab7f 137
138%files dll
139%defattr(644,root,root,755)
efbabe07
JB
140%{_dlldir}/libpcre-1.dll
141%{_dlldir}/libpcre16-0.dll
142%{_dlldir}/libpcrecpp-0.dll
143%{_dlldir}/libpcreposix-0.dll
This page took 0.093355 seconds and 4 git commands to generate.