]> git.pld-linux.org Git - packages/crossmingw32-pangomm.git/blame - crossmingw32-pangomm.spec
- updated to 2.42.2
[packages/crossmingw32-pangomm.git] / crossmingw32-pangomm.spec
CommitLineData
d12a0496
JB
1Summary: A C++ interface for pango library - cross MinGW32 version
2Summary(pl.UTF-8): Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32
7ef93766 3Name: crossmingw32-pangomm
81e228a4 4Version: 2.42.2
351a5463 5Release: 1
7ef93766
JB
6License: LGPL v2+
7Group: Development/Libraries
81e228a4
JB
8Source0: https://download.gnome.org/sources/pangomm/2.42/pangomm-%{version}.tar.xz
9# Source0-md5: 85707ce52628b6a3c3caf245095ba6d5
12affd2e 10URL: https://www.gtkmm.org/
7ef93766 11BuildRequires: autoconf >= 2.59
b684277f 12BuildRequires: automake >= 1:1.11
40f420a2 13BuildRequires: crossmingw32-cairomm >= 1.12.0
96a2f5e4 14BuildRequires: crossmingw32-gcc-c++ >= 1:4.7
5eec1e2f 15BuildRequires: crossmingw32-glibmm >= 2.48.0
96a2f5e4 16BuildRequires: crossmingw32-pango >= 1.41.0
81e228a4
JB
17# for gmmproc tools
18BuildRequires: glibmm-devel >= 2.46.2
accc7186 19BuildRequires: libtool >= 2:2.0
96a2f5e4 20BuildRequires: mm-common >= 0.9.10
7ef93766 21BuildRequires: pkgconfig >= 1:0.15
b684277f 22BuildRequires: rpmbuild(macros) >= 1.446
5e1672ab
JB
23BuildRequires: tar >= 1:1.22
24BuildRequires: xz
40f420a2 25Requires: crossmingw32-cairomm >= 1.12.0
96a2f5e4 26Requires: crossmingw32-gcc-c++ >= 1:4.7
5eec1e2f 27Requires: crossmingw32-glibmm >= 2.48.0
96a2f5e4 28Requires: crossmingw32-pango >= 1.41.0
7ef93766
JB
29Provides: crossmingw32-gtkmm-pango
30Obsoletes: crossmingw32-gtkmm-pango
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%define no_install_post_strip 1
34
35%define target i386-mingw32
36%define target_platform i386-pc-mingw32
37
38%define _sysprefix /usr
39%define _prefix %{_sysprefix}/%{target}
40%define _libdir %{_prefix}/lib
41%define _pkgconfigdir %{_prefix}/lib/pkgconfig
42%define _dlldir /usr/share/wine/windows/system
43%define __cc %{target}-gcc
44%define __cxx %{target}-g++
42df9968 45%define __pkgconfig_provides %{nil}
0902db15 46%define __pkgconfig_requires %{nil}
7ef93766 47
4fe9972e 48%define _ssp_cflags %{nil}
7ef93766
JB
49%ifnarch %{ix86}
50# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
51%define optflags -O2
52%endif
ab466ace 53# -z options are invalid for mingw linker, most of -f options are Linux-specific
7ef93766 54%define filterout_ld -Wl,-z,.*
8084f475 55%define filterout_c -f[-a-z0-9=]*
7ef93766
JB
56
57%description
d12a0496 58A C++ interface for pango library - cross MinGW32 version.
7ef93766
JB
59
60%description -l pl.UTF-8
d12a0496 61Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32.
7ef93766
JB
62
63%package static
d12a0496
JB
64Summary: Static pangomm library (cross MinGW32 version)
65Summary(pl.UTF-8): Statyczna biblioteka pangomm (wersja skrośna MinGW32)
7ef93766
JB
66Group: Development/Libraries
67Requires: %{name} = %{version}-%{release}
68Provides: crossmingw32-gtkmm-pango-static
69Obsoletes: crossmingw32-gtkmm-pango-static
70
71%description static
d12a0496 72Static pangomm library (cross MinGW32 version).
7ef93766
JB
73
74%description static -l pl.UTF-8
d12a0496 75Statyczna biblioteka pangomm (wersja skrośna MinGW32).
7ef93766
JB
76
77%package dll
78Summary: DLL pangomm library for Windows
79Summary(pl.UTF-8): Biblioteka DLL pangomm dla Windows
80Group: Applications/Emulators
40f420a2 81Requires: crossmingw32-cairomm-dll >= 1.12.0
5eec1e2f 82Requires: crossmingw32-glibmm-dll >= 2.48.0
96a2f5e4 83Requires: crossmingw32-pango-dll >= 1.41.0
7ef93766
JB
84Requires: wine
85Provides: crossmingw32-gtkmm-pango-dll
86Obsoletes: crossmingw32-gtkmm-pango-dll
87
88%description dll
89DLL pangomm library for Windows.
90
91%description dll -l pl.UTF-8
92Biblioteka DLL pangomm dla Windows.
93
94%prep
95%setup -q -n pangomm-%{version}
96
97%build
81e228a4
JB
98# use host gmmprocdir (before changing PKG_CONFIG_LIBDIR to cross target)
99GMMPROC_DIR=$(pkg-config --variable=gmmprocdir glibmm-2.4)
b684277f 100export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
81e228a4 101mm-common-prepare --copy --force
7ef93766 102%{__libtoolize}
aa1fb165 103%{__aclocal} -I build
7ef93766
JB
104%{__autoconf}
105%{__autoheader}
106%{__automake}
8084f475
JB
107# std-threads required by glibmm requires at least WinXP API
108CPPFLAGS="%{rpmcppflags} -DWINVER=0x0501"
7ef93766
JB
109%configure \
110 --target=%{target} \
111 --host=%{target} \
aa1fb165 112 --disable-documentation \
81e228a4 113 --enable-maintainer-mode \
5a97095e 114 --disable-silent-rules \
7ef93766
JB
115 --enable-static
116
81e228a4
JB
117%{__make} \
118 GMMPROC_DIR="$GMMPROC_DIR"
7ef93766
JB
119
120%install
121rm -rf $RPM_BUILD_ROOT
122
123%{__make} install \
124 DESTDIR=$RPM_BUILD_ROOT
125
126install -d $RPM_BUILD_ROOT%{_dlldir}
40f420a2 127%{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
7ef93766 128
12affd2e
JB
129%{__rm} $RPM_BUILD_ROOT%{_libdir}/libpangomm-*.la
130
7ef93766
JB
131%if 0%{!?debug:1}
132%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
133%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
134%endif
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%files
140%defattr(644,root,root,755)
141%doc AUTHORS ChangeLog NEWS README
142%{_libdir}/libpangomm-1.4.dll.a
7ef93766
JB
143%{_libdir}/pangomm-1.4
144%{_includedir}/pangomm-1.4
145%{_pkgconfigdir}/pangomm-1.4.pc
146
147%files static
148%defattr(644,root,root,755)
149%{_libdir}/libpangomm-1.4.a
150
151%files dll
152%defattr(644,root,root,755)
fd50b6af 153%{_dlldir}/libpangomm-1.4-1.dll
This page took 0.756898 seconds and 4 git commands to generate.