]> git.pld-linux.org Git - packages/crossmingw32-pangomm.git/blame - crossmingw32-pangomm.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-pangomm.git] / crossmingw32-pangomm.spec
CommitLineData
d12a0496
JB
1Summary: A C++ interface for pango library - cross MinGW32 version
2Summary(pl.UTF-8): Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32
7ef93766 3Name: crossmingw32-pangomm
accc7186 4Version: 2.28.4
42df9968 5Release: 2
7ef93766
JB
6License: LGPL v2+
7Group: Development/Libraries
5e1672ab 8Source0: http://ftp.gnome.org/pub/GNOME/sources/pangomm/2.28/pangomm-%{version}.tar.xz
accc7186 9# Source0-md5: f4fe0905ee56e1ff0205005e61d2a66f
7ef93766
JB
10URL: http://www.gtkmm.org/
11BuildRequires: autoconf >= 2.59
b684277f 12BuildRequires: automake >= 1:1.11
7ef93766
JB
13BuildRequires: crossmingw32-cairomm >= 1.6.3
14BuildRequires: crossmingw32-gcc-c++
d12a0496 15BuildRequires: crossmingw32-glibmm >= 2.22.0
b5bb7627 16BuildRequires: crossmingw32-pango >= 1.24.0
accc7186 17BuildRequires: libtool >= 2:2.0
b775d524 18BuildRequires: mm-common >= 0.9.5
7ef93766 19BuildRequires: pkgconfig >= 1:0.15
b684277f 20BuildRequires: rpmbuild(macros) >= 1.446
5e1672ab
JB
21BuildRequires: tar >= 1:1.22
22BuildRequires: xz
7ef93766 23Requires: crossmingw32-cairomm >= 1.6.3
d02042ea 24Requires: crossmingw32-glibmm >= 2.22.0
b5bb7627 25Requires: crossmingw32-pango >= 1.24.0
7ef93766
JB
26Provides: crossmingw32-gtkmm-pango
27Obsoletes: crossmingw32-gtkmm-pango
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%define no_install_post_strip 1
31
32%define target i386-mingw32
33%define target_platform i386-pc-mingw32
34
35%define _sysprefix /usr
36%define _prefix %{_sysprefix}/%{target}
37%define _libdir %{_prefix}/lib
38%define _pkgconfigdir %{_prefix}/lib/pkgconfig
39%define _dlldir /usr/share/wine/windows/system
40%define __cc %{target}-gcc
41%define __cxx %{target}-g++
42df9968 42%define __pkgconfig_provides %{nil}
7ef93766
JB
43
44%ifnarch %{ix86}
45# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
46%define optflags -O2
47%endif
48# -z options are invalid for mingw linker
49%define filterout_ld -Wl,-z,.*
50
51%description
d12a0496 52A C++ interface for pango library - cross MinGW32 version.
7ef93766
JB
53
54%description -l pl.UTF-8
d12a0496 55Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32.
7ef93766
JB
56
57%package static
d12a0496
JB
58Summary: Static pangomm library (cross MinGW32 version)
59Summary(pl.UTF-8): Statyczna biblioteka pangomm (wersja skrośna MinGW32)
7ef93766
JB
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
62Provides: crossmingw32-gtkmm-pango-static
63Obsoletes: crossmingw32-gtkmm-pango-static
64
65%description static
d12a0496 66Static pangomm library (cross MinGW32 version).
7ef93766
JB
67
68%description static -l pl.UTF-8
d12a0496 69Statyczna biblioteka pangomm (wersja skrośna MinGW32).
7ef93766
JB
70
71%package dll
72Summary: DLL pangomm library for Windows
73Summary(pl.UTF-8): Biblioteka DLL pangomm dla Windows
74Group: Applications/Emulators
75Requires: crossmingw32-cairomm-dll >= 1.6.3
d02042ea 76Requires: crossmingw32-glibmm-dll >= 2.22.0
b5bb7627 77Requires: crossmingw32-pango-dll >= 1.24.0
7ef93766
JB
78Requires: wine
79Provides: crossmingw32-gtkmm-pango-dll
80Obsoletes: crossmingw32-gtkmm-pango-dll
81
82%description dll
83DLL pangomm library for Windows.
84
85%description dll -l pl.UTF-8
86Biblioteka DLL pangomm dla Windows.
87
88%prep
89%setup -q -n pangomm-%{version}
90
91%build
b684277f 92export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
7ef93766 93%{__libtoolize}
aa1fb165 94%{__aclocal} -I build
7ef93766
JB
95%{__autoconf}
96%{__autoheader}
97%{__automake}
98%configure \
99 --target=%{target} \
100 --host=%{target} \
aa1fb165 101 --disable-documentation \
5a97095e 102 --disable-silent-rules \
7ef93766
JB
103 --enable-static
104
105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110%{__make} install \
111 DESTDIR=$RPM_BUILD_ROOT
112
113install -d $RPM_BUILD_ROOT%{_dlldir}
114mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
115
116%if 0%{!?debug:1}
117%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
118%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
119%endif
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%files
125%defattr(644,root,root,755)
126%doc AUTHORS ChangeLog NEWS README
127%{_libdir}/libpangomm-1.4.dll.a
128%{_libdir}/libpangomm-1.4.la
129%{_libdir}/pangomm-1.4
130%{_includedir}/pangomm-1.4
131%{_pkgconfigdir}/pangomm-1.4.pc
132
133%files static
134%defattr(644,root,root,755)
135%{_libdir}/libpangomm-1.4.a
136
137%files dll
138%defattr(644,root,root,755)
139%{_dlldir}/libpangomm-1.4-*.dll
This page took 0.287293 seconds and 4 git commands to generate.