]> git.pld-linux.org Git - packages/crossmingw32-pango.git/blobdiff - crossmingw32-pango.spec
- x32 rebuild
[packages/crossmingw32-pango.git] / crossmingw32-pango.spec
index aa2e57c88382e0ae65a87e6dd5168257504cf666..d1e410a44b4bada4d44a45d407735ae7a2c42d3c 100644 (file)
@@ -1,31 +1,33 @@
-Summary:       System for layout and rendering of internationalized text - cross Mingw32 version
-Summary(pl.UTF-8):     System renderowania międzynarodowego tekstu - wersja skrośna dla Mingw32
+Summary:       System for layout and rendering of internationalized text - cross MinGW32 version
+Summary(pl.UTF-8):     System renderowania międzynarodowego tekstu - wersja skrośna dla MinGW32
 %define                realname   pango
 Name:          crossmingw32-%{realname}
-Version:       1.20.2
-Release:       1
+Version:       1.36.8
+Release:       3
 License:       LGPL v2+
 Group:         Development/Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/pango/1.20/%{realname}-%{version}.tar.bz2
-# Source0-md5: b90d82bb5a92c7dd346c1eac97285e37
-Patch0:                %{realname}-xfonts.patch
-Patch1:                %{realname}-lt.patch
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/pango/1.36/%{realname}-%{version}.tar.xz
+# Source0-md5: 217a9a753006275215fa9fa127760ece
 URL:           http://www.pango.org/
 BuildRequires: autoconf >= 2.59-9
 BuildRequires: automake >= 1:1.9
-BuildRequires: crossmingw32-cairo >= 1.4.10
-BuildRequires: crossmingw32-fontconfig >= 2.4.0
+BuildRequires: crossmingw32-cairo >= 1.12.10
+BuildRequires: crossmingw32-fontconfig >= 2.10.91
 BuildRequires: crossmingw32-freetype >= 2.1.7
 BuildRequires: crossmingw32-gcc
-BuildRequires: crossmingw32-glib2 >= 2.16.3
+BuildRequires: crossmingw32-glib2 >= 2.34.0
+BuildRequires: crossmingw32-harfbuzz >= 0.9.9
 BuildRequires: libtool >= 1:1.4.2-9
 BuildRequires: perl-base
 BuildRequires: pkgconfig >= 1:0.15
 BuildRequires: rpmbuild(macros) >= 1.197
-Requires:      crossmingw32-cairo >= 1.4.10
-Requires:      crossmingw32-fontconfig >= 2.4.0
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
+Requires:      crossmingw32-cairo >= 1.12.10
+Requires:      crossmingw32-fontconfig >= 2.10.91
 Requires:      crossmingw32-freetype >= 2.1.7
-Requires:      crossmingw32-glib2 >= 2.16.3
+Requires:      crossmingw32-glib2 >= 2.34.0
+Requires:      crossmingw32-harfbuzz >= 0.9.9
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                no_install_post_strip   1
@@ -40,23 +42,35 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _dlldir                 /usr/share/wine/windows/system
 %define                __cc                    %{target}-gcc
 %define                __cxx                   %{target}-g++
+%define                __pkgconfig_provides    %{nil}
+%define                __pkgconfig_requires    %{nil}
+
+%define                _ssp_cflags             %{nil}
+%ifnarch %{ix86}
+# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
+%define                optflags        -O2
+%endif
+# -z options are invalid for mingw linker, most of -f options are Linux-specific
+%define                filterout_ld    -Wl,-z,.*
+%define                filterout_c     -f[-a-z0-9=]*
 
 %description
 System for layout and rendering of internationalized text (cross
-mingw32 version).
+MinGW32 version).
 
 %description -l pl.UTF-8
 System obsługi i renderowania międzynarodowego tekstu (wersja skrośna
-mingw32).
+MinGW32).
 
 %package dll
 Summary:       DLL pango libraries for Windows
 Summary(pl.UTF-8):     Biblioteki DLL pango dla Windows
 Group:         Applications/Emulators
-Requires:      crossmingw32-cairo-dll >= 1.4.10
-Requires:      crossmingw32-fontconfig-dll >= 2.4.0
+Requires:      crossmingw32-cairo-dll >= 1.12.10
+Requires:      crossmingw32-fontconfig-dll >= 2.10.91
 Requires:      crossmingw32-freetype-dll >= 2.1.7
-Requires:      crossmingw32-glib2-dll >= 2.16.3
+Requires:      crossmingw32-glib2-dll >= 2.34.0
+Requires:      crossmingw32-harfbuzz-dll >= 0.9.9
 Requires:      wine
 
 %description dll
@@ -67,8 +81,6 @@ Biblioteki DLL pango dla Windows.
 
 %prep
 %setup -q -n %{realname}-%{version}
-%patch0 -p1
-%patch1 -p1
 
 %build
 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
@@ -80,8 +92,7 @@ export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
 %configure \
        --target=%{target} \
        --host=%{target} \
-       --with-fribidi \
-       --enable-static
+       --disable-silent-rules
 
 %{__make}
 
@@ -97,14 +108,19 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}/pango
 install -d $RPM_BUILD_ROOT%{_dlldir}
 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
 
+# omitted from make install
+for f in pango pangocairo pangoft2 pangowin32 ; do
+       cp -p pango/${f}.def $RPM_BUILD_ROOT%{_libdir}/${f}-1.0.def
+done
+
 %if 0%{!?debug:1}
 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
 %endif
 
-rm -rf $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,man}
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,man}
 # useless (modules loaded through libgmodule)
-rm -f $RPM_BUILD_ROOT%{_libdir}/pango/1.6.0/modules/*.{la,a}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/pango/1.8.0/modules/*.{la,a}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -136,3 +152,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_dlldir}/libpangocairo-1.0-*.dll
 %{_dlldir}/libpangoft2-1.0-*.dll
 %{_dlldir}/libpangowin32-1.0-*.dll
+%dir %{_libdir}/pango
+%dir %{_libdir}/pango/1.8.0
+%dir %{_libdir}/pango/1.8.0/modules
+%{_libdir}/pango/1.8.0/modules/*.dll
This page took 0.119214 seconds and 4 git commands to generate.