]> git.pld-linux.org Git - packages/crossmingw32-pango.git/blob - crossmingw32-pango.spec
9bab2a6654a75faeab1d10a46f4ee48fc3536ca4
[packages/crossmingw32-pango.git] / crossmingw32-pango.spec
1 Summary:        System for layout and rendering of internationalized text - cross MinGW32 version
2 Summary(pl.UTF-8):      System renderowania międzynarodowego tekstu - wersja skrośna dla MinGW32
3 %define         realname   pango
4 Name:           crossmingw32-%{realname}
5 Version:        1.36.8
6 Release:        2
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pango/1.36/%{realname}-%{version}.tar.xz
10 # Source0-md5:  217a9a753006275215fa9fa127760ece
11 URL:            http://www.pango.org/
12 BuildRequires:  autoconf >= 2.59-9
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  crossmingw32-cairo >= 1.12.10
15 BuildRequires:  crossmingw32-fontconfig >= 2.10.91
16 BuildRequires:  crossmingw32-freetype >= 2.1.7
17 BuildRequires:  crossmingw32-gcc
18 BuildRequires:  crossmingw32-glib2 >= 2.34.0
19 BuildRequires:  crossmingw32-harfbuzz >= 0.9.9
20 BuildRequires:  libtool >= 1:1.4.2-9
21 BuildRequires:  perl-base
22 BuildRequires:  pkgconfig >= 1:0.15
23 BuildRequires:  rpmbuild(macros) >= 1.197
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 Requires:       crossmingw32-cairo >= 1.12.10
27 Requires:       crossmingw32-fontconfig >= 2.10.91
28 Requires:       crossmingw32-freetype >= 2.1.7
29 Requires:       crossmingw32-glib2 >= 2.34.0
30 Requires:       crossmingw32-harfbuzz >= 0.9.9
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         no_install_post_strip   1
34
35 %define         target                  i386-mingw32
36 %define         target_platform         i386-pc-mingw32
37
38 %define         _sysprefix              /usr
39 %define         _prefix                 %{_sysprefix}/%{target}
40 %define         _libdir                 %{_prefix}/lib
41 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
42 %define         _dlldir                 /usr/share/wine/windows/system
43 %define         __cc                    %{target}-gcc
44 %define         __cxx                   %{target}-g++
45 %define         __pkgconfig_provides    %{nil}
46 %define         __pkgconfig_requires    %{nil}
47
48 %define         _ssp_cflags             %{nil}
49 %ifnarch %{ix86}
50 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
51 %define         optflags        -O2
52 %endif
53 # -z options are invalid for mingw linker, most of -f options are Linux-specific
54 %define         filterout_ld    -Wl,-z,.*
55 %define         filterout_c     -f[-a-z0-9=]*
56
57 %description
58 System for layout and rendering of internationalized text (cross
59 MinGW32 version).
60
61 %description -l pl.UTF-8
62 System obsługi i renderowania międzynarodowego tekstu (wersja skrośna
63 MinGW32).
64
65 %package dll
66 Summary:        DLL pango libraries for Windows
67 Summary(pl.UTF-8):      Biblioteki DLL pango dla Windows
68 Group:          Applications/Emulators
69 Requires:       crossmingw32-cairo-dll >= 1.12.10
70 Requires:       crossmingw32-fontconfig-dll >= 2.10.91
71 Requires:       crossmingw32-freetype-dll >= 2.1.7
72 Requires:       crossmingw32-glib2-dll >= 2.34.0
73 Requires:       crossmingw32-harfbuzz-dll >= 0.9.9
74 Requires:       wine
75
76 %description dll
77 DLL pango libraries for Windows.
78
79 %description dll -l pl.UTF-8
80 Biblioteki DLL pango dla Windows.
81
82 %prep
83 %setup -q -n %{realname}-%{version}
84
85 %build
86 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
87 %{__libtoolize}
88 %{__aclocal}
89 %{__autoheader}
90 %{__autoconf}
91 %{__automake}
92 %configure \
93         --target=%{target} \
94         --host=%{target} \
95         --disable-silent-rules
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 # missing from make install but required by it
103 install -d $RPM_BUILD_ROOT%{_sysconfdir}/pango
104
105 %{__make} -j1 install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 install -d $RPM_BUILD_ROOT%{_dlldir}
109 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
110
111 # omitted from make install
112 for f in pango pangocairo pangoft2 pangowin32 ; do
113         cp -p pango/${f}.def $RPM_BUILD_ROOT%{_libdir}/${f}-1.0.def
114 done
115
116 %if 0%{!?debug:1}
117 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
118 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
119 %endif
120
121 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,man}
122 # useless (modules loaded through libgmodule)
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pango/1.8.0/modules/*.{la,a}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS NEWS README
131 %{_libdir}/libpango-1.0.dll.a
132 %{_libdir}/libpangocairo-1.0.dll.a
133 %{_libdir}/libpangoft2-1.0.dll.a
134 %{_libdir}/libpangowin32-1.0.dll.a
135 %{_libdir}/libpango-1.0.la
136 %{_libdir}/libpangocairo-1.0.la
137 %{_libdir}/libpangoft2-1.0.la
138 %{_libdir}/libpangowin32-1.0.la
139 %{_libdir}/pango-1.0.def
140 %{_libdir}/pangocairo-1.0.def
141 %{_libdir}/pangoft2-1.0.def
142 %{_libdir}/pangowin32-1.0.def
143 %{_includedir}/pango-1.0
144 %{_pkgconfigdir}/pango.pc
145 %{_pkgconfigdir}/pangocairo.pc
146 %{_pkgconfigdir}/pangoft2.pc
147 %{_pkgconfigdir}/pangowin32.pc
148
149 %files dll
150 %defattr(644,root,root,755)
151 %{_dlldir}/libpango-1.0-*.dll
152 %{_dlldir}/libpangocairo-1.0-*.dll
153 %{_dlldir}/libpangoft2-1.0-*.dll
154 %{_dlldir}/libpangowin32-1.0-*.dll
155 %dir %{_libdir}/pango
156 %dir %{_libdir}/pango/1.8.0
157 %dir %{_libdir}/pango/1.8.0/modules
158 %{_libdir}/pango/1.8.0/modules/*.dll
This page took 0.142171 seconds and 2 git commands to generate.