]> git.pld-linux.org Git - packages/crossmingw32-pango.git/blob - crossmingw32-pango.spec
7d3bab012f18cfa125fce4c5b9eebaed1fb93861
[packages/crossmingw32-pango.git] / crossmingw32-pango.spec
1 Summary:        System for layout and rendering of internationalized text - cross MinGW32 version
2 Summary(pl.UTF-8):      System renderowania międzynarodowego tekstu - wersja skrośna dla MinGW32
3 %define         realname   pango
4 Name:           crossmingw32-%{realname}
5 Version:        1.46.1
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pango/1.46/%{realname}-%{version}.tar.xz
10 # Source0-md5:  fa7f0a1f216a2c97d96138245d0bcac6
11 URL:            http://www.pango.org/
12 # cairo-ft cairo-pdf cairo-png cairo-ps cairo-win32
13 BuildRequires:  crossmingw32-cairo >= 1.12.10
14 BuildRequires:  crossmingw32-fontconfig >= 2.11.91
15 BuildRequires:  crossmingw32-freetype >= 2.1.7
16 BuildRequires:  crossmingw32-fribidi >= 0.19.7
17 BuildRequires:  crossmingw32-gcc
18 BuildRequires:  crossmingw32-glib2 >= 2.60.0
19 BuildRequires:  crossmingw32-harfbuzz >= 2.6.0
20 BuildRequires:  crossmingw32-w32api >= 5.0.2-6
21 # glib-genmarshal, glib-mkenums
22 BuildRequires:  glib2-devel >= 1:2.60.0
23 BuildRequires:  meson >= 0.50.0-2
24 BuildRequires:  ninja >= 1.5
25 BuildRequires:  perl-base
26 BuildRequires:  pkgconfig >= 1:0.15
27 BuildRequires:  rpmbuild(macros) >= 1.736
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 Requires:       crossmingw32-cairo >= 1.12.10
31 Requires:       crossmingw32-fontconfig >= 2.11.91
32 Requires:       crossmingw32-freetype >= 2.1.7
33 Requires:       crossmingw32-fribidi >= 0.19.7
34 Requires:       crossmingw32-glib2 >= 2.60.0
35 Requires:       crossmingw32-harfbuzz >= 2.6.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         no_install_post_strip   1
39
40 %define         target                  i386-mingw32
41 %define         target_platform         i386-pc-mingw32
42
43 %define         _sysprefix              /usr
44 %define         _prefix                 %{_sysprefix}/%{target}
45 %define         _libdir                 %{_prefix}/lib
46 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
47 %define         _dlldir                 /usr/share/wine/windows/system
48 %define         __pkgconfig_provides    %{nil}
49 %define         __pkgconfig_requires    %{nil}
50 # for meson 0.50+, keep __cc/__cxx as host compiler and pass %{target}-* in meson-cross.txt
51
52 %define         _ssp_cflags             %{nil}
53 %ifnarch %{ix86}
54 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
55 %define         optflags        -O2
56 %endif
57 # -z options are invalid for mingw linker, most of -f options are Linux-specific
58 %define         filterout_ld    -Wl,-z,.*
59 %define         filterout_c     -f[-a-z0-9=]*
60
61 %description
62 System for layout and rendering of internationalized text (cross
63 MinGW32 version).
64
65 %description -l pl.UTF-8
66 System obsługi i renderowania międzynarodowego tekstu (wersja skrośna
67 MinGW32).
68
69 %package static
70 Summary:        Static Pango libraries (cross MinGW32 version)
71 Summary(pl.UTF-8):      Statyczne biblioteki Pango (wersja skrośna MinGW32)
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74
75 %description static
76 Static Pango libraries (cross MinGW32 version).
77
78 %description static -l pl.UTF-8
79 Statyczne biblioteki Pango (wersja skrośna MinGW32).
80
81 %package dll
82 Summary:        DLL pango libraries for Windows
83 Summary(pl.UTF-8):      Biblioteki DLL pango dla Windows
84 Group:          Applications/Emulators
85 Requires:       crossmingw32-cairo-dll >= 1.12.10
86 Requires:       crossmingw32-fontconfig-dll >= 2.11.91
87 Requires:       crossmingw32-freetype-dll >= 2.1.7
88 Requires:       crossmingw32-fribidi-dll >= 0.19.7
89 Requires:       crossmingw32-glib2-dll >= 2.60.0
90 Requires:       crossmingw32-harfbuzz-dll >= 2.6.0
91 Requires:       wine
92
93 %description dll
94 DLL pango libraries for Windows.
95
96 %description dll -l pl.UTF-8
97 Biblioteki DLL pango dla Windows.
98
99 %prep
100 %setup -q -n %{realname}-%{version}
101
102 cat > meson-cross.txt <<'EOF'
103 [host_machine]
104 system = 'windows'
105 cpu_family = 'x86'
106 cpu = 'i386'
107 endian='little'
108 [binaries]
109 c = '%{target}-gcc'
110 cpp = '%{target}-g++'
111 ar = '%{target}-ar'
112 windres = '%{target}-windres'
113 pkgconfig = 'pkg-config'
114 [properties]
115 c_args = ['%(echo %{rpmcflags} | sed -e "s/ \+/ /g;s/ /', '/g")', '-DWINVER=0x0600']
116 EOF
117
118 %build
119 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
120 %meson build \
121         --cross-file meson-cross.txt \
122         %{?debug:--debug} \
123         -Dgtk_doc=false \
124         -Dintrospection=false
125
126 %ninja_build -C build
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %ninja_install -C build
132
133 install -d $RPM_BUILD_ROOT%{_dlldir}
134 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
135
136 %if 0%{!?debug:1}
137 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
138 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
139 %endif
140
141 %{__rm} $RPM_BUILD_ROOT%{_bindir}/pango-{list,view}.exe
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 %defattr(644,root,root,755)
148 %doc NEWS README.md README.win32 THANKS
149 %{_libdir}/libpango-1.0.dll.a
150 %{_libdir}/libpangocairo-1.0.dll.a
151 %{_libdir}/libpangoft2-1.0.dll.a
152 %{_libdir}/libpangowin32-1.0.dll.a
153 %{_includedir}/pango-1.0
154 %{_pkgconfigdir}/pango.pc
155 %{_pkgconfigdir}/pangocairo.pc
156 %{_pkgconfigdir}/pangofc.pc
157 %{_pkgconfigdir}/pangoft2.pc
158 %{_pkgconfigdir}/pangoot.pc
159 %{_pkgconfigdir}/pangowin32.pc
160
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/libpango-1.0.a
164 %{_libdir}/libpangocairo-1.0.a
165 %{_libdir}/libpangoft2-1.0.a
166 %{_libdir}/libpangowin32-1.0.a
167
168 %files dll
169 %defattr(644,root,root,755)
170 %{_dlldir}/libpango-1.0-0.dll
171 %{_dlldir}/libpangocairo-1.0-0.dll
172 %{_dlldir}/libpangoft2-1.0-0.dll
173 %{_dlldir}/libpangowin32-1.0-0.dll
This page took 0.107844 seconds and 3 git commands to generate.