]> git.pld-linux.org Git - packages/crossmingw32-pango.git/blob - crossmingw32-pango.spec
5da075e75ffdf1374a6d7fc4b5e6b3f3c5f17ba6
[packages/crossmingw32-pango.git] / crossmingw32-pango.spec
1 Summary:        System for layout and rendering of internationalized text - cross Mingw32 version
2 Summary(pl.UTF-8):      System renderowania międzynarodowego tekstu - wersja skrośna dla Mingw32
3 %define         realname   pango
4 Name:           crossmingw32-%{realname}
5 Version:        1.20.0
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pango/1.20/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  f0959c4b9b058ba9e4d13fc9086b7e7d
11 Patch0:         %{realname}-xfonts.patch
12 Patch1:         %{realname}-lt.patch
13 URL:            http://www.pango.org/
14 BuildRequires:  autoconf >= 2.59-9
15 BuildRequires:  automake >= 1:1.9
16 BuildRequires:  crossmingw32-cairo >= 1.4.10
17 BuildRequires:  crossmingw32-fontconfig >= 2.4.0
18 BuildRequires:  crossmingw32-freetype >= 2.1.7
19 BuildRequires:  crossmingw32-gcc
20 BuildRequires:  crossmingw32-glib2 >= 2.14.1
21 BuildRequires:  libtool >= 1:1.4.2-9
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig >= 1:0.15
24 BuildRequires:  rpmbuild(macros) >= 1.197
25 Requires:       crossmingw32-cairo >= 1.4.10
26 Requires:       crossmingw32-fontconfig >= 2.4.0
27 Requires:       crossmingw32-freetype >= 2.1.7
28 Requires:       crossmingw32-glib2 >= 2.14.1
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         no_install_post_strip   1
32
33 %define         target                  i386-mingw32
34 %define         target_platform         i386-pc-mingw32
35
36 %define         _sysprefix              /usr
37 %define         _prefix                 %{_sysprefix}/%{target}
38 %define         _libdir                 %{_prefix}/lib
39 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
40 %define         _dlldir                 /usr/share/wine/windows/system
41 %define         __cc                    %{target}-gcc
42 %define         __cxx                   %{target}-g++
43
44 %description
45 System for layout and rendering of internationalized text (cross
46 mingw32 version).
47
48 %description -l pl.UTF-8
49 System obsługi i renderowania międzynarodowego tekstu (wersja skrośna
50 mingw32).
51
52 %package dll
53 Summary:        DLL pango libraries for Windows
54 Summary(pl.UTF-8):      Biblioteki DLL pango dla Windows
55 Group:          Applications/Emulators
56 Requires:       crossmingw32-cairo-dll >= 1.4.10
57 Requires:       crossmingw32-fontconfig-dll >= 2.4.0
58 Requires:       crossmingw32-freetype-dll >= 2.1.7
59 Requires:       crossmingw32-glib2-dll >= 2.14.1
60 Requires:       wine
61
62 %description dll
63 DLL pango libraries for Windows.
64
65 %description dll -l pl.UTF-8
66 Biblioteki DLL pango dla Windows.
67
68 %prep
69 %setup -q -n %{realname}-%{version}
70 %patch0 -p1
71 %patch1 -p1
72
73 %build
74 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
75 %{__libtoolize}
76 %{__aclocal}
77 %{__autoheader}
78 %{__autoconf}
79 %{__automake}
80 %configure \
81         --target=%{target} \
82         --host=%{target} \
83         --with-fribidi \
84         --enable-static
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 # missing from make install but required by it
92 install -d $RPM_BUILD_ROOT%{_sysconfdir}/pango
93
94 %{__make} -j1 install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 install -d $RPM_BUILD_ROOT%{_dlldir}
98 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
99
100 %if 0%{!?debug:1}
101 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
102 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
103 %endif
104
105 rm -rf $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,man}
106 # useless (modules loaded through libgmodule)
107 rm -f $RPM_BUILD_ROOT%{_libdir}/pango/1.6.0/modules/*.{la,a}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS NEWS README
115 %{_libdir}/libpango-1.0.dll.a
116 %{_libdir}/libpangocairo-1.0.dll.a
117 %{_libdir}/libpangoft2-1.0.dll.a
118 %{_libdir}/libpangowin32-1.0.dll.a
119 %{_libdir}/libpango-1.0.la
120 %{_libdir}/libpangocairo-1.0.la
121 %{_libdir}/libpangoft2-1.0.la
122 %{_libdir}/libpangowin32-1.0.la
123 %{_libdir}/pango-1.0.def
124 %{_libdir}/pangocairo-1.0.def
125 %{_libdir}/pangoft2-1.0.def
126 %{_libdir}/pangowin32-1.0.def
127 %{_includedir}/pango-1.0
128 %{_pkgconfigdir}/pango.pc
129 %{_pkgconfigdir}/pangocairo.pc
130 %{_pkgconfigdir}/pangoft2.pc
131 %{_pkgconfigdir}/pangowin32.pc
132
133 %files dll
134 %defattr(644,root,root,755)
135 %{_dlldir}/libpango-1.0-*.dll
136 %{_dlldir}/libpangocairo-1.0-*.dll
137 %{_dlldir}/libpangoft2-1.0-*.dll
138 %{_dlldir}/libpangowin32-1.0-*.dll
This page took 0.048667 seconds and 2 git commands to generate.