]> git.pld-linux.org Git - packages/crossmingw32-libtiff.git/blob - crossmingw32-libtiff.spec
e87d3e92a1499c9d2ddb4c7b8dbe65ac071fcf84
[packages/crossmingw32-libtiff.git] / crossmingw32-libtiff.spec
1 # TODO: jbigkit support
2 Summary:        Library for handling TIFF files - cross MinGW32 version
3 Summary(pl.UTF-8):      Biblioteka do manipulacji plikami w formacie TIFF - wersja skrośna MinGW32
4 %define         realname   libtiff
5 Name:           crossmingw32-%{realname}
6 Version:        4.0.0
7 Release:        1
8 License:        BSD-like
9 Group:          Development/Libraries
10 Source0:        http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11 # Source0-md5:  456ad12e7c492b275a0d047f2ba89904
12 Patch0:         %{realname}-glut.patch
13 Patch1:         %{realname}-sec.patch
14 URL:            http://www.remotesensing.org/libtiff/
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  crossmingw32-gcc-c++
18 BuildRequires:  crossmingw32-libjpeg
19 BuildRequires:  crossmingw32-zlib
20 BuildRequires:  libtool >= 2:2.2
21 Requires:       crossmingw32-libjpeg
22 Requires:       crossmingw32-xz
23 Requires:       crossmingw32-zlib
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         no_install_post_strip   1
27
28 %define         target                  i386-mingw32
29 %define         target_platform         i386-pc-mingw32
30
31 %define         _sysprefix              /usr
32 %define         _prefix                 %{_sysprefix}/%{target}
33 %define         _libdir                 %{_prefix}/lib
34 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
35 %define         _dlldir                 /usr/share/wine/windows/system
36 %define         __cc                    %{target}-gcc
37 %define         __cxx                   %{target}-g++
38
39 %ifnarch %{ix86}
40 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
41 %define         optflags        -O2
42 %endif
43 # -z options are invalid for mingw linker
44 %define         filterout_ld    -Wl,-z,.*
45
46 %description
47 This package is a library of functions that manipulate TIFF images
48 (cross MinGW32 version).
49
50 %description -l pl.UTF-8
51 Ten pakiet zawiera bibliotekę pozwalającą manipulować plikami w
52 formacie TIFF (w wersji skrośnej MinGW32).
53
54 %package static
55 Summary:        Static libtiff library (cross MinGW32 version)
56 Summary(pl.UTF-8):      Statyczna biblioteka libtiff (wersja skrośna MinGW32)
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59
60 %description static
61 Static libtiff library (cross MinGW32 version).
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka libtiff (wersja skrośna MinGW32).
65
66 %package dll
67 Summary:        DLL libtiff library for Windows
68 Summary(pl.UTF-8):      Biblioteka DLL libtiff dla Windows
69 Group:          Applications/Emulators
70 Requires:       wine
71 Requires:       crossmingw32-libjpeg-dll
72 Requires:       crossmingw32-xz-dll
73 Requires:       crossmingw32-zlib-dll
74
75 %description dll
76 DLL libtiff library for Windows.
77
78 %description dll -l pl.UTF-8
79 Biblioteka DLL libtiff dla Windows.
80
81 %package cxx
82 Summary:        libtiff C++ streams library (cross MinGW32 version)
83 Summary(pl.UTF-8):      Biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32)
84 Group:          Development/Libraries
85 Requires:       %{name} = %{version}-%{release}
86
87 %description cxx
88 libtiff C++ streams library (cross MinGW32 version).
89
90 %description cxx -l pl.UTF-8
91 Biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32).
92
93 %package cxx-static
94 Summary:        Static libtiff C++ streams library (cross MinGW32 version)
95 Summary(pl.UTF-8):      Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32)
96 Group:          Development/Libraries
97 Requires:       %{name}-cxx = %{version}-%{release}
98
99 %description cxx-static
100 Static libtiff C++ streams library (cross MinGW32 version).
101
102 %description cxx-static -l pl.UTF-8
103 Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna
104 MinGW32).
105
106 %package cxx-dll
107 Summary:        DLL libtiff C++ streams library for Windows
108 Summary(pl.UTF-8):      Biblioteka DLL strumieni C++ libtiff dla Windows
109 Group:          Applications/Emulators
110 Requires:       %{name}-dll = %{version}-%{release}
111
112 %description cxx-dll
113 DLL libtiff C++ streams library for Windows.
114
115 %description cxx-dll -l pl.UTF-8
116 Biblioteka DLL strumieni C++ libtiff dla Windows.
117
118 %prep
119 %setup -q -n tiff-%{version}
120 %patch0 -p1
121 %patch1 -p1
122
123 %build
124 %{__libtoolize}
125 %{__aclocal} -I m4
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         lt_cv_deplibs_check_method=pass_all \
131         --target=%{target} \
132         --host=%{target} \
133         --enable-static
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 install -d $RPM_BUILD_ROOT%{_dlldir}
143 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
144
145 %if 0%{!?debug:1}
146 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
147 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
148 %endif
149
150 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{doc,man}
151 %{__rm} $RPM_BUILD_ROOT%{_bindir}/*.exe
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %files
157 %defattr(644,root,root,755)
158 %doc COPYRIGHT ChangeLog README TODO
159 %{_libdir}/libtiff.dll.a
160 %{_libdir}/libtiff.la
161 %{_includedir}/tiff*.h
162 %{_pkgconfigdir}/libtiff-4.pc
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libtiff.a
167
168 %files dll
169 %defattr(644,root,root,755)
170 %{_dlldir}/libtiff-*.dll
171
172 %files cxx
173 %defattr(644,root,root,755)
174 %{_libdir}/libtiffxx.dll.a
175 %{_libdir}/libtiffxx.la
176 %{_includedir}/tiffio.hxx
177
178 %files cxx-static
179 %defattr(644,root,root,755)
180 %{_libdir}/libtiffxx.a
181
182 %files cxx-dll
183 %defattr(644,root,root,755)
184 %{_dlldir}/libtiffxx-*.dll
This page took 0.076556 seconds and 3 git commands to generate.