]> git.pld-linux.org Git - packages/crossmingw32-libtiff.git/blob - crossmingw32-libtiff.spec
adca49e231d6f2eb19338988b79825a18d0f4f5b
[packages/crossmingw32-libtiff.git] / crossmingw32-libtiff.spec
1 # TODO: jbigkit, zstd, libdeflate support
2 Summary:        Library for handling TIFF files - cross MinGW32 version
3 Summary(pl.UTF-8):      Biblioteka do manipulacji plikami w formacie TIFF - wersja skrośna MinGW32
4 %define         realname   libtiff
5 Name:           crossmingw32-%{realname}
6 Version:        4.4.0
7 Release:        1
8 License:        BSD-like
9 Group:          Development/Libraries
10 Source0:        http://download.osgeo.org/libtiff/tiff-%{version}.tar.xz
11 # Source0-md5:  47d72beb1171df09502e74566b4d1b43
12 Patch0:         %{realname}-glut.patch
13 URL:            http://www.simplesystems.org/libtiff/
14 BuildRequires:  autoconf >= 2.64
15 BuildRequires:  automake >= 1:1.11
16 BuildRequires:  crossmingw32-gcc-c++
17 BuildRequires:  crossmingw32-libjpeg
18 BuildRequires:  crossmingw32-libwebp
19 BuildRequires:  crossmingw32-zlib
20 BuildRequires:  libtool >= 2:2.2
21 Requires:       crossmingw32-libjpeg
22 Requires:       crossmingw32-libwebp
23 Requires:       crossmingw32-xz
24 Requires:       crossmingw32-zlib
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         no_install_post_strip   1
28 %define         _enable_debug_packages  0
29
30 %define         target                  i386-mingw32
31 %define         target_platform         i386-pc-mingw32
32
33 %define         _sysprefix              /usr
34 %define         _prefix                 %{_sysprefix}/%{target}
35 %define         _libdir                 %{_prefix}/lib
36 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
37 %define         _dlldir                 /usr/share/wine/windows/system
38 %define         __cc                    %{target}-gcc
39 %define         __cxx                   %{target}-g++
40 %define         __pkgconfig_provides    %{nil}
41 %define         __pkgconfig_requires    %{nil}
42
43 %ifnarch %{ix86}
44 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
45 %define         optflags        -O2
46 %endif
47 # -z options are invalid for mingw linker, most of -f options are Linux-specific
48 %define         filterout_ld    -Wl,-z,.*
49 %define         filterout_c     -f[-a-z0-9=]*
50 %define         filterout_cxx   -f[-a-z0-9=]*
51
52 %description
53 This package is a library of functions that manipulate TIFF images
54 (cross MinGW32 version).
55
56 %description -l pl.UTF-8
57 Ten pakiet zawiera bibliotekę pozwalającą manipulować plikami w
58 formacie TIFF (w wersji skrośnej MinGW32).
59
60 %package static
61 Summary:        Static libtiff library (cross MinGW32 version)
62 Summary(pl.UTF-8):      Statyczna biblioteka libtiff (wersja skrośna MinGW32)
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description static
67 Static libtiff library (cross MinGW32 version).
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka libtiff (wersja skrośna MinGW32).
71
72 %package dll
73 Summary:        DLL libtiff library for Windows
74 Summary(pl.UTF-8):      Biblioteka DLL libtiff dla Windows
75 Group:          Applications/Emulators
76 Requires:       wine
77 Requires:       crossmingw32-libjpeg-dll
78 Requires:       crossmingw32-libwebp-dll
79 Requires:       crossmingw32-xz-dll
80 Requires:       crossmingw32-zlib-dll
81
82 %description dll
83 DLL libtiff library for Windows.
84
85 %description dll -l pl.UTF-8
86 Biblioteka DLL libtiff dla Windows.
87
88 %package cxx
89 Summary:        libtiff C++ streams library (cross MinGW32 version)
90 Summary(pl.UTF-8):      Biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32)
91 Group:          Development/Libraries
92 Requires:       %{name} = %{version}-%{release}
93
94 %description cxx
95 libtiff C++ streams library (cross MinGW32 version).
96
97 %description cxx -l pl.UTF-8
98 Biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32).
99
100 %package cxx-static
101 Summary:        Static libtiff C++ streams library (cross MinGW32 version)
102 Summary(pl.UTF-8):      Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32)
103 Group:          Development/Libraries
104 Requires:       %{name}-cxx = %{version}-%{release}
105
106 %description cxx-static
107 Static libtiff C++ streams library (cross MinGW32 version).
108
109 %description cxx-static -l pl.UTF-8
110 Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna
111 MinGW32).
112
113 %package cxx-dll
114 Summary:        DLL libtiff C++ streams library for Windows
115 Summary(pl.UTF-8):      Biblioteka DLL strumieni C++ libtiff dla Windows
116 Group:          Applications/Emulators
117 Requires:       %{name}-dll = %{version}-%{release}
118
119 %description cxx-dll
120 DLL libtiff C++ streams library for Windows.
121
122 %description cxx-dll -l pl.UTF-8
123 Biblioteka DLL strumieni C++ libtiff dla Windows.
124
125 %prep
126 %setup -q -n tiff-%{version}
127 %patch0 -p1
128
129 %build
130 %{__libtoolize}
131 %{__aclocal} -I m4
132 %{__autoconf}
133 %{__autoheader}
134 %{__automake}
135 %configure \
136         lt_cv_deplibs_check_method=pass_all \
137         --target=%{target} \
138         --host=%{target} \
139         --enable-static
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 install -d $RPM_BUILD_ROOT%{_dlldir}
149 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
150
151 %if 0%{!?debug:1}
152 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
153 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
154 %endif
155
156 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{doc,man}
157 %{__rm} $RPM_BUILD_ROOT%{_bindir}/*.exe
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %files
163 %defattr(644,root,root,755)
164 %doc COPYRIGHT ChangeLog README.md TODO
165 %{_libdir}/libtiff.dll.a
166 %{_libdir}/libtiff.la
167 %{_includedir}/tiff*.h
168 %{_pkgconfigdir}/libtiff-4.pc
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libtiff.a
173
174 %files dll
175 %defattr(644,root,root,755)
176 %{_dlldir}/libtiff-*.dll
177
178 %files cxx
179 %defattr(644,root,root,755)
180 %{_libdir}/libtiffxx.dll.a
181 %{_libdir}/libtiffxx.la
182 %{_includedir}/tiffio.hxx
183
184 %files cxx-static
185 %defattr(644,root,root,755)
186 %{_libdir}/libtiffxx.a
187
188 %files cxx-dll
189 %defattr(644,root,root,755)
190 %{_dlldir}/libtiffxx-*.dll
This page took 0.11276 seconds and 3 git commands to generate.