]> git.pld-linux.org Git - packages/crossmingw32-libsigc++.git/blob - crossmingw32-libsigc++.spec
5038ec4a50007358abbab1824a4360c5cfa9b791
[packages/crossmingw32-libsigc++.git] / crossmingw32-libsigc++.spec
1 #
2 %define         _realname       libsigc++
3 Summary:        The Typesafe Signal Framework for C++ - Mingw32 cross version
4 Summary(pl):    ¦rodowisko sygna³ów z kontrol± typów dla C++ - wersja skro¶na dla Mingw32
5 Name:           crossmingw32-%{_realname}
6 Version:        2.0.17
7 Release:        2
8 Epoch:          1
9 License:        LGPL
10 Group:          Libraries
11 Source0:        http://ftp.gnome.org/pub/gnome/sources/libsigc++/2.0/%{_realname}-%{version}.tar.bz2
12 # Source0-md5:  fde0ee69e3125e982746d9fe005763e1
13 URL:            http://libsigc.sourceforge.net/
14 BuildRequires:  autoconf >= 2.59
15 BuildRequires:  automake >= 1.9
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool
18 BuildRequires:  m4
19 BuildRequires:  perl-base
20 Obsoletes:      libsigc++-examples
21 Conflicts:      libsigc++ < 1.1.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         no_install_post_strip   1
25
26 %define         target                  i386-mingw32
27 %define         target_platform         i386-pc-mingw32
28 %define         arch                    %{_prefix}/%{target}
29 %define         gccarch                 %{_prefix}/lib/gcc-lib/%{target}
30 %define         gcclib                  %{_prefix}/lib/gcc-lib/%{target}/%{version}
31
32 %define         _sysprefix              /usr
33 %define         _prefix                 %{_sysprefix}/%{target}
34 %define         __cc                    %{target}-gcc
35 %define         __cxx                   %{target}-g++
36
37 %description
38 This library implements a full callback system for use in widget
39 libraries, abstract interfaces, and general programming. Originally
40 part of the Gtk-- widget set, libsigc++ is now a seperate library to
41 provide for more general use. It is the most complete library of its
42 kind with the ablity to connect an abstract callback to a class
43 method, function, or function object. It contains adaptor classes for
44 connection of dissimilar callbacks and has an ease of use unmatched by
45 other C++ callback libraries.
46
47 %description -l pl
48 Ta biblioteka jest implementacj± pe³nego systemu callbacków do
49 u¿ywania w bibliotekach widgetów, interfejsach abstrakcyjnych i
50 ogólnym programowaniu. Oryginalnie by³a to czê¶æ zestawu widgetów
51 Gtk--, ale jest teraz oddzieln± bibliotek± ogólniejszego
52 przeznaczenia. Jest to kompletna biblioteka tego typu z mo¿liwo¶ci±
53 ³±czenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
54 obiektami funkcji. Zawiera klasy adapterów do ³±czenia ró¿nych
55 callbacków.
56
57 %prep
58 %setup -q -n %{_realname}-%{version}
59
60 %build
61 %{__libtoolize}
62 %{__aclocal} -I scripts
63 %{__autoconf}
64 %{__automake}
65
66 %configure \
67         --host=%{target_platform} \
68         %{!?with_static_libs:--disable-static}
69 %{__make} all
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc AUTHORS ChangeLog NEWS README TODO
83 %{_libdir}/lib*.a
84 %{_libdir}/lib*.la
85 %dir %{_includedir}/sigc++-2.0
86 %{_includedir}/sigc++-2.0
87 %dir %{_libdir}/sigc++-2.0
88 %{_libdir}/sigc++*
89 %{_prefix}/lib/pkgconfig/*
This page took 0.060466 seconds and 2 git commands to generate.