]> git.pld-linux.org Git - packages/crossmingw32-libpng.git/blob - crossmingw32-libpng.spec
- updated to 1.6.43
[packages/crossmingw32-libpng.git] / crossmingw32-libpng.spec
1 %define         realname        libpng
2 Summary:        PNG library - MinGW32 cross version
3 Summary(pl.UTF-8):      Biblioteka PNG - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        1.6.43
6 Release:        1
7 License:        distributable
8 Group:          Development/Libraries
9 Source0:        https://downloads.sourceforge.net/libpng/%{realname}-%{version}.tar.xz
10 # Source0-md5:  22b8362d16c3724eba9c1fb8d187320a
11 Patch0:         https://downloads.sourceforge.net/libpng-apng/%{realname}-%{version}-apng.patch.gz
12 # Patch0-md5:   fc21268c9c583c5d2e7ead8a9ec17240
13 Patch1:         %{realname}-pngminus.patch
14 URL:            http://www.libpng.org/pub/png/libpng.html
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  crossmingw32-zlib
17 BuildRequires:  sed >= 4.0
18 BuildRequires:  tar >= 1:1.22
19 BuildRequires:  xz >= 1:4.999.7
20 Requires:       crossmingw32-zlib >= 1.2.9
21 Provides:       crossmingw32-libpng(APNG) = 0.10
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         no_install_post_strip   1
25 %define         _enable_debug_packages  0
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37 %define         __pkgconfig_provides    %{nil}
38 %define         __pkgconfig_requires    %{nil}
39
40 %ifnarch %{ix86}
41 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42 %define         optflags        -O2
43 %endif
44 # -z options are invalid for mingw linker, most of -f options are Linux-specific
45 %define         filterout_ld    -Wl,-z,.*
46 %define         filterout_c     -f[-a-z0-9=]*
47
48 %description
49 The PNG library is a collection of routines used to create and
50 manipulate PNG format graphics files. The PNG format was designed as a
51 replacement for GIF, with many improvements and extensions.
52
53 This package contains the cross version for Win32.
54
55 %description -l pl.UTF-8
56 Biblioteki PNG są kolekcją form używanych do tworzenia i manipulowania
57 plikami w formacie graficznym PNG. Format ten został stworzony jako
58 zamiennik dla formatu GIF, z wieloma rozszerzeniami i nowościami.
59
60 Ten pakiet zawiera wersję skrośną dla Win32.
61
62 %package static
63 Summary:        Static libpng library (cross MinGW32 version)
64 Summary(pl.UTF-8):      Statyczna biblioteka libpng (wersja skrośna MinGW32)
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Provides:       crossmingw32-libpng-static(APNG) = 0.10
68
69 %description static
70 Static libpng library (cross MinGW32 version).
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka libpng (wersja skrośna MinGW32).
74
75 %package dll
76 Summary:        libpng - DLL library for Windows
77 Summary(pl.UTF-8):      libpng - biblioteka DLL dla Windows
78 Group:          Applications/Emulators
79 Requires:       crossmingw32-zlib-dll >= 1.2.9
80 Requires:       wine
81 Provides:       crossmingw32-libpng-dll(APNG) = 0.10
82
83 %description dll
84 libpng - DLL library for Windows.
85
86 %description dll -l pl.UTF-8
87 libpng - biblioteka DLL dla Windows.
88
89 %prep
90 %setup -q -n %{realname}-%{version}
91 %patch0 -p1
92 %patch1 -p1
93
94 %build
95 %configure \
96         --target=%{target} \
97         --host=%{target} \
98         --with-pkgconfigdir=%{_pkgconfigdir}
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 install -d $RPM_BUILD_ROOT%{_dlldir}
109 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
110
111 ln -sf libpng16.dll.a $RPM_BUILD_ROOT%{_libdir}/libpng.dll.a
112
113 %if 0%{!?debug:1}
114 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
115 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
116 %endif
117
118 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/man
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %{_libdir}/libpng16.dll.a
126 %{_libdir}/libpng.dll.a
127 %{_libdir}/libpng16.la
128 %{_libdir}/libpng.la
129 %{_includedir}/libpng16
130 %{_includedir}/png*.h
131 %{_pkgconfigdir}/libpng16.pc
132 %{_pkgconfigdir}/libpng.pc
133
134 %files static
135 %defattr(644,root,root,755)
136 %{_libdir}/libpng16.a
137 %{_libdir}/libpng.a
138
139 %files dll
140 %defattr(644,root,root,755)
141 %{_dlldir}/libpng16-*.dll
This page took 0.133873 seconds and 3 git commands to generate.