]> git.pld-linux.org Git - packages/crossmingw32-libglade2.git/blob - crossmingw32-libglade2.spec
- updated from libglade2.spec, drop .la file, release 2
[packages/crossmingw32-libglade2.git] / crossmingw32-libglade2.spec
1 %define         realname libglade2
2 Summary:        libglade library - cross Mingw32 version
3 Summary(pl.UTF-8):      Biblioteka do ładowania definicji interfejsu generowanego programem glade - wersja skrośna dla Mingw32
4 Name:           crossmingw32-%{realname}
5 Version:        2.6.4
6 Release:        2
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libglade/2.6/libglade-%{version}.tar.bz2
10 # Source0-md5:  d1776b40f4e166b5e9c107f1c8fe4139
11 Patch0:         %{realname}-gmodule-link.patch
12 Patch1:         %{realname}-no-gnome-common.patch
13 URL:            https://developer.gnome.org/libglade/
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake >= 1:1.9
16 BuildRequires:  bison
17 BuildRequires:  crossmingw32-atk >= 1.18.0
18 BuildRequires:  crossmingw32-gettext
19 BuildRequires:  crossmingw32-gtk+2 >= 2.10.13
20 BuildRequires:  crossmingw32-libxml2 >= 2.6.29
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig >= 1:0.15
23 BuildRequires:  python >= 2.0
24 BuildRequires:  python-modules >= 2.0
25 BuildRequires:  rpmbuild(macros) >= 1.197
26 Requires:       crossmingw32-atk >= 1.18.0
27 Requires:       crossmingw32-gtk+2 >= 2.10.13
28 Requires:       crossmingw32-libxml2 >= 2.6.29
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         no_install_post_strip   1
32
33 %define         target                  i386-mingw32
34 %define         target_platform         i386-pc-mingw32
35
36 %define         _sysprefix              /usr
37 %define         _prefix                 %{_sysprefix}/%{target}
38 %define         _libdir                 %{_prefix}/lib
39 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
40 %define         _dlldir                 /usr/share/wine/windows/system
41 %define         __cc                    %{target}-gcc
42 %define         __cxx                   %{target}-g++
43 %define         __pkgconfig_provides    %{nil}
44 %define         __pkgconfig_requires    %{nil}
45
46 %define         _ssp_cflags             %{nil}
47 %ifnarch %{ix86}
48 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
49 %define         optflags        -O2
50 %endif
51 # -z options are invalid for mingw linker, most of -f options are Linux-specific
52 %define         filterout_ld    -Wl,-z,.*
53 %define         filterout_c     -f[-a-z0-9=]*
54
55 %description
56 This library allows you to load user interfaces in your program, which
57 are stored externally. This allows alteration of the interface without
58 recompilation of the program. The interfaces can also be edited with
59 GLADE.
60
61 This package contains the cross version for Win32.
62
63 %description -l pl.UTF-8
64 Biblioteka libglade umożliwia dynamiczne ładowanie definicji
65 interfejsu użytkownika generowanego za pomocą programu glade. Taka
66 separacja definicji interfejsu umożliwia pracę nad nim bez
67 konieczności rekompilacji programu.
68
69 Ten pakiet zawiera wersję skrośną dla Win32.
70
71 %package static
72 Summary:        Static libglade library (cross mingw32 version)
73 Summary(pl.UTF-8):      Statyczna biblioteka libglade (wersja skrośna mingw32)
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76
77 %description static
78 Static libglade library (cross mingw32 version).
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka libglade (wersja skrośna mingw32).
82
83 %package dll
84 Summary:        DLL libglade library for Windows
85 Summary(pl.UTF-8):      Biblioteka DLL libglade dla Windows
86 Group:          Applications/Emulators
87 Requires:       crossmingw32-atk-dll >= 1.18.0
88 Requires:       crossmingw32-gtk+2-dll >= 2.10.13
89 Requires:       crossmingw32-libxml2-dll >= 2.6.29
90 Requires:       wine
91
92 %description dll
93 DLL libglade library for Windows.
94
95 %description dll -l pl.UTF-8
96 Biblioteka DLL libglade dla Windows.
97
98 %prep
99 %setup -q -n libglade-%{version}
100 %patch0 -p1
101 %patch1 -p1
102
103 %build
104 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
105 %{__libtoolize}
106 %{__glib_gettextize}
107 %{__aclocal} -I m4
108 %{__autoconf}
109 %{__automake}
110 %configure \
111         lt_cv_deplibs_check_method=pass_all \
112         --target=%{target} \
113         --host=%{target} \
114         --disable-gtk-doc
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} -j1 install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install -d $RPM_BUILD_ROOT%{_dlldir}
125 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
126
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libglade-*.la
128
129 %if 0%{!?debug:1}
130 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
131 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
132 %endif
133
134 %{__rm} $RPM_BUILD_ROOT%{_bindir}/libglade-convert
135 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,xml}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog NEWS README
143 %{_libdir}/libglade-2.0.dll.a
144 %{_pkgconfigdir}/libglade-2.0.pc
145 %{_includedir}/libglade-2.0
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libglade-2.0.a
150
151 %files dll
152 %defattr(644,root,root,755)
153 %{_dlldir}/libglade-2.0-0.dll
This page took 0.575875 seconds and 4 git commands to generate.