]> git.pld-linux.org Git - packages/crossmingw32-libglade2.git/blob - crossmingw32-libglade2.spec
- fix missing export (glade_xml_construct_from_buffer, needed by libglademm 2.6.4)
[packages/crossmingw32-libglade2.git] / crossmingw32-libglade2.spec
1 %define         _realname   libglade2
2 Summary:        libglade library - cross Mingw32 version
3 Summary(pl.UTF-8):      Biblioteka do ładowania definicji interfejsu generowanego programem glade - wersja skrośna dla Mingw32
4 Name:           crossmingw32-%{_realname}
5 Version:        2.6.1
6 Release:        1
7 License:        LGPL
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libglade/2.6/libglade-%{version}.tar.bz2
10 # Source0-md5:  489be887b26b9973f77e2c6111ab7d5a
11 URL:            http://www.gnome.org/
12 BuildRequires:  autoconf >= 2.52
13 BuildRequires:  automake
14 BuildRequires:  bison
15 BuildRequires:  crossmingw32-atk >= 1.18.0
16 BuildRequires:  crossmingw32-gettext
17 BuildRequires:  crossmingw32-gtk+2 >= 2.10.13
18 BuildRequires:  crossmingw32-libxml2 >= 2.6.29
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig
21 BuildRequires:  python >= 2.0
22 BuildRequires:  python-modules >= 2.0
23 BuildRequires:  rpmbuild(macros) >= 1.197
24 Requires:       crossmingw32-atk >= 1.18.0
25 Requires:       crossmingw32-gtk+2 >= 2.10.13
26 Requires:       crossmingw32-libxml2 >= 2.6.29
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         no_install_post_strip   1
30
31 %define         target                  i386-mingw32
32 %define         target_platform         i386-pc-mingw32
33 %define         arch                    %{_prefix}/%{target}
34
35 %define         _sysprefix              /usr
36 %define         _prefix                 %{_sysprefix}/%{target}
37 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
38 %define         _dlldir                 /usr/share/wine/windows/system
39 %define         __cc                    %{target}-gcc
40 %define         __cxx                   %{target}-g++
41
42 %description
43 This library allows you to load user interfaces in your program, which
44 are stored externally. This allows alteration of the interface without
45 recompilation of the program. The interfaces can also be edited with
46 GLADE.
47
48 This package contains the cross version for Win32.
49
50 %description -l pl.UTF-8
51 Biblioteka libglade umożliwia dynamiczne ładowanie definicji
52 interfejsu użytkownika generowanego za pomocą programu glade. Taka
53 separacja definicji interfejsu umożliwia pracę nad nim bez
54 konieczności rekompilacji programu.
55
56 Ten pakiet zawiera wersję skrośną dla Win32.
57
58 %package static
59 Summary:        Static libglade library (cross mingw32 version)
60 Summary(pl.UTF-8):      Statyczna biblioteka libglade (wersja skrośna mingw32)
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63
64 %description static
65 Static libglade library (cross mingw32 version).
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka libglade (wersja skrośna mingw32).
69
70 %package dll
71 Summary:        DLL libglade library for Windows
72 Summary(pl.UTF-8):      Biblioteka DLL libglade dla Windows
73 Group:          Applications/Emulators
74 Requires:       crossmingw32-atk-dll >= 1.18.0
75 Requires:       crossmingw32-gtk+2-dll >= 2.10.13
76 Requires:       crossmingw32-libxml2-dll >= 2.6.29
77 Requires:       wine
78
79 %description dll
80 DLL libglade library for Windows.
81
82 %description dll -l pl.UTF-8
83 Biblioteka DLL libglade dla Windows.
84
85 %prep
86 %setup -q -n libglade-%{version}
87
88 # ensure to remove workaround below when obsolete
89 grep -q glade_xml_construct_from_buffer glade/glade.def && exit 1
90 # missing export
91 echo -e '\tglade_xml_construct_from_buffer' >> glade/glade.def
92
93 %build
94 export PKG_CONFIG_PATH=%{_prefix}/lib/pkgconfig
95 %{__libtoolize}
96 %{__glib_gettextize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__automake}
100 %configure \
101         lt_cv_deplibs_check_method=pass_all \
102         --target=%{target} \
103         --host=%{target} \
104         --disable-gtk-doc
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT%{_libdir}/libglade/2.0
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 install -d $RPM_BUILD_ROOT%{_dlldir}
116 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
117
118 %if 0%{!?debug:1}
119 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
120 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
121 %endif
122
123 rm -rf $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,xml}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS NEWS README
131 %{_libdir}/libglade-2.0.dll.a
132 %{_libdir}/libglade-2.0.la
133 %{_pkgconfigdir}/libglade-2.0.pc
134 %{_includedir}/libglade-2.0
135
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libglade-2.0.a
139
140 %files dll
141 %defattr(644,root,root,755)
142 %{_dlldir}/libglade-2.0-*.dll
This page took 0.078673 seconds and 4 git commands to generate.