]> git.pld-linux.org Git - packages/crossmingw32-libglade2.git/blob - crossmingw32-libglade2.spec
- for crosscompiling use PKG_CONFIG_LIBDIR instead of PKG_CONFIG_PATH
[packages/crossmingw32-libglade2.git] / crossmingw32-libglade2.spec
1 %define         realname   libglade2
2 Summary:        libglade library - cross Mingw32 version
3 Summary(pl.UTF-8):      Biblioteka do ładowania definicji interfejsu generowanego programem glade - wersja skrośna dla Mingw32
4 Name:           crossmingw32-%{realname}
5 Version:        2.6.2
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libglade/2.6/libglade-%{version}.tar.bz2
10 # Source0-md5:  da4f9d1c6cd1337f6ef5e2db768d8557
11 URL:            http://www.gnome.org/
12 BuildRequires:  autoconf >= 2.52
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  bison
15 BuildRequires:  crossmingw32-atk >= 1.18.0
16 BuildRequires:  crossmingw32-gettext
17 BuildRequires:  crossmingw32-gtk+2 >= 2.10.13
18 BuildRequires:  crossmingw32-libxml2 >= 2.6.29
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig >= 1:0.15
21 BuildRequires:  python >= 2.0
22 BuildRequires:  python-modules >= 2.0
23 BuildRequires:  rpmbuild(macros) >= 1.197
24 Requires:       crossmingw32-atk >= 1.18.0
25 Requires:       crossmingw32-gtk+2 >= 2.10.13
26 Requires:       crossmingw32-libxml2 >= 2.6.29
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         no_install_post_strip   1
30
31 %define         target                  i386-mingw32
32 %define         target_platform         i386-pc-mingw32
33
34 %define         _sysprefix              /usr
35 %define         _prefix                 %{_sysprefix}/%{target}
36 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
37 %define         _dlldir                 /usr/share/wine/windows/system
38 %define         __cc                    %{target}-gcc
39 %define         __cxx                   %{target}-g++
40
41 %description
42 This library allows you to load user interfaces in your program, which
43 are stored externally. This allows alteration of the interface without
44 recompilation of the program. The interfaces can also be edited with
45 GLADE.
46
47 This package contains the cross version for Win32.
48
49 %description -l pl.UTF-8
50 Biblioteka libglade umożliwia dynamiczne ładowanie definicji
51 interfejsu użytkownika generowanego za pomocą programu glade. Taka
52 separacja definicji interfejsu umożliwia pracę nad nim bez
53 konieczności rekompilacji programu.
54
55 Ten pakiet zawiera wersję skrośną dla Win32.
56
57 %package static
58 Summary:        Static libglade library (cross mingw32 version)
59 Summary(pl.UTF-8):      Statyczna biblioteka libglade (wersja skrośna mingw32)
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description static
64 Static libglade library (cross mingw32 version).
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka libglade (wersja skrośna mingw32).
68
69 %package dll
70 Summary:        DLL libglade library for Windows
71 Summary(pl.UTF-8):      Biblioteka DLL libglade dla Windows
72 Group:          Applications/Emulators
73 Requires:       crossmingw32-atk-dll >= 1.18.0
74 Requires:       crossmingw32-gtk+2-dll >= 2.10.13
75 Requires:       crossmingw32-libxml2-dll >= 2.6.29
76 Requires:       wine
77
78 %description dll
79 DLL libglade library for Windows.
80
81 %description dll -l pl.UTF-8
82 Biblioteka DLL libglade dla Windows.
83
84 %prep
85 %setup -q -n libglade-%{version}
86
87 # ensure to remove workaround below when obsolete
88 grep -q glade_xml_construct_from_buffer glade/glade.def && exit 1
89 # missing export
90 echo -e '\tglade_xml_construct_from_buffer' >> glade/glade.def
91
92 %build
93 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
94 %{__libtoolize}
95 %{__glib_gettextize}
96 %{__aclocal} -I m4
97 %{__autoconf}
98 %{__automake}
99 %configure \
100         lt_cv_deplibs_check_method=pass_all \
101         --target=%{target} \
102         --host=%{target} \
103         --disable-gtk-doc
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 install -d $RPM_BUILD_ROOT%{_dlldir}
114 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
115
116 %if 0%{!?debug:1}
117 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
118 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
119 %endif
120
121 rm -rf $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,xml}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog NEWS README
129 %{_libdir}/libglade-2.0.dll.a
130 %{_libdir}/libglade-2.0.la
131 %{_pkgconfigdir}/libglade-2.0.pc
132 %{_includedir}/libglade-2.0
133
134 %files static
135 %defattr(644,root,root,755)
136 %{_libdir}/libglade-2.0.a
137
138 %files dll
139 %defattr(644,root,root,755)
140 %{_dlldir}/libglade-2.0-*.dll
This page took 0.089552 seconds and 4 git commands to generate.