]> git.pld-linux.org Git - packages/crossmingw32-libglade2.git/blob - crossmingw32-libglade2.spec
- to unblind qboosh (sry - didn't commit earlier)
[packages/crossmingw32-libglade2.git] / crossmingw32-libglade2.spec
1 #
2 # TODO: register glade-2.0.dtd
3 # TODO: consider moving libglade-convert to main package - it is used to converting old
4 #       1.2.x version *.glade files to current structure.
5 %define         _realname   libglade2
6 Summary:        libglade library - cross Mingw32 version
7 Summary(es.UTF-8):El libglade permite que usted cargue archivos del interfaz del glade
8 Summary(pl.UTF-8):Biblioteka do ładowania definicji interfejsu generowanego programem glade - wersja skrośna dla Mingw32
9 Summary(pt_BR.UTF-8):Esta biblioteca permite carregar arquivos da interface glade
10 Name:           crossmingw32-%{_realname}
11 Version:        2.6.0
12 Release:        1
13 License:        LGPL
14 Group:          X11/Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libglade/2.6/libglade-%{version}.tar.bz2
16 # Source0-md5:  81d7b2b64871ce23a5fae1e5da0b1f6e
17 URL:            http://www.gnome.org/
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  automake
20 BuildRequires:  bison
21 BuildRequires:  crossmingw32-atk >= 1.12.1
22 BuildRequires:  crossmingw32-gettext
23 BuildRequires:  crossmingw32-gtk+2 >= 2.10.0
24 BuildRequires:  crossmingw32-libxml2 >= 2.6.26
25 BuildRequires:  crossmingw32-pkgconfig
26 BuildRequires:  libtool
27 BuildRequires:  python >= 2.0
28 BuildRequires:  python-modules >= 2.0
29 BuildRequires:  rpmbuild(macros) >= 1.197
30 Requires:       FHS >= 2.3-16
31 Requires:       crossmingw32-atk >= 1.12.1
32 Requires:       python-modules >= 2.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         no_install_post_strip   1
36
37 %define         target                  i386-mingw32
38 %define         target_platform         i386-pc-mingw32
39 %define         arch                    %{_prefix}/%{target}
40 %define         gccarch                 %{_prefix}/lib/gcc-lib/%{target}
41 %define         gcclib                  %{_prefix}/lib/gcc-lib/%{target}/%{version}
42
43 %define         _sysprefix              /usr
44 %define         _prefix                 %{_sysprefix}/%{target}
45 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
46 %define         __cc                    %{target}-gcc
47 %define         __cxx                   %{target}-g++
48
49 %description
50 This library allows you to load user interfaces in your program, which
51 are stored externally. This allows alteration of the interface without
52 recompilation of the program. The interfaces can also be edited with
53 GLADE.
54
55 %description -l es.UTF-8
56 El libglade permite que usted cargue archivos del interfaz del glade
57 en tiempo de ejecución.
58
59 %description -l pl.UTF-8
60 Biblioteka libglade umożliwia dynamiczne ładowanie definicji
61 interfejsu użytkownika generowanego za pomocą programu glade. Taka
62 separacja definicji interfejsu umożliwia pracę nad nim bez
63 konieczności rekompilacji programu.
64
65 %description -l pt_BR.UTF-8
66 O libglade permite carregar, em tempo de execução, arquivos da
67 interface glade. Não é necessário ter o glade instalado, mas esta
68 é a melhor maneira de criar os arquivos de interface.
69
70 %prep
71 %setup -q -n libglade-%{version}
72
73 %build
74 export PKG_CONFIG_PATH=%{_prefix}/lib/pkgconfig
75 %{__libtoolize}
76 %{__glib_gettextize}
77 %{__aclocal} -I m4
78 %{__autoconf}
79 %{__automake}
80 %configure \
81         --target=%{target} \
82         --host=%{target} \
83         --disable-gtk-doc
84
85 %{__sed} -i -e 's/^deplibs_check_method=.*/deplibs_check_method="pass_all"/' libtool
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT%{_libdir}/libglade/2.0
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT \
95         pkgconfigdir=%{_pkgconfigdir}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS NEWS README
103 %{_libdir}/lib*.la
104 %{_libdir}/lib*.a
105 %{_libdir}/libglade
106 %dir %{_datadir}/xml/libglade
107 %{_datadir}/xml/libglade/*.dtd
108 %attr(755,root,root) %{_bindir}/*
109 %{_pkgconfigdir}/*
110 %{_includedir}/libglade-*
This page took 0.088354 seconds and 4 git commands to generate.