]> git.pld-linux.org Git - packages/crossmingw32-lib3ds.git/blob - crossmingw32-lib3ds.spec
9a6a54e2210cd7996726deb57a636b821fc2691f
[packages/crossmingw32-lib3ds.git] / crossmingw32-lib3ds.spec
1 %define         realname        lib3ds
2 Summary:        The 3D Studio File Format Library - Mingw32 cross version
3 Summary(pl.UTF-8):      Biblioteka obsługująca format plików 3D Studio - wersja skrośna dla Mingw32
4 Name:           crossmingw32-%{realname}
5 Version:        1.2.0
6 Release:        4
7 License:        LGPL
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/lib3ds/%{realname}-%{version}.tar.gz
10 # Source0-md5:  3a7f891d18af0151876b98bc05d3b373
11 URL:            http://lib3ds.sourceforge.net/
12 Requires:       crossmingw32-runtime
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  crossmingw32-w32api
17 BuildRequires:  libtool
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         no_install_post_strip   1
21
22 %define         target          i386-mingw32
23 %define         target_platform i386-pc-mingw32
24 %define         arch            %{_prefix}/%{target}
25 %define         gccarch         %{_prefix}/lib/gcc-lib/%{target}
26 %define         gcclib          %{_prefix}/lib/gcc-lib/%{target}/%{version}
27
28 %define         __cc            %{target}-gcc
29 %define         __cxx           %{target}-g++
30
31 %ifarch alpha sparc sparc64 sparcv9
32 %define         optflags        -O2
33 %endif
34
35 %description
36 lib3ds is a free alternative to Autodesk's 3DS File Toolkit for
37 handling 3DS files. It's main goal is to simplify the creation of 3DS
38 import and export filters.
39
40 %description -l pl.UTF-8
41 lib3ds to wolnodostępna alternatywa dla 3DS File Toolkit Autodeska do
42 obsługi plików 3DS. Głównym celem biblioteki jest uproszczenie
43 tworzenia filtrów importujących i eksportujących 3DS.
44
45 %package dll
46 Summary:        %{realname} - DLL library for Windows
47 Summary(pl.UTF-8):      %{realname} - biblioteka DLL dla Windows
48 Group:          Applications/Emulators
49
50 %description dll
51 %{realname} - DLL library for Windows.
52
53 %description dll -l pl.UTF-8
54 %{realname} - biblioteka DLL dla Windows.
55
56 %prep
57 %setup -q -n %{realname}-%{version}
58
59 %build
60 CC=%{target}-gcc ; export CC
61 CXX=%{target}-g++ ; export CXX
62 LD=%{target}-ld ; export LD
63 AR=%{target}-ar ; export AR
64 AS=%{target}-as ; export AS
65 CROSS_COMPILE=1 ; export CROSS_COMPILE
66 CPPFLAGS="-I%{arch}/include" ; export CPPFLAGS
67 RANLIB=%{target}-ranlib ; export RANLIB
68 LDSHARED="%{target}-gcc -shared" ; export LDSHARED
69 TARGET="%{target}" ; export TARGET
70
71 tail -n 116 aclocal.m4 | head -n 102 > acinclude.m4
72 %{__libtoolize}
73 %{__aclocal}
74 %{__autoconf}
75 %{__autoheader}
76 %{__automake}
77 %configure \
78         --host=%{_host} \
79         --target=%{target}
80
81 # glut is broken
82 echo "int main(){}" > examples/player.c
83
84 %{__make}
85
86 cd lib3ds
87 %{__cc} --shared *.o -Wl,--enable-auto-image-base -o 3ds.dll -Wl,--out-implib,lib3ds.dll.a
88
89 %if 0%{!?debug:1}
90 %{target}-strip *.dll
91 %{target}-strip -g -R.comment -R.note *.a
92 %endif
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT%{arch}/{include/lib3ds,lib}
97 install -d $RPM_BUILD_ROOT%{_datadir}/wine/windows/system
98
99 cd lib3ds
100
101 install *.h $RPM_BUILD_ROOT%{arch}/include/lib3ds
102 rm $RPM_BUILD_ROOT%{arch}/include/lib3ds/chunktable.h
103 install lib3ds{,.dll}.a $RPM_BUILD_ROOT%{arch}/lib
104 install 3ds.dll $RPM_BUILD_ROOT%{_datadir}/wine/windows/system
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %{arch}/include/*
112 %{arch}/lib/*
113
114 %files dll
115 %defattr(644,root,root,755)
116 %{_datadir}/wine/windows/system/*
This page took 0.074015 seconds and 3 git commands to generate.