]> git.pld-linux.org Git - packages/crossmingw32-harfbuzz.git/blame - crossmingw32-harfbuzz.spec
- updated to 0.9.24
[packages/crossmingw32-harfbuzz.git] / crossmingw32-harfbuzz.spec
CommitLineData
457aa3ee
JB
1Summary: HarfBuzz - internationalized text shaping library - MinGW32 cross version
2Summary(pl.UTF-8): Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
3Name: crossmingw32-harfbuzz
c1f5955b
JB
4Version: 0.9.24
5Release: 1
457aa3ee
JB
6License: MIT
7Group: Development/Libraries
8Source0: http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-%{version}.tar.bz2
c1f5955b 9# Source0-md5: 9da7f9dd901ed9e093a033118ac663f4
f9ba0ecc 10Patch0: harfbuzz-mingw32.patch
457aa3ee 11URL: http://www.freedesktop.org/wiki/HarfBuzz
15a364e6
JB
12BuildRequires: autoconf >= 2.64
13BuildRequires: automake >= 1:1.11.1
457aa3ee
JB
14BuildRequires: crossmingw32-cairo >= 1.8.0
15BuildRequires: crossmingw32-freetype >= 2.3.8
16BuildRequires: crossmingw32-glib2 >= 2.16
17BuildRequires: crossmingw32-gcc-c++
15a364e6 18BuildRequires: libtool >= 2:2.2
a2a964b7 19BuildRequires: pkgconfig >= 1:0.20
457aa3ee
JB
20Requires: crossmingw32-cairo >= 1.8.0
21Requires: crossmingw32-freetype >= 2.3.8
22Requires: crossmingw32-glib2 >= 2.16
23Requires: crossmingw32-gcc-c++
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26# see <harfbuzz/internal/ftserv.h>, the real horror
27%define specflags -fno-strict-aliasing
28
29%define no_install_post_strip 1
30
31%define target i386-mingw32
32%define target_platform i386-pc-mingw32
33
34%define _sysprefix /usr
35%define _prefix %{_sysprefix}/%{target}
36%define _libdir %{_prefix}/lib
37%define _pkgconfigdir %{_prefix}/lib/pkgconfig
38%define _dlldir /usr/share/wine/windows/system
39%define __cc %{target}-gcc
40%define __cxx %{target}-g++
16d7336b 41%define __pkgconfig_provides %{nil}
94aebac6 42%define __pkgconfig_requires %{nil}
457aa3ee
JB
43
44%ifnarch %{ix86}
45# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
46%define optflags -O2
47%endif
48# -z options are invalid for mingw linker, most of -f options are Linux-specific
49%define filterout_ld -Wl,-z,.*
50%define filterout_c -f[-a-z0-9=]*
51%define filterout_cxx -f[-a-z0-9=]*
52
53%description
54Internationalized OpenType text layout and rendering library.
55
56This package contains the cross version for Win32.
57
58%description -l pl.UTF-8
59Biblioteka rozmieszczająca i rysująca tekst z fontów OpenType,
60obsługująca wiele języków.
61
62Ten pakiet zawiera wersję skrośną dla Win32.
63
64%package static
65Summary: Static harfbuzz library (cross MinGW32 version)
66Summary(pl.UTF-8): Statyczna biblioteka harfbuzz (wersja skrośna MinGW32)
67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
69
70%description static
71Static harfbuzz library (cross MinGW32 version).
72
73%description static -l pl.UTF-8
74Statyczna biblioteka harfbuzz (wersja skrośna MinGW32).
75
76%package dll
77Summary: DLL harfbuzz library for Windows
78Summary(pl.UTF-8): Biblioteka DLL harfbuzz dla Windows
79Group: Applications/Emulators
80Requires: crossmingw32-cairo-dll >= 1.8.0
81Requires: crossmingw32-freetype-dll >= 2.3.8
82Requires: crossmingw32-glib2-dll >= 2.16
83Requires: wine
84
85%description dll
86DLL harfbuzz library for Windows.
87
88%description dll -l pl.UTF-8
89Biblioteka DLL harfbuzz dla Windows.
90
91%prep
92%setup -q -n harfbuzz-%{version}
f9ba0ecc 93%patch0 -p1
457aa3ee
JB
94
95%build
15a364e6
JB
96%{__libtoolize}
97%{__aclocal} -I m4
98%{__autoconf}
99%{__autoheader}
100%{__automake}
457aa3ee
JB
101export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
102%configure \
103 --target=%{target} \
104 --build=i686-pc-linux-gnu \
105 --host=%{target} \
2bcfc9b2 106 --disable-gtk-doc \
457aa3ee 107 --disable-silent-rules \
15a364e6
JB
108 --enable-static \
109 --with-cairo \
110 --with-freetype \
111 --with-glib \
112 --without-graphite2 \
2bcfc9b2 113 --with-html-dir=%{_gtkdocdir} \
15a364e6
JB
114 --without-icu \
115 --with-uniscribe
457aa3ee
JB
116
117%{__make}
118
119%install
120rm -rf $RPM_BUILD_ROOT
121
15a364e6 122%{__make} install \
457aa3ee
JB
123 DESTDIR=$RPM_BUILD_ROOT
124
125install -d $RPM_BUILD_ROOT%{_dlldir}
126mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
127
128%if 0%{!?debug:1}
129%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
130%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
131%endif
132
2bcfc9b2
JB
133%{__rm} -rf $RPM_BUILD_ROOT%{_gtkdocdir}
134
457aa3ee
JB
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%files
139%defattr(644,root,root,755)
140%doc COPYING ChangeLog README TODO
141%{_libdir}/libharfbuzz.dll.a
142%{_libdir}/libharfbuzz.la
143%{_includedir}/harfbuzz
144%{_pkgconfigdir}/harfbuzz.pc
145
146%files static
147%defattr(644,root,root,755)
148%{_libdir}/libharfbuzz.a
149
150%files dll
151%defattr(644,root,root,755)
152%{_dlldir}/libharfbuzz-*.dll
This page took 0.052751 seconds and 4 git commands to generate.