]> git.pld-linux.org Git - packages/crossmingw32-gtkmm.git/blob - crossmingw32-gtkmm.spec
b1226edb0089721d72e7e6951791b7cbc47c6077
[packages/crossmingw32-gtkmm.git] / crossmingw32-gtkmm.spec
1 Summary:        A C++ interface for the GTK+ (a GUI library for X) - cross MinGW32 version
2 Summary(pl.UTF-8):      Wrapper C++ dla GTK+ - skrośna wersja MinGW32
3 %define         realname   gtkmm
4 Name:           crossmingw32-%{realname}
5 Version:        2.24.3
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.24/%{realname}-%{version}.tar.xz
10 # Source0-md5:  42fc5a3feeb33ea59b7660200e2a5465
11 URL:            http://www.gtkmm.org/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  crossmingw32-atkmm >= 2.22.2
15 BuildRequires:  crossmingw32-cairomm >= 1.6.3
16 BuildRequires:  crossmingw32-gcc-c++ >= 3.3.1
17 BuildRequires:  crossmingw32-glibmm >= 2.28.0
18 BuildRequires:  crossmingw32-gtk+2 >= 2.20.0
19 BuildRequires:  crossmingw32-pangomm >= 2.28.0
20 BuildRequires:  libtool >= 2:1.5
21 BuildRequires:  mm-common >= 0.9.5
22 BuildRequires:  perl-base >= 1:5.6.0
23 BuildRequires:  pkgconfig >= 1:0.15
24 BuildRequires:  rpmbuild(macros) >= 1.446
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       crossmingw32-atkmm >= 2.22.2
28 Requires:       crossmingw32-cairomm >= 1.6.3
29 Requires:       crossmingw32-gtk+2 >= 2.20.0
30 Requires:       crossmingw32-pangomm >= 2.28.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         no_install_post_strip   1
34
35 %define         target                  i386-mingw32
36 %define         target_platform         i386-pc-mingw32
37
38 %define         _sysprefix              /usr
39 %define         _prefix                 %{_sysprefix}/%{target}
40 %define         _libdir                 %{_prefix}/lib
41 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
42 %define         _dlldir                 /usr/share/wine/windows/system
43 %define         __cc                    %{target}-gcc
44 %define         __cxx                   %{target}-g++
45
46 %ifnarch %{ix86}
47 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
48 %define         optflags        -O2
49 %endif
50 # -z options are invalid for mingw linker
51 %define         filterout_ld    -Wl,-z,.*
52
53 %description
54 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
55 library. The interface provides a convenient interface for C++
56 programmers to create GUIs with GTK+'s flexible object-oriented
57 framework. Features include type safe callbacks, widgets that are
58 extensible using inheritance and over 110 classes that can be freely
59 combined to quickly create complex user interfaces.
60
61 This package contains the cross version for Win32.
62
63 %description -l pl.UTF-8
64 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
65 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
66 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
67
68 Ten pakiet zawiera wersję skrośną dla Win32.
69
70 %package static
71 Summary:        Static gtkmm libraries (cross MinGW32 version)
72 Summary(pl.UTF-8):      Statyczne biblioteki gtkmm (wersja skrośna MinGW32)
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75
76 %description static
77 Static gtkmm libraries (cross MinGW32 version).
78
79 %description static -l pl.UTF-8
80 Statyczne biblioteki gtkmm (wersja skrośna MinGW32).
81
82 %package dll
83 Summary:        DLL gtkmm libraries for Windows
84 Summary(pl.UTF-8):      Biblioteki DLL gtkmm dla Windows
85 Group:          Applications/Emulators
86 Requires:       crossmingw32-atkmm-dll >= 2.22.2
87 Requires:       crossmingw32-cairomm-dll >= 1.6.3
88 Requires:       crossmingw32-glibmm-dll >= 2.28.0
89 Requires:       crossmingw32-gtk+2-dll >= 2.20.0
90 Requires:       crossmingw32-pangomm-dll >= 2.28.0
91 Requires:       wine
92
93 %description dll
94 DLL gtkmm libraries for Windows.
95
96 %description dll -l pl.UTF-8
97 Biblioteki DLL gtkmm dla Windows.
98
99 %prep
100 %setup -q -n %{realname}-%{version}
101
102 %build
103 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
104 %{__libtoolize}
105 %{__aclocal} -I build
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         --targe=%{target} \
111         --host=%{target} \
112         --disable-documentation \
113         --enable-static
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 install -d $RPM_BUILD_ROOT%{_dlldir}
124 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
125
126 %if 0%{!?debug:1}
127 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
128 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
129 %endif
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 %defattr(644,root,root,755)
136 %doc AUTHORS ChangeLog NEWS PORTING README
137 %{_libdir}/libgdkmm-2.4.dll.a
138 %{_libdir}/libgtkmm-2.4.dll.a
139 %{_libdir}/libgdkmm-2.4.la
140 %{_libdir}/libgtkmm-2.4.la
141 %{_libdir}/gdkmm-2.4
142 %{_libdir}/gtkmm-2.4
143 %{_includedir}/gdkmm-2.4
144 %{_includedir}/gtkmm-2.4
145 %{_pkgconfigdir}/gdkmm-2.4.pc
146 %{_pkgconfigdir}/gtkmm-2.4.pc
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libgdkmm-2.4.a
151 %{_libdir}/libgtkmm-2.4.a
152
153 %files dll
154 %defattr(644,root,root,755)
155 %{_dlldir}/libgdkmm-2.4-*.dll
156 %{_dlldir}/libgtkmm-2.4-*.dll
This page took 0.088735 seconds and 3 git commands to generate.