]> git.pld-linux.org Git - packages/crossmingw32-glib2.git/commitdiff
- updated to 2.52.1 auto/th/crossmingw32-glib2-2.52.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 10 Apr 2017 19:56:01 +0000 (21:56 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 10 Apr 2017 19:56:01 +0000 (21:56 +0200)
- added C90 fix for WIN32 specific code to win32 patch

crossmingw32-glib2.spec
glib2-win32.patch

index 7e75602eea4acc1016f7a945ac17a445db178328..09d492eefe3c53a2d07c9e59c49a185a9f041683 100644 (file)
@@ -12,12 +12,12 @@ Summary(tr.UTF-8):  Yararlı ufak yordamlar kitaplığı
 Summary(zh_CN.UTF-8):  实用工具函数库
 %define                realname   glib
 Name:          crossmingw32-glib2
-Version:       2.50.3
+Version:       2.52.1
 Release:       1
 License:       LGPL v2+
 Group:         Development/Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/glib/2.50/glib-%{version}.tar.xz
-# Source0-md5: 381ab22934f296750d036aa55a397ded
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/glib/2.52/glib-%{version}.tar.xz
+# Source0-md5: 36b4c7bf4f2b398ac8ad90578d05c950
 Patch0:                glib2-win32.patch
 URL:           http://www.gtk.org/
 BuildRequires: autoconf >= 2.62
index 5472d5b8783411db15aac6e3d25f0d5abaad7ec0..dea9ef99bec949805b48782b6b90df60d123598f 100644 (file)
  
  #include "glib.h"
  #include "gthreadprivate.h"
+--- glib-2.52.1/glib/gfileutils.c.orig 2017-04-08 07:47:34.000000000 +0200
++++ glib-2.52.1/glib/gfileutils.c      2017-04-10 21:52:01.204735832 +0200
+@@ -317,6 +317,11 @@
+ g_file_test (const gchar *filename,
+              GFileTest    test)
+ {
++#ifdef G_OS_WIN32
++  int attributes;
++  wchar_t *wfilename;
++#endif
++
+   g_return_val_if_fail (filename != NULL, FALSE);
+ #ifdef G_OS_WIN32
+@@ -327,8 +332,7 @@
+ #  ifndef FILE_ATTRIBUTE_DEVICE
+ #    define FILE_ATTRIBUTE_DEVICE 64
+ #  endif
+-  int attributes;
+-  wchar_t *wfilename = g_utf8_to_utf16 (filename, -1, NULL, NULL, NULL);
++  wfilename = g_utf8_to_utf16 (filename, -1, NULL, NULL, NULL);
+   if (wfilename == NULL)
+     return FALSE;
This page took 0.10145 seconds and 4 git commands to generate.