]> git.pld-linux.org Git - packages/crossmingw32-gdk-pixbuf2.git/blob - crossmingw32-gdk-pixbuf2.spec
bd1304b24fb08a5fe457e07896e6d07075349763
[packages/crossmingw32-gdk-pixbuf2.git] / crossmingw32-gdk-pixbuf2.spec
1 #
2 # Conditional build:
3 %bcond_without  gdiplus # use libjpeg and libtiff instead of system GDIPLUS
4 #
5 Summary:        An image loading and scaling library - cross MinGW32 version
6 Summary(pl.UTF-8):      Biblioteka ładująca i skalująca obrazki - wersja skrośna MinGW32
7 Name:           crossmingw32-gdk-pixbuf2
8 Version:        2.24.1
9 Release:        1
10 License:        LGPL v2+
11 Group:          Development/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gdk-pixbuf/2.24/gdk-pixbuf-%{version}.tar.xz
13 # Source0-md5:  72f39b34b20f68148c1609bd27415412
14 Patch0:         gdk-pixbuf2-gdip.patch
15 URL:            http://developer.gnome.org/gdk-pixbuf/
16 BuildRequires:  crossmingw32-gcc
17 BuildRequires:  crossmingw32-glib2 >= 2.28.0
18 BuildRequires:  crossmingw32-jasper
19 BuildRequires:  crossmingw32-libpng
20 BuildRequires:  gtk-doc >= 1.11
21 BuildRequires:  pkgconfig >= 1:0.15
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 %if %{without gdiplus}
25 BuildRequires:  crossmingw32-libjpeg
26 BuildRequires:  crossmingw32-libtiff
27 %endif
28 Requires:       crossmingw32-glib2 >= 2.28.0
29 Conflicts:      crossmingw32-gtk+2 < 2.22.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         abiver  2.10.0
33
34 %define         no_install_post_strip   1
35
36 %define         target                  i386-mingw32
37 %define         target_platform         i386-pc-mingw32
38
39 %define         _sysprefix              /usr
40 %define         _prefix                 %{_sysprefix}/%{target}
41 %define         _libdir                 %{_prefix}/lib
42 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
43 %define         _dlldir                 /usr/share/wine/windows/system
44 %define         __cc                    %{target}-gcc
45 %define         __cxx                   %{target}-g++
46
47 #define         filterout_ld            (-Wl,)?-as-needed.*
48
49 %ifnarch %{ix86}
50 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
51 %define         optflags        -O2
52 %endif
53 # -z options are invalid for mingw linker
54 %define         filterout_ld    -Wl,-z,.*
55
56 %description
57 gdk-pixbuf is an image loading and scaling library that can be
58 extended by loadable modules for new image formats.
59
60 This package contains the cross version for Win32.
61
62 %description -l pl.UTF-8
63 gdk-pixbuf to biblioteka ładująca i skalująca obrazki, której
64 funkcjonalność może być rozszerzana o obsługę nowych formatów poprzez
65 ładowane moduły.
66
67 Ten pakiet zawiera wersję skrośną dla Win32.
68
69 %package dll
70 Summary:        DLL gdk-pixbuf libraries for Windows
71 Summary(pl.UTF-8):      Biblioteki DLL gdk-pixbuf dla Windows
72 Group:          Applications/Emulators
73 Requires:       crossmingw32-glib2-dll >= 2.28.0
74 Requires:       wine
75 Conflicts:      crossmingw32-gtk+2-dll < 2.22.0
76
77 %description dll
78 DLL gdk-pixbuf libraries for Windows.
79
80 %description dll -l pl.UTF-8
81 Biblioteki DLL gdk-pixbuf dla Windows.
82
83 %prep
84 %setup -q -n gdk-pixbuf-%{version}
85 %patch0 -p1
86
87 %build
88 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
89 %configure \
90         --target=%{target} \
91         --host=%{target} \
92         --disable-gtk-doc \
93         --disable-man \
94         --with-libjasper \
95         %{!?with_gdiplus:--without-gdiplus}
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 install -d $RPM_BUILD_ROOT%{_dlldir}
106 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
107
108 %if 0%{!?debug:1}
109 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll \
110         $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders/*.dll
111 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
112 %endif
113
114 # shut up check-files
115 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,locale,man}
116 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders/*.{la,dll.a}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %{_libdir}/libgdk_pixbuf-2.0.dll.a
124 %{_libdir}/libgdk_pixbuf-2.0.la
125 %{_libdir}/gdk_pixbuf-2.0.def
126 %{_includedir}/gdk-pixbuf-2.0
127 %{_pkgconfigdir}/gdk-pixbuf-2.0.pc
128
129 %files dll
130 %defattr(644,root,root,755)
131 %{_dlldir}/libgdk_pixbuf-2.0-*.dll
132 %dir %{_libdir}/gdk-pixbuf-2.0
133 %dir %{_libdir}/gdk-pixbuf-2.0/%{abiver}
134 %dir %{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders
135 %{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders/libpixbufloader-*.dll
This page took 0.307861 seconds and 2 git commands to generate.