]> git.pld-linux.org Git - packages/crossmingw32-gdk-pixbuf2.git/blob - crossmingw32-gdk-pixbuf2.spec
041ff357836efe847b0f27a81e19ed0418d5e0bf
[packages/crossmingw32-gdk-pixbuf2.git] / crossmingw32-gdk-pixbuf2.spec
1 #
2 # Conditional build:
3 %bcond_without  gdiplus # use libjpeg and libtiff instead of system GDIPLUS
4 #
5 Summary:        An image loading and scaling library - cross MinGW32 version
6 Summary(pl.UTF-8):      Biblioteka ładująca i skalująca obrazki - wersja skrośna MinGW32
7 Name:           crossmingw32-gdk-pixbuf2
8 Version:        2.26.3
9 Release:        1
10 License:        LGPL v2+
11 Group:          Development/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gdk-pixbuf/2.26/gdk-pixbuf-%{version}.tar.xz
13 # Source0-md5:  350fb5dcaded7810bb77d424896f0b4e
14 Patch0:         gdk-pixbuf2-png-nodep.patch
15 Patch1:         gdk-pixbuf2-gdip.patch
16 URL:            http://developer.gnome.org/gdk-pixbuf/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  crossmingw32-gcc
20 BuildRequires:  crossmingw32-glib2 >= 2.32.0
21 BuildRequires:  crossmingw32-jasper
22 BuildRequires:  crossmingw32-libpng
23 BuildRequires:  gettext-devel >= 0.17
24 BuildRequires:  gtk-doc >= 1.11
25 BuildRequires:  libtool >= 2:2.2.6
26 BuildRequires:  pkgconfig >= 1:0.15
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 %if %{without gdiplus}
30 BuildRequires:  crossmingw32-libjpeg
31 BuildRequires:  crossmingw32-libtiff
32 %endif
33 Requires:       crossmingw32-glib2 >= 2.32.0
34 Conflicts:      crossmingw32-gtk+2 < 2.22.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         abiver  2.10.0
38
39 %define         no_install_post_strip   1
40
41 %define         target                  i386-mingw32
42 %define         target_platform         i386-pc-mingw32
43
44 %define         _sysprefix              /usr
45 %define         _prefix                 %{_sysprefix}/%{target}
46 %define         _libdir                 %{_prefix}/lib
47 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
48 %define         _dlldir                 /usr/share/wine/windows/system
49 %define         __cc                    %{target}-gcc
50 %define         __cxx                   %{target}-g++
51
52 #define         filterout_ld            (-Wl,)?-as-needed.*
53
54 %ifnarch %{ix86}
55 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
56 %define         optflags        -O2
57 %endif
58 # -z options are invalid for mingw linker
59 %define         filterout_ld    -Wl,-z,.*
60
61 %description
62 gdk-pixbuf is an image loading and scaling library that can be
63 extended by loadable modules for new image formats.
64
65 This package contains the cross version for Win32.
66
67 %description -l pl.UTF-8
68 gdk-pixbuf to biblioteka ładująca i skalująca obrazki, której
69 funkcjonalność może być rozszerzana o obsługę nowych formatów poprzez
70 ładowane moduły.
71
72 Ten pakiet zawiera wersję skrośną dla Win32.
73
74 %package dll
75 Summary:        DLL gdk-pixbuf libraries for Windows
76 Summary(pl.UTF-8):      Biblioteki DLL gdk-pixbuf dla Windows
77 Group:          Applications/Emulators
78 Requires:       crossmingw32-glib2-dll >= 2.32.0
79 Requires:       wine
80 Conflicts:      crossmingw32-gtk+2-dll < 2.22.0
81
82 %description dll
83 DLL gdk-pixbuf libraries for Windows.
84
85 %description dll -l pl.UTF-8
86 Biblioteki DLL gdk-pixbuf dla Windows.
87
88 %prep
89 %setup -q -n gdk-pixbuf-%{version}
90 %patch0 -p1
91 %patch1 -p1
92
93 %build
94 %{__gettextize}
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
101 %configure \
102         --target=%{target} \
103         --host=%{target} \
104         --disable-gtk-doc \
105         --disable-man \
106         --disable-silent-rules \
107         --with-libjasper \
108         %{!?with_gdiplus:--without-gdiplus}
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install -d $RPM_BUILD_ROOT%{_dlldir}
119 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
120
121 %if 0%{!?debug:1}
122 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll \
123         $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders/*.dll
124 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
125 %endif
126
127 # shut up check-files
128 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,locale,man}
129 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders/*.{la,dll.a}
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 %defattr(644,root,root,755)
136 %{_libdir}/libgdk_pixbuf-2.0.dll.a
137 %{_libdir}/libgdk_pixbuf-2.0.la
138 %{_libdir}/gdk_pixbuf-2.0.def
139 %{_includedir}/gdk-pixbuf-2.0
140 %{_pkgconfigdir}/gdk-pixbuf-2.0.pc
141
142 %files dll
143 %defattr(644,root,root,755)
144 %{_dlldir}/libgdk_pixbuf-2.0-*.dll
145 %dir %{_libdir}/gdk-pixbuf-2.0
146 %dir %{_libdir}/gdk-pixbuf-2.0/%{abiver}
147 %dir %{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders
148 %{_libdir}/gdk-pixbuf-2.0/%{abiver}/loaders/libpixbufloader-*.dll
This page took 0.052002 seconds and 2 git commands to generate.