]> git.pld-linux.org Git - packages/crossmingw32-gcc.git/commitdiff
- crossmingw32 gcc patch
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 11 Dec 2000 08:35:48 +0000 (08:35 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    crossmingw32-gcc-includes.patch -> 1.1
    crossmingw32-gcc-libiberty.patch -> 1.1
    crossmingw32-gcc-libio.patch -> 1.1

crossmingw32-gcc-includes.patch [new file with mode: 0644]
crossmingw32-gcc-libiberty.patch [new file with mode: 0644]
crossmingw32-gcc-libio.patch [new file with mode: 0644]

diff --git a/crossmingw32-gcc-includes.patch b/crossmingw32-gcc-includes.patch
new file mode 100644 (file)
index 0000000..9c612ce
--- /dev/null
@@ -0,0 +1,20 @@
+--- gcc-2.95.2/Makefile.in-noinc       Sun Aug  6 22:50:46 2000
++++ gcc-2.95.2/Makefile.in     Sun Aug  6 22:51:57 2000
+@@ -219,7 +219,7 @@
+         echo $$r/gcc/xgcc -B$$r/gcc/ -B$(build_tooldir)/bin/ -idirafter $$r/$(TARGET_SUBDIR)/newlib/targ-include -idirafter $$s/newlib/libc/include -nostdinc; \
+       fi; \
+     else \
+-      echo $$r/gcc/xgcc -B$$r/gcc/ -B$(build_tooldir)/bin/; \
++      echo $$r/gcc/xgcc -B$$r/gcc/ -B$(build_tooldir)/bin/ -idirafter $(build_tooldir)/include; \
+     fi; \
+   else \
+     if [ "$(host_canonical)" = "$(target_canonical)" ] ; then \
+@@ -255,7 +255,7 @@
+         echo $$r/gcc/xgcc -B$$r/gcc/ -B$(build_tooldir)/bin/ -idirafter $$r/$(TARGET_SUBDIR)/newlib/targ-include -idirafter $$s/newlib/libc/include -nostdinc; \
+       fi; \
+     else \
+-      echo $$r/gcc/xgcc -B$$r/gcc/ -B$(build_tooldir)/bin/; \
++      echo $$r/gcc/xgcc -B$$r/gcc/ -B$(build_tooldir)/bin/ -idirafter $(build_tooldir)/include; \
+     fi; \
+   else \
+     if [ "$(host_canonical)" = "$(target_canonical)" ] ; then \
diff --git a/crossmingw32-gcc-libiberty.patch b/crossmingw32-gcc-libiberty.patch
new file mode 100644 (file)
index 0000000..dfde64b
--- /dev/null
@@ -0,0 +1,100 @@
+diff -r -N -C2 gas-980103.orig/libiberty/config/mt-mingw32 gas-980103/libiberty/config/mt-mingw32
+*** gas-980103.orig/libiberty/config/mt-mingw32        Thu Jan  1 00:00:00 1970
+--- gas-980103/libiberty/config/mt-mingw32     Sat Jan  3 15:27:05 1998
+***************
+*** 0 ****
+--- 1,27 ----
++ # Mingw32 target Makefile fragment.
++ # The autoconfiguration fails for a Mingw32 target, because of an
++ # incompatible definition of sys_errlist, which is imported from a DLL.
++ # Therefore, we compute the dependencies by hand.
++ 
++ HDEFINES = -DNO_SYS_PARAM_H -DNO_SYS_FILE_H
++ CONFIG_H = mgconfig.h
++ NEEDED_LIST = mgneeded-list
++ 
++ mgconfig.h: Makefile
++      if [ -f ../newlib/Makefile ]; then \
++        $(MAKE) $(FLAGS_TO_PASS) xconfig.h; \
++        cp xconfig.h mgconfig.h; \
++      else \
++        echo "#define NEED_basename 1"    > mgconfig.h; \
++        echo "#define NEED_sys_siglist 1" >> mgconfig.h; \
++        echo "#define NEED_strsignal 1"   >> mgconfig.h; \
++        echo "#define NEED_psignal 1"     >> mgconfig.h; \
++      fi
++ 
++ mgneeded-list: Makefile
++      if [ -f ../newlib/Makefile ]; then \
++        $(MAKE) $(FLAGS_TO_PASS) xneeded-list; \
++        cp xneeded-list mgneeded-list; \
++      else \
++        echo getopt.o vasprintf.o > mgneeded-list; \
++      fi
+diff -r -N -C2 gcc-2.95.2/libiberty/config.table~ gcc-2.95/libiberty/config.table
+*** gcc-2.95.2/libiberty/config.table~ Wed Apr  7 05:31:23 1999
+--- gcc-2.95.2/libiberty/config.table  Mon Jul 31 21:01:49 2000
+***************
+*** 23,26 ****
+--- 23,30 ----
+      arm*-*-*)                frags="${frags} ../../config/mh-armpic" ;;
+      hppa*-*-*)               frags="${frags} ../../config/mh-papic" ;;
++     i[3456]86-*-mingw32*)    frags="${frags} ../../config/mt-mingw32" ;;
++      # Mingw32 does not require strerror.o from REQUIRED_OFILES.
++      # Worse: it will not compile it because of an incompatible sys_errlist
++      # definition.
+      i[3456]86-*-*)   frags="${frags} ../../config/mh-x86pic" ;;
+      powerpc*-*-aix*) ;;
+diff -r -N -C2 gas-980103.orig/libiberty/pexecute.c gas-980103/libiberty/pexecute.c
+*** gas-980103.orig/libiberty/pexecute.c       Sat Jan  3 09:12:16 1998
+--- gas-980103/libiberty/pexecute.c    Sat Jan  3 15:44:23 1998
+***************
+*** 223,227 ****
+--- 223,230 ----
+  #if defined (_WIN32)
+  
++ #include <io.h>
++ #include <fcntl.h>
+  #include <process.h>
++ #include <signal.h>
+  extern int _spawnv ();
+  extern int _spawnvp ();
+***************
+*** 236,240 ****
+     to remove the outermost set of double quotes from all arguments.  */
+  
+! const char * const *
+  fix_argv (argvec)
+       char **argvec;
+--- 239,243 ----
+     to remove the outermost set of double quotes from all arguments.  */
+  
+! char * const *
+  fix_argv (argvec)
+       char **argvec;
+***************
+*** 253,257 ****
+            if (temp[j] == '"')
+              {
+!               newtemp = xmalloc (len + 2);
+                strncpy (newtemp, temp, j);
+                newtemp [j] = '\\';
+--- 256,260 ----
+            if (temp[j] == '"')
+              {
+!               newtemp = (char *) xmalloc (len + 2);
+                strncpy (newtemp, temp, j);
+                newtemp [j] = '\\';
+***************
+*** 267,271 ****
+        }
+  
+!   return (const char * const *) argvec;
+  }
+  
+--- 270,274 ----
+        }
+  
+!   return (char * const *) argvec;
+  }
+  
diff --git a/crossmingw32-gcc-libio.patch b/crossmingw32-gcc-libio.patch
new file mode 100644 (file)
index 0000000..e6062b3
--- /dev/null
@@ -0,0 +1,13 @@
+--- gcc-2.95.2/libio/stdiostream.h-inc Mon Aug  7 16:45:44 2000
++++ gcc-2.95.2/libio/stdiostream.h     Mon Aug  7 16:46:10 2000
+@@ -34,6 +34,10 @@
+ #include <iostream.h>
+ #include <stdio.h>
++#ifdef _WIN32
++#include <io.h>
++#endif
++
+ extern "C++" {
+ class stdiobuf : public filebuf {
+   protected:
This page took 0.10432 seconds and 4 git commands to generate.