]> git.pld-linux.org Git - packages/crossmingw32-gcc.git/blob - crossmingw32-gcc.spec
74bde243b4ab92e81c2ed072a4e1c73742e358a6
[packages/crossmingw32-gcc.git] / crossmingw32-gcc.spec
1 #
2 # TODO:
3 # - openmp
4 #
5 # Conditional build:
6 %bcond_with     bootstrap       # bootstrap build (using binary w32api/mingwrt)
7 #
8 Summary:        Cross MinGW32 GNU binary utility development utilities - gcc
9 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW32 gcc
10 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW32 gcc
11 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW32 - gcc
12 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW32 gcc
13 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW32 gcc
14 Name:           crossmingw32-gcc
15 Version:        4.7.3
16 Release:        1
17 Epoch:          1
18 License:        GPL v3+
19 Group:          Development/Languages
20 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
21 # Source0-md5:  86f428a30379bdee0224e353ee2f999e
22 %define         apiver  3.17
23 Source1:        http://downloads.sourceforge.net/mingw/w32api-%{apiver}-2-mingw32-dev.tar.lzma
24 # Source1-md5:  c3a86ffa6b8c21de868df54e4e38f05e
25 %define         runver  3.20
26 Source2:        http://downloads.sourceforge.net/mingw/mingwrt-%{runver}-mingw32-dev.tar.gz
27 # Source2-md5:  2d2f5c8165ff9c29661a5be96336a4f7
28 # svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_4_7_3_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_7-branch > gcc-branch.diff
29 Patch100:       gcc-branch.diff
30 # Patch100-md5: ed71b602ecff35de8f4678e27dd9c2ef
31 Patch0:         %{name}-buildsystem1.patch
32 Patch1:         %{name}-buildsystem2.patch
33 Patch2:         %{name}-lfs.patch
34 BuildRequires:  autoconf >= 2.64
35 BuildRequires:  automake >= 1:1.9.3
36 BuildRequires:  bison
37 BuildRequires:  crossmingw32-binutils >= 2.15.91.0.2-2
38 BuildRequires:  flex
39 BuildRequires:  libmpc-devel
40 %if %{without bootstrap}
41 BuildRequires:  crossmingw32-runtime >= 3.5
42 BuildRequires:  crossmingw32-w32api >= 3.1
43 %endif
44 BuildRequires:  mpfr-devel
45 BuildRequires:  perl-tools-pod
46 BuildRequires:  texinfo >= 4.2
47 %if %{with booststrap}
48 BuildRequires:  tar >= 1:1.22
49 BuildRequires:  xz
50 %endif
51 Requires:       crossmingw32-binutils >= 2.15.91.0.2-2
52 Requires:       gcc-dirs
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %define         target          i386-mingw32
56 %define         sysprefix       /usr
57 %define         arch            %{sysprefix}/%{target}
58 %define         gccarchdir      %{_libdir}/gcc/%{target}
59 %define         gcclibdir       %{gccarchdir}/%{version}
60 %define         _dlldir         /usr/share/wine/windows/system
61
62 %define         _noautostrip    .*/lib.*\\.a
63
64 %define         _enable_debug_packages 0
65
66 # functions with printf format attribute but with special parser and also
67 # receiving non constant format strings
68 %define         Werror_cflags   %{nil}
69
70 %define         _ssp_cflags     %{nil}
71
72 %description
73 crossmingw32 is a complete cross-compiling development system for
74 building stand-alone Microsoft Windows applications under Linux using
75 the MinGW32 build libraries. This includes a binutils, gcc with g++
76 and objc, and libstdc++, all cross targeted to i386-mingw32, along
77 with supporting Win32 libraries in 'coff' format from free sources.
78
79 This package contains cross targeted gcc.
80
81 %description -l de.UTF-8
82 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
83 anderem Rechner Code für Win32 zu generieren.
84
85 %description -l pl.UTF-8
86 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
87 pozwalającym budować aplikacje MS Windows pod Linuksem używając
88 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
89 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
90 z bibliotek w formacie COFF.
91
92 Ten pakiet zawiera gcc generujące skrośnie kod dla Win32.
93
94 %package -n crossmingw32-libgcc-dll
95 Summary:        libgcc DLL library for Windows
96 Summary(pl.UTF-8):      Biblioteka DLL libgcc dla Windows
97 Group:          Applications/Emulators
98 Requires:       wine
99
100 %description -n crossmingw32-libgcc-dll
101 libgcc DLL library for Windows.
102
103 %description -n crossmingw32-libgcc-dll -l pl.UTF-8
104 Biblioteka DLL libgcc dla Windows.
105
106 %package c++
107 Summary:        MinGW32 binary utility development utilities - g++
108 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - g++
109 Group:          Development/Languages
110 Requires:       %{name} = %{epoch}:%{version}-%{release}
111
112 %description c++
113 crossmingw32 is a complete cross-compiling development system for
114 building stand-alone Microsoft Windows applications under Linux using
115 the MinGW32 build libraries. This includes a binutils, gcc with g++
116 and objc, and libstdc++, all cross targeted to i386-mingw32, along
117 with supporting Win32 libraries in 'coff' format from free sources.
118
119 This package contains cross targeted g++ and (static) libstdc++.
120
121 %description c++ -l pl.UTF-8
122 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
123 pozwalającym budować aplikacje MS Windows pod Linuksem używając
124 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
125 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
126 z bibliotek w formacie COFF.
127
128 Ten pakiet zawiera g++ generujące kod pod Win32 oraz bibliotekę
129 libstdc++.
130
131 %package -n crossmingw32-libstdc++-static
132 Summary:        Static standard C++ library - cross MinGW32 version
133 Summary(pl.UTF-8):      Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32
134 Group:          Development/Libraries
135 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
136
137 %description -n crossmingw32-libstdc++-static
138 Static standard C++ library - cross MinGW32 version.
139
140 %description -n crossmingw32-libstdc++-static -l pl.UTF-8
141 Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32.
142
143 %package -n crossmingw32-libstdc++-dll
144 Summary:        libstdc++ DLL library for Windows
145 Summary(pl.UTF-8):      Biblioteka DLL libstdc++ dla Windows
146 Group:          Applications/Emulators
147 Requires:       crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
148 Requires:       wine
149
150 %description -n crossmingw32-libstdc++-dll
151 libstdc++ DLL library for Windows.
152
153 %description -n crossmingw32-libstdc++-dll -l pl.UTF-8
154 Biblioteka DLL libstdc++ dla Windows.
155
156 %package objc
157 Summary:        MinGW32 binary utility development utilities - objc
158 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - objc
159 Group:          Development/Languages
160 Requires:       %{name} = %{epoch}:%{version}-%{release}
161
162 %description objc
163 crossmingw32 is a complete cross-compiling development system for
164 building stand-alone Microsoft Windows applications under Linux using
165 the MinGW32 build libraries. This includes a binutils, gcc with g++
166 and objc, and libstdc++, all cross targeted to i386-mingw32, along
167 with supporting Win32 libraries in 'coff' format from free sources.
168
169 This package contains cross targeted objc compiler.
170
171 %description objc -l pl.UTF-8
172 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
173 pozwalającym budować aplikacje MS Windows pod Linuksem używając
174 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
175 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
176 z bibliotek w formacie COFF.
177
178 Ten pakiet zawiera kompilator objc generujący kod pod Win32.
179
180 %package -n crossmingw32-libobjc-static
181 Summary:        Static Objective C library - cross MinGW32 version
182 Summary(pl.UTF-8):      Statyczna biblioteka Objective C - wersja skrośna MinGW32
183 Group:          Development/Libraries
184 Requires:       %{name}-objc = %{epoch}:%{version}-%{release}
185
186 %description -n crossmingw32-libobjc-static
187 Static Objective C library - cross MinGW32 version.
188
189 %description -n crossmingw32-libobjc-static -l pl.UTF-8
190 Statyczna biblioteka Objective C - wersja skrośna MinGW32.
191
192 %package -n crossmingw32-libobjc-dll
193 Summary:        libobjc DLL library for Windows
194 Summary(pl.UTF-8):      Biblioteka DLL libobjc dla Windows
195 Group:          Applications/Emulators
196 Requires:       crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
197 Requires:       wine
198
199 %description -n crossmingw32-libobjc-dll
200 libobjc DLL library for Windows.
201
202 %description -n crossmingw32-libobjc-dll -l pl.UTF-8
203 Biblioteka DLL libobjc dla Windows.
204
205 %package fortran
206 Summary:        MinGW32 binary utility development utilities - Fortran
207 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - Fortran
208 Group:          Development/Languages
209 Requires:       %{name} = %{epoch}:%{version}-%{release}
210 Requires:       crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
211 Obsoletes:      crossmingw32-gcc-g77
212
213 %description fortran
214 crossmingw32 is a complete cross-compiling development system for
215 building stand-alone Microsoft Windows applications under Linux using
216 the MinGW32 build libraries. This includes a binutils, gcc with g++
217 and objc, and libstdc++, all cross targeted to i386-mingw32, along
218 with supporting Win32 libraries in 'coff' format from free sources.
219
220 This package contains cross targeted Fortran compiler.
221
222 %description fortran -l pl.UTF-8
223 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
224 pozwalającym budować aplikacje MS Windows pod Linuksem używając
225 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
226 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
227 z bibliotek w formacie COFF.
228
229 Ten pakiet zawiera kompilator Fortranu generujący kod pod Win32.
230
231 %package -n crossmingw32-libgfortran-static
232 Summary:        Static Fortran library - cross MinGW32 version
233 Summary(pl.UTF-8):      Statyczna biblioteka Fortranu - wersja skrośna MinGW32
234 Group:          Development/Libraries
235 Requires:       %{name}-fortran = %{epoch}:%{version}-%{release}
236
237 %description -n crossmingw32-libgfortran-static
238 Static Fortran library - cross MinGW32 version.
239
240 %description -n crossmingw32-libgfortran-static -l pl.UTF-8
241 Statyczna biblioteka Fortranu - wersja skrośna MinGW32.
242
243 %package -n crossmingw32-libgfortran-dll
244 Summary:        libgfortran DLL library for Windows
245 Summary(pl.UTF-8):      Biblioteka DLL libgfortran dla Windows
246 Group:          Applications/Emulators
247 Requires:       crossmingw32-libquadmath-dll
248
249 %description -n crossmingw32-libgfortran-dll
250 libgfortran DLL library for Windows.
251
252 %description -n crossmingw32-libgfortran-dll -l pl.UTF-8
253 Biblioteka DLL libgfortran dla Windows.
254
255 %package -n crossmingw32-libquadmath
256 Summary:        GCC __float128 support library - cross MinGW32 version
257 Summary(pl.UTF-8):      Biblioteka do obsługi typu __float128 - wersja skrośna MinGW32
258 License:        GPL v2+ with linking exception
259 Group:          Development/Libraries
260 Requires:       %{name} = %{epoch}:%{version}-%{release}
261
262 %description -n crossmingw32-libquadmath
263 This package contains cross MinGW32 version of GCC support library
264 which is needed for __float128 math support and for Fortran REAL*16
265 support.
266
267 %description -n crossmingw32-libquadmath -l pl.UTF-8
268 Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GCC do obsługi
269 operacji matematycznych na zmiennych typu __float128 oraz typu REAL*16
270 w Fortranie.
271
272 %package -n crossmingw32-libquadmath-static
273 Summary:        Static GCC __float128 support library - cross MinGW32 version
274 Summary(pl.UTF-8):      Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna MinGW32
275 License:        GPL v2+ with linking exception
276 Group:          Development/Libraries
277 Requires:       crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
278
279 %description -n crossmingw32-libquadmath-static
280 Static GCC __float128 support library - cross MinGW32 version.
281
282 %description -n crossmingw32-libquadmath-static -l pl.UTF-8
283 Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna
284 MinGW32.
285
286 %package -n crossmingw32-libquadmath-dll
287 Summary:        DLL GCC __float128 support library for Windows
288 Summary(pl.UTF-8):      Biblioteka DLL GCC do obsługi typu __float128 dla Windows
289 License:        GPL v2+ with linking exception
290 Group:          Applications/Emulators
291 Requires:       wine
292
293 %description -n crossmingw32-libquadmath-dll
294 DLL GCC __float128 support library for Windows.
295
296 %description -n crossmingw32-libquadmath-dll -l pl.UTF-8
297 Biblioteka DLL GCC do obsługi typu __float128 dla Windows.
298
299 %package java
300 Summary:        MinGW32 binary utility development utilities - Java
301 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - Java
302 Group:          Development/Languages
303 Requires:       %{name} = %{epoch}:%{version}-%{release}
304
305 %description java
306 crossmingw32 is a complete cross-compiling development system for
307 building stand-alone Microsoft Windows applications under Linux using
308 the MinGW32 build libraries. This includes a binutils, gcc with g++
309 and objc, and libstdc++, all cross targeted to i386-mingw32, along
310 with supporting Win32 libraries in 'coff' format from free sources.
311
312 This package contains cross targeted Java compiler.
313
314 %description java -l pl.UTF-8
315 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
316 pozwalającym budować aplikacje MS Windows pod Linuksem używając
317 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
318 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
319 z bibliotek w formacie COFF.
320
321 Ten pakiet zawiera kompilator Javy generujący kod pod Win32.
322
323 %prep
324 %setup -q -n gcc-%{version}
325 %patch100 -p0
326 %patch0 -p1
327 %patch2 -p1
328
329 %if %{with bootstrap}
330 # note: "winsup" dirs below are special, handled by gcc's configure
331 install -d winsup/{mingw,w32api}
332 tar xf %{SOURCE1} -C winsup/w32api
333 tar xf %{SOURCE2} -C winsup/mingw
334 %endif
335
336 # override snapshot version.
337 echo %{version} > gcc/BASE-VER
338 echo "release" > gcc/DEV-PHASE
339
340 %build
341 rm -rf builddir && install -d builddir && cd builddir
342 %if %{with bootstrap}
343 install -d %{target}/winsup
344 ln -sf ../../../winsup/mingw/lib %{target}/winsup/mingw
345 ln -sf ../../../winsup/w32api %{target}/winsup/w32api
346 WINSUPDIR=$(cd ..; pwd)/winsup
347 %endif
348
349 CC="%{__cc}" \
350 CFLAGS="%{rpmcflags}" \
351 CXXFLAGS="%{rpmcxxflags}" \
352 TEXCONFIG=false \
353 ../configure \
354         --prefix=%{sysprefix} \
355         --bindir=%{arch}/bin \
356         --libdir=%{_libdir} \
357         --includedir=%{arch}/include \
358         --libexecdir=%{_libdir} \
359         --infodir=%{_infodir} \
360         --mandir=%{_mandir} \
361         %{!?with_bootstrap:--with-headers=%{arch}/include} \
362         --with-libs=%{!?with_bootstrap:%{arch}/lib}%{?with_bootstrap:${WINSUPDIR}/mingw/lib} \
363         --with-build-time-tools=%{arch}/bin \
364         --with-dwarf2 \
365         --with-gnu-as \
366         --with-gnu-ld \
367         --with-mangler-in-ld \
368         --with-long-double-128 \
369         --enable-threads \
370         --enable-languages="c,c++,fortran,java,objc" \
371         --enable-c99 \
372         --enable-long-long \
373         --enable-fully-dynamic-string \
374         --enable-libstdcxx-allocator=new \
375         --enable-version-specific-runtime-libs \
376         --enable-shared \
377         --disable-nls \
378         --disable-symvers \
379         --disable-sjlj-exceptions \
380         --disable-win32-registry \
381         --disable-multilib \
382         --disable-libssp \
383         --target=%{target}
384
385 cd ..
386 %{__make} -C builddir all-host
387 patch -p1 <%{PATCH1}
388 %{__make} -C builddir
389
390 %install
391 rm -rf $RPM_BUILD_ROOT
392 install -d $RPM_BUILD_ROOT%{_bindir}
393
394 %{__make} -C builddir install \
395         DESTDIR=$RPM_BUILD_ROOT
396
397 # host (ELF) library
398 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libiberty.a
399
400 mv $RPM_BUILD_ROOT%{gcclibdir}/include-fixed/{limits,syslimits}.h $RPM_BUILD_ROOT%{gcclibdir}/include
401 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/include-fixed
402 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/install-tools
403
404 # these must be symlinks: gcclibdir is calculated relatively to real binary path
405 ln -sf %{arch}/bin/%{target}-gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
406 ln -sf %{arch}/bin/%{target}-g++ $RPM_BUILD_ROOT%{_bindir}/%{target}-g++
407 ln -sf %{arch}/bin/%{target}-cpp $RPM_BUILD_ROOT%{_bindir}/%{target}-cpp
408 ln -sf %{arch}/bin/%{target}-gcov $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov
409 ln -sf %{arch}/bin/%{target}-gcj $RPM_BUILD_ROOT%{_bindir}/%{target}-gcj
410 ln -sf %{arch}/bin/%{target}-jcf-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-jcf-dump
411 ln -sf %{arch}/bin/%{target}-gfortran $RPM_BUILD_ROOT%{_bindir}/%{target}-gfortran
412
413 # DLLs
414 install -d $RPM_BUILD_ROOT%{_dlldir}
415 mv -f $RPM_BUILD_ROOT%{gccarchdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
416 mv -f $RPM_BUILD_ROOT%{gcclibdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
417 if [ ! -f $RPM_BUILD_ROOT%{_dlldir}/libgcc_s_dw2-1.dll ]; then
418         echo "libgcc DLL not installed?"
419         install builddir/i386-mingw32/libgcc/shlib/libgcc_s_dw2-1.dll $RPM_BUILD_ROOT%{_dlldir}
420 fi
421
422 %if 0%{!?debug:1}
423 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
424 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{gcclibdir}/lib*.a
425 %endif
426
427 # for pretty-printers see native gcc
428 %{__rm} $RPM_BUILD_ROOT%{gcclibdir}/libstdc++.dll.a-gdb.py
429 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gcc-%{version}/python/libstdcxx
430 # no plugin development for mingw32 (at least for now)
431 %{__rm} $RPM_BUILD_ROOT%{gcclibdir}/liblto_plugin.la
432 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/plugin
433 # already in native gcc
434 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
435 # common FSF man pages
436 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man7/{fsf-funding,gfdl,gpl}.7
437 # programs not packaged
438 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/%{target}-{aot-compile,gc-analyze,gcj-dbtool,gij,grmic,jv-convert,rebuild-gcj-db}.1
439
440 %clean
441 rm -rf $RPM_BUILD_ROOT
442
443 %files
444 %defattr(644,root,root,755)
445 %attr(755,root,root) %{_bindir}/%{target}-gcc
446 %attr(755,root,root) %{_bindir}/%{target}-cpp
447 %attr(755,root,root) %{_bindir}/%{target}-gcov
448 %attr(755,root,root) %{arch}/bin/%{target}-gcc
449 %attr(755,root,root) %{arch}/bin/%{target}-gcc-%{version}
450 %attr(755,root,root) %{arch}/bin/%{target}-gcc-ar
451 %attr(755,root,root) %{arch}/bin/%{target}-gcc-nm
452 %attr(755,root,root) %{arch}/bin/%{target}-gcc-ranlib
453 %attr(755,root,root) %{arch}/bin/%{target}-cpp
454 %attr(755,root,root) %{arch}/bin/%{target}-gcov
455 %attr(755,root,root) %{arch}/bin/gcc
456 %dir %{gccarchdir}
457 %dir %{gcclibdir}
458 %attr(755,root,root) %{gcclibdir}/cc1
459 %attr(755,root,root) %{gcclibdir}/collect2
460 %attr(755,root,root) %{gcclibdir}/lto-wrapper
461 %attr(755,root,root) %{gcclibdir}/lto1
462 %attr(755,root,root) %{gcclibdir}/liblto_plugin.so*
463 %{gcclibdir}/libgcc.a
464 %{gcclibdir}/libgcc_eh.a
465 %{gcclibdir}/libgcc_s.a
466 %{gcclibdir}/libgcov.a
467 %{gcclibdir}/crtbegin.o
468 %{gcclibdir}/crtend.o
469 %{gcclibdir}/crtfastmath.o
470 %dir %{gcclibdir}/include
471 %{gcclibdir}/include/*.h
472 %{_mandir}/man1/%{target}-cpp.1*
473 %{_mandir}/man1/%{target}-gcc.1*
474 %{_mandir}/man1/%{target}-gcov.1*
475
476 %files -n crossmingw32-libgcc-dll
477 %defattr(644,root,root,755)
478 %{_dlldir}/libgcc_s_dw2-1.dll
479
480 %files c++
481 %defattr(644,root,root,755)
482 %attr(755,root,root) %{_bindir}/%{target}-g++
483 %attr(755,root,root) %{arch}/bin/%{target}-c++
484 %attr(755,root,root) %{arch}/bin/%{target}-g++
485 %attr(755,root,root) %{arch}/bin/c++
486 %attr(755,root,root) %{arch}/bin/g++
487 %attr(755,root,root) %{gcclibdir}/cc1plus
488 %{gcclibdir}/libstdc++.dll.a
489 %{gcclibdir}/libstdc++.la
490 %{gcclibdir}/libsupc++.la
491 %{gcclibdir}/libsupc++.a
492 %{gcclibdir}/include/c++
493 %{_mandir}/man1/%{target}-g++.1*
494
495 %files -n crossmingw32-libstdc++-static
496 %defattr(644,root,root,755)
497 %{gcclibdir}/libstdc++.a
498
499 %files -n crossmingw32-libstdc++-dll
500 %defattr(644,root,root,755)
501 %{_dlldir}/libstdc++-6.dll
502
503 %files objc
504 %defattr(644,root,root,755)
505 %attr(755,root,root) %{gcclibdir}/cc1obj
506 %{gcclibdir}/libobjc.dll.a
507 %{gcclibdir}/libobjc.la
508 %{gcclibdir}/include/objc
509
510 %files -n crossmingw32-libobjc-static
511 %defattr(644,root,root,755)
512 %{gcclibdir}/libobjc.a
513
514 %files -n crossmingw32-libobjc-dll
515 %defattr(644,root,root,755)
516 %{_dlldir}/libobjc-4.dll
517
518 %files fortran
519 %defattr(644,root,root,755)
520 %attr(755,root,root) %{_bindir}/%{target}-gfortran
521 %attr(755,root,root) %{arch}/bin/%{target}-gfortran
522 %attr(755,root,root) %{arch}/bin/gfortran
523 %attr(755,root,root) %{gcclibdir}/f951
524 %{gcclibdir}/finclude
525 %{gcclibdir}/libcaf_single.a
526 %{gcclibdir}/libcaf_single.la
527 %{gcclibdir}/libgfortran.dll.a
528 %{gcclibdir}/libgfortran.la
529 %{gcclibdir}/libgfortran.spec
530 %{gcclibdir}/libgfortranbegin.a
531 %{gcclibdir}/libgfortranbegin.la
532 %{_mandir}/man1/%{target}-gfortran.1*
533
534 %files -n crossmingw32-libgfortran-static
535 %defattr(644,root,root,755)
536 %{gcclibdir}/libgfortran.a
537
538 %files -n crossmingw32-libgfortran-dll
539 %defattr(644,root,root,755)
540 %{_dlldir}/libgfortran-3.dll
541
542 %files -n crossmingw32-libquadmath
543 %defattr(644,root,root,755)
544 %{gcclibdir}/libquadmath.dll.a
545 %{gcclibdir}/libquadmath.la
546
547 %files -n crossmingw32-libquadmath-static
548 %defattr(644,root,root,755)
549 %{gcclibdir}/libquadmath.a
550
551 %files -n crossmingw32-libquadmath-dll
552 %defattr(644,root,root,755)
553 %{_dlldir}/libquadmath-0.dll
554
555 %files java
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_bindir}/%{target}-gcj
558 %attr(755,root,root) %{_bindir}/%{target}-jcf-dump
559 %attr(755,root,root) %{arch}/bin/%{target}-gcj
560 %attr(755,root,root) %{arch}/bin/%{target}-jcf-dump
561 %attr(755,root,root) %{gcclibdir}/jc1
562 %attr(755,root,root) %{gcclibdir}/jvgenmain
563 %{_mandir}/man1/%{target}-gcj.1*
564 %{_mandir}/man1/%{target}-jcf-dump.1*
This page took 0.950399 seconds and 2 git commands to generate.