]> git.pld-linux.org Git - packages/crossmingw32-gcc.git/blob - crossmingw32-gcc.spec
38edc289b7db805a6534f0fb5eb01cb60f2ea76b
[packages/crossmingw32-gcc.git] / crossmingw32-gcc.spec
1 #
2 # TODO:
3 # - openmp
4 #
5 # Conditional build:
6 %bcond_with     bootstrap       # bootstrap build (using binary w32api/mingwrt)
7 #
8 Summary:        Cross MinGW32 GNU binary utility development utilities - gcc
9 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW32 gcc
10 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW32 gcc
11 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW32 - gcc
12 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW32 gcc
13 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW32 gcc
14 Name:           crossmingw32-gcc
15 Version:        4.9.2
16 Release:        2
17 Epoch:          1
18 License:        GPL v3+
19 Group:          Development/Languages
20 Source0:        https://ftp.gnu.org/gnu/gcc/gcc-%{version}/gcc-%{version}.tar.bz2
21 # Source0-md5:  4df8ee253b7f3863ad0b86359cd39c43
22 %define         mingw32_ver     4.0.3
23 Source1:        http://downloads.sourceforge.net/mingw/mingwrt-%{mingw32_ver}-1-mingw32-dev.tar.lzma
24 # Source1-md5:  c2c9aa82e0cb47abac01760525684858
25 # svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_4_9_2_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_9-branch > gcc-branch.diff
26 Patch100:       gcc-branch.diff
27 # Patch100-md5: 1f1a11566ddf413cca96fbb04fd790d4
28 Patch0:         %{name}-buildsystem1.patch
29 Patch1:         %{name}-buildsystem2.patch
30 Patch2:         %{name}-lfs.patch
31 BuildRequires:  autoconf >= 2.64
32 BuildRequires:  automake >= 1:1.9.3
33 BuildRequires:  bison
34 BuildRequires:  crossmingw32-binutils >= 2.15.91.0.2-2
35 BuildRequires:  cloog-isl-devel >= 0.17.0
36 BuildRequires:  cloog-isl-devel < 0.19
37 BuildRequires:  flex
38 BuildRequires:  gmp-devel >= 4.1
39 BuildRequires:  isl-devel >= 0.13
40 BuildRequires:  libmpc-devel
41 %if %{without bootstrap}
42 BuildRequires:  crossmingw32-runtime >= 3.5
43 BuildRequires:  crossmingw32-w32api >= 3.1
44 %endif
45 BuildRequires:  mpfr-devel
46 BuildRequires:  perl-tools-pod
47 BuildRequires:  ppl-devel >= 0.11
48 BuildRequires:  texinfo >= 4.2
49 %if %{with booststrap}
50 BuildRequires:  tar >= 1:1.22
51 BuildRequires:  xz
52 %endif
53 Requires:       crossmingw32-binutils >= 2.15.91.0.2-2
54 Requires:       gcc-dirs
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         target          i386-mingw32
58 %define         sysprefix       /usr
59 %define         arch            %{sysprefix}/%{target}
60 %define         gccarchdir      %{_libdir}/gcc/%{target}
61 %define         gcclibdir       %{gccarchdir}/%{version}
62 %define         _dlldir         /usr/share/wine/windows/system
63
64 %define         _noautostrip    .*/lib.*\\.a
65
66 %define         _enable_debug_packages 0
67
68 # functions with printf format attribute but with special parser and also
69 # receiving non constant format strings
70 %define         Werror_cflags   %{nil}
71
72 %define         _ssp_cflags     %{nil}
73
74 %description
75 crossmingw32 is a complete cross-compiling development system for
76 building stand-alone Microsoft Windows applications under Linux using
77 the MinGW32 build libraries. This includes a binutils, gcc with g++
78 and objc, and libstdc++, all cross targeted to i386-mingw32, along
79 with supporting Win32 libraries in 'coff' format from free sources.
80
81 This package contains cross targeted gcc.
82
83 %description -l de.UTF-8
84 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
85 anderem Rechner Code für Win32 zu generieren.
86
87 %description -l pl.UTF-8
88 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
89 pozwalającym budować aplikacje MS Windows pod Linuksem używając
90 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
91 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
92 z bibliotek w formacie COFF.
93
94 Ten pakiet zawiera gcc generujące skrośnie kod dla Win32.
95
96 %package -n crossmingw32-libgcc-dll
97 Summary:        libgcc DLL library for Windows
98 Summary(pl.UTF-8):      Biblioteka DLL libgcc dla Windows
99 Group:          Applications/Emulators
100 Requires:       wine
101
102 %description -n crossmingw32-libgcc-dll
103 libgcc DLL library for Windows.
104
105 %description -n crossmingw32-libgcc-dll -l pl.UTF-8
106 Biblioteka DLL libgcc dla Windows.
107
108 %package c++
109 Summary:        MinGW32 binary utility development utilities - g++
110 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - g++
111 Group:          Development/Languages
112 Requires:       %{name} = %{epoch}:%{version}-%{release}
113
114 %description c++
115 crossmingw32 is a complete cross-compiling development system for
116 building stand-alone Microsoft Windows applications under Linux using
117 the MinGW32 build libraries. This includes a binutils, gcc with g++
118 and objc, and libstdc++, all cross targeted to i386-mingw32, along
119 with supporting Win32 libraries in 'coff' format from free sources.
120
121 This package contains cross targeted g++ and (static) libstdc++.
122
123 %description c++ -l pl.UTF-8
124 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
125 pozwalającym budować aplikacje MS Windows pod Linuksem używając
126 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
127 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
128 z bibliotek w formacie COFF.
129
130 Ten pakiet zawiera g++ generujące kod pod Win32 oraz bibliotekę
131 libstdc++.
132
133 %package -n crossmingw32-libstdc++-static
134 Summary:        Static standard C++ library - cross MinGW32 version
135 Summary(pl.UTF-8):      Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32
136 Group:          Development/Libraries
137 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
138
139 %description -n crossmingw32-libstdc++-static
140 Static standard C++ library - cross MinGW32 version.
141
142 %description -n crossmingw32-libstdc++-static -l pl.UTF-8
143 Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32.
144
145 %package -n crossmingw32-libstdc++-dll
146 Summary:        libstdc++ DLL library for Windows
147 Summary(pl.UTF-8):      Biblioteka DLL libstdc++ dla Windows
148 Group:          Applications/Emulators
149 Requires:       crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
150 Requires:       wine
151
152 %description -n crossmingw32-libstdc++-dll
153 libstdc++ DLL library for Windows.
154
155 %description -n crossmingw32-libstdc++-dll -l pl.UTF-8
156 Biblioteka DLL libstdc++ dla Windows.
157
158 %package objc
159 Summary:        MinGW32 binary utility development utilities - objc
160 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - objc
161 Group:          Development/Languages
162 Requires:       %{name} = %{epoch}:%{version}-%{release}
163
164 %description objc
165 crossmingw32 is a complete cross-compiling development system for
166 building stand-alone Microsoft Windows applications under Linux using
167 the MinGW32 build libraries. This includes a binutils, gcc with g++
168 and objc, and libstdc++, all cross targeted to i386-mingw32, along
169 with supporting Win32 libraries in 'coff' format from free sources.
170
171 This package contains cross targeted objc compiler.
172
173 %description objc -l pl.UTF-8
174 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
175 pozwalającym budować aplikacje MS Windows pod Linuksem używając
176 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
177 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
178 z bibliotek w formacie COFF.
179
180 Ten pakiet zawiera kompilator objc generujący kod pod Win32.
181
182 %package -n crossmingw32-libobjc-static
183 Summary:        Static Objective C library - cross MinGW32 version
184 Summary(pl.UTF-8):      Statyczna biblioteka Objective C - wersja skrośna MinGW32
185 Group:          Development/Libraries
186 Requires:       %{name}-objc = %{epoch}:%{version}-%{release}
187
188 %description -n crossmingw32-libobjc-static
189 Static Objective C library - cross MinGW32 version.
190
191 %description -n crossmingw32-libobjc-static -l pl.UTF-8
192 Statyczna biblioteka Objective C - wersja skrośna MinGW32.
193
194 %package -n crossmingw32-libobjc-dll
195 Summary:        libobjc DLL library for Windows
196 Summary(pl.UTF-8):      Biblioteka DLL libobjc dla Windows
197 Group:          Applications/Emulators
198 Requires:       crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
199 Requires:       wine
200
201 %description -n crossmingw32-libobjc-dll
202 libobjc DLL library for Windows.
203
204 %description -n crossmingw32-libobjc-dll -l pl.UTF-8
205 Biblioteka DLL libobjc dla Windows.
206
207 %package fortran
208 Summary:        MinGW32 binary utility development utilities - Fortran
209 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - Fortran
210 Group:          Development/Languages
211 Requires:       %{name} = %{epoch}:%{version}-%{release}
212 Requires:       crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
213 Obsoletes:      crossmingw32-gcc-g77
214
215 %description fortran
216 crossmingw32 is a complete cross-compiling development system for
217 building stand-alone Microsoft Windows applications under Linux using
218 the MinGW32 build libraries. This includes a binutils, gcc with g++
219 and objc, and libstdc++, all cross targeted to i386-mingw32, along
220 with supporting Win32 libraries in 'coff' format from free sources.
221
222 This package contains cross targeted Fortran compiler.
223
224 %description fortran -l pl.UTF-8
225 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
226 pozwalającym budować aplikacje MS Windows pod Linuksem używając
227 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
228 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
229 z bibliotek w formacie COFF.
230
231 Ten pakiet zawiera kompilator Fortranu generujący kod pod Win32.
232
233 %package -n crossmingw32-libgfortran-static
234 Summary:        Static Fortran library - cross MinGW32 version
235 Summary(pl.UTF-8):      Statyczna biblioteka Fortranu - wersja skrośna MinGW32
236 Group:          Development/Libraries
237 Requires:       %{name}-fortran = %{epoch}:%{version}-%{release}
238
239 %description -n crossmingw32-libgfortran-static
240 Static Fortran library - cross MinGW32 version.
241
242 %description -n crossmingw32-libgfortran-static -l pl.UTF-8
243 Statyczna biblioteka Fortranu - wersja skrośna MinGW32.
244
245 %package -n crossmingw32-libgfortran-dll
246 Summary:        libgfortran DLL library for Windows
247 Summary(pl.UTF-8):      Biblioteka DLL libgfortran dla Windows
248 Group:          Applications/Emulators
249 Requires:       crossmingw32-libquadmath-dll
250
251 %description -n crossmingw32-libgfortran-dll
252 libgfortran DLL library for Windows.
253
254 %description -n crossmingw32-libgfortran-dll -l pl.UTF-8
255 Biblioteka DLL libgfortran dla Windows.
256
257 %package -n crossmingw32-libquadmath
258 Summary:        GCC __float128 support library - cross MinGW32 version
259 Summary(pl.UTF-8):      Biblioteka do obsługi typu __float128 - wersja skrośna MinGW32
260 License:        GPL v2+ with linking exception
261 Group:          Development/Libraries
262 Requires:       %{name} = %{epoch}:%{version}-%{release}
263
264 %description -n crossmingw32-libquadmath
265 This package contains cross MinGW32 version of GCC support library
266 which is needed for __float128 math support and for Fortran REAL*16
267 support.
268
269 %description -n crossmingw32-libquadmath -l pl.UTF-8
270 Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GCC do obsługi
271 operacji matematycznych na zmiennych typu __float128 oraz typu REAL*16
272 w Fortranie.
273
274 %package -n crossmingw32-libquadmath-static
275 Summary:        Static GCC __float128 support library - cross MinGW32 version
276 Summary(pl.UTF-8):      Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna MinGW32
277 License:        GPL v2+ with linking exception
278 Group:          Development/Libraries
279 Requires:       crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
280
281 %description -n crossmingw32-libquadmath-static
282 Static GCC __float128 support library - cross MinGW32 version.
283
284 %description -n crossmingw32-libquadmath-static -l pl.UTF-8
285 Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna
286 MinGW32.
287
288 %package -n crossmingw32-libquadmath-dll
289 Summary:        DLL GCC __float128 support library for Windows
290 Summary(pl.UTF-8):      Biblioteka DLL GCC do obsługi typu __float128 dla Windows
291 License:        GPL v2+ with linking exception
292 Group:          Applications/Emulators
293 Requires:       wine
294
295 %description -n crossmingw32-libquadmath-dll
296 DLL GCC __float128 support library for Windows.
297
298 %description -n crossmingw32-libquadmath-dll -l pl.UTF-8
299 Biblioteka DLL GCC do obsługi typu __float128 dla Windows.
300
301 %package java
302 Summary:        MinGW32 binary utility development utilities - Java
303 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - Java
304 Group:          Development/Languages
305 Requires:       %{name} = %{epoch}:%{version}-%{release}
306
307 %description java
308 crossmingw32 is a complete cross-compiling development system for
309 building stand-alone Microsoft Windows applications under Linux using
310 the MinGW32 build libraries. This includes a binutils, gcc with g++
311 and objc, and libstdc++, all cross targeted to i386-mingw32, along
312 with supporting Win32 libraries in 'coff' format from free sources.
313
314 This package contains cross targeted Java compiler.
315
316 %description java -l pl.UTF-8
317 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
318 pozwalającym budować aplikacje MS Windows pod Linuksem używając
319 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
320 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
321 z bibliotek w formacie COFF.
322
323 Ten pakiet zawiera kompilator Javy generujący kod pod Win32.
324
325 %prep
326 %setup -q -n gcc-%{version}
327 %patch100 -p0
328 %patch0 -p1
329 %patch2 -p1
330
331 %if %{with bootstrap}
332 # note: "winsup" dir is special, handled by gcc's configure
333 install -d winsup/mingw
334 tar xf %{SOURCE1} -C winsup/mingw
335 %endif
336
337 # override snapshot version.
338 echo %{version} > gcc/BASE-VER
339 echo "release" > gcc/DEV-PHASE
340
341 %build
342 rm -rf builddir && install -d builddir && cd builddir
343 %if %{with bootstrap}
344 install -d %{target}/winsup
345 ln -sf ../../../winsup/mingw/lib %{target}/winsup/mingw
346 ln -sf ../../../winsup/mingw/include %{target}/winsup/w32api
347 WINSUPDIR=$(cd ..; pwd)/winsup
348 %endif
349
350 CC="%{__cc}" \
351 CFLAGS="%{rpmcflags}" \
352 CXXFLAGS="%{rpmcxxflags}" \
353 TEXCONFIG=false \
354 ../configure \
355         --prefix=%{sysprefix} \
356         --bindir=%{arch}/bin \
357         --libdir=%{_libdir} \
358         --includedir=%{arch}/include \
359         --libexecdir=%{_libdir} \
360         --infodir=%{_infodir} \
361         --mandir=%{_mandir} \
362         %{!?with_bootstrap:--with-headers=%{arch}/include} \
363         --with-libs=%{!?with_bootstrap:%{arch}/lib}%{?with_bootstrap:${WINSUPDIR}/mingw/lib} \
364         --with-build-time-tools=%{arch}/bin \
365         --with-dwarf2 \
366         --with-gnu-as \
367         --with-gnu-ld \
368         --with-mangler-in-ld \
369         --with-long-double-128 \
370         --with-ppl \
371         --disable-ppl-version-check \
372         --enable-threads \
373         --enable-languages="c,c++,fortran,java,objc" \
374         --enable-c99 \
375         --enable-long-long \
376         --enable-fully-dynamic-string \
377         --enable-libstdcxx-allocator=new \
378         --enable-version-specific-runtime-libs \
379         --enable-shared \
380         --disable-nls \
381         --disable-symvers \
382         --disable-sjlj-exceptions \
383         --disable-win32-registry \
384         --disable-multilib \
385         --disable-libssp \
386         --target=%{target}
387
388 cd ..
389 %{__make} -C builddir all-host
390 patch -p1 <%{PATCH1}
391 %{__make} -C builddir
392
393 %install
394 rm -rf $RPM_BUILD_ROOT
395 install -d $RPM_BUILD_ROOT%{_bindir}
396
397 %{__make} -C builddir install \
398         DESTDIR=$RPM_BUILD_ROOT
399
400 mv $RPM_BUILD_ROOT%{gcclibdir}/include-fixed/{limits,syslimits}.h $RPM_BUILD_ROOT%{gcclibdir}/include
401 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/include-fixed
402 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/install-tools
403
404 # these must be symlinks: gcclibdir is calculated relatively to real binary path
405 ln -sf %{arch}/bin/%{target}-gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
406 ln -sf %{arch}/bin/%{target}-g++ $RPM_BUILD_ROOT%{_bindir}/%{target}-g++
407 ln -sf %{arch}/bin/%{target}-cpp $RPM_BUILD_ROOT%{_bindir}/%{target}-cpp
408 ln -sf %{arch}/bin/%{target}-gcov $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov
409 ln -sf %{arch}/bin/%{target}-gcj $RPM_BUILD_ROOT%{_bindir}/%{target}-gcj
410 ln -sf %{arch}/bin/%{target}-jcf-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-jcf-dump
411 ln -sf %{arch}/bin/%{target}-gfortran $RPM_BUILD_ROOT%{_bindir}/%{target}-gfortran
412
413 # DLLs
414 install -d $RPM_BUILD_ROOT%{_dlldir}
415 mv -f $RPM_BUILD_ROOT%{gccarchdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
416 mv -f $RPM_BUILD_ROOT%{gcclibdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
417 if [ ! -f $RPM_BUILD_ROOT%{_dlldir}/libgcc_s_dw2-1.dll ]; then
418         echo "libgcc DLL not installed?"
419         install builddir/i386-mingw32/libgcc/shlib/libgcc_s_dw2-1.dll $RPM_BUILD_ROOT%{_dlldir}
420 fi
421
422 %if 0%{!?debug:1}
423 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
424 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{gcclibdir}/lib*.a
425 %endif
426
427 # for pretty-printers see native gcc
428 %{__rm} $RPM_BUILD_ROOT%{gcclibdir}/libstdc++.dll.a-gdb.py
429 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gcc-%{version}/python/libstdcxx
430 # no plugin development for mingw32 (at least for now)
431 %{__rm} $RPM_BUILD_ROOT%{gcclibdir}/liblto_plugin.la
432 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/plugin
433 # already in native gcc
434 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
435 # common FSF man pages
436 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man7/{fsf-funding,gfdl,gpl}.7
437 # programs not packaged
438 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/%{target}-{aot-compile,gc-analyze,gcj-dbtool,gij,grmic,jv-convert,rebuild-gcj-db}.1
439
440 %clean
441 rm -rf $RPM_BUILD_ROOT
442
443 %files
444 %defattr(644,root,root,755)
445 %attr(755,root,root) %{_bindir}/%{target}-gcc
446 %attr(755,root,root) %{_bindir}/%{target}-cpp
447 %attr(755,root,root) %{_bindir}/%{target}-gcov
448 %attr(755,root,root) %{arch}/bin/%{target}-gcc
449 %attr(755,root,root) %{arch}/bin/%{target}-gcc-%{version}
450 %attr(755,root,root) %{arch}/bin/%{target}-gcc-ar
451 %attr(755,root,root) %{arch}/bin/%{target}-gcc-nm
452 %attr(755,root,root) %{arch}/bin/%{target}-gcc-ranlib
453 %attr(755,root,root) %{arch}/bin/%{target}-cpp
454 %attr(755,root,root) %{arch}/bin/%{target}-gcov
455 %dir %{gccarchdir}
456 %dir %{gcclibdir}
457 %attr(755,root,root) %{gcclibdir}/cc1
458 %attr(755,root,root) %{gcclibdir}/collect2
459 %attr(755,root,root) %{gcclibdir}/lto-wrapper
460 %attr(755,root,root) %{gcclibdir}/lto1
461 %attr(755,root,root) %{gcclibdir}/liblto_plugin.so*
462 %{gcclibdir}/libgcc.a
463 %{gcclibdir}/libgcc_eh.a
464 %{gcclibdir}/libgcc_s.a
465 %{gcclibdir}/libgcov.a
466 %{gcclibdir}/crtbegin.o
467 %{gcclibdir}/crtend.o
468 %{gcclibdir}/crtfastmath.o
469 %dir %{gcclibdir}/include
470 %{gcclibdir}/include/*.h
471 %{_mandir}/man1/%{target}-cpp.1*
472 %{_mandir}/man1/%{target}-gcc.1*
473 %{_mandir}/man1/%{target}-gcov.1*
474
475 %files -n crossmingw32-libgcc-dll
476 %defattr(644,root,root,755)
477 %{_dlldir}/libgcc_s_dw2-1.dll
478
479 %files c++
480 %defattr(644,root,root,755)
481 %attr(755,root,root) %{_bindir}/%{target}-g++
482 %attr(755,root,root) %{arch}/bin/%{target}-c++
483 %attr(755,root,root) %{arch}/bin/%{target}-g++
484 %attr(755,root,root) %{gcclibdir}/cc1plus
485 %{gcclibdir}/libstdc++.dll.a
486 %{gcclibdir}/libstdc++.la
487 %{gcclibdir}/libsupc++.la
488 %{gcclibdir}/libsupc++.a
489 %{gcclibdir}/include/c++
490 %{_mandir}/man1/%{target}-g++.1*
491
492 %files -n crossmingw32-libstdc++-static
493 %defattr(644,root,root,755)
494 %{gcclibdir}/libstdc++.a
495
496 %files -n crossmingw32-libstdc++-dll
497 %defattr(644,root,root,755)
498 %{_dlldir}/libstdc++-6.dll
499
500 %files objc
501 %defattr(644,root,root,755)
502 %attr(755,root,root) %{gcclibdir}/cc1obj
503 %{gcclibdir}/libobjc.dll.a
504 %{gcclibdir}/libobjc.la
505 %{gcclibdir}/include/objc
506
507 %files -n crossmingw32-libobjc-static
508 %defattr(644,root,root,755)
509 %{gcclibdir}/libobjc.a
510
511 %files -n crossmingw32-libobjc-dll
512 %defattr(644,root,root,755)
513 %{_dlldir}/libobjc-4.dll
514
515 %files fortran
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_bindir}/%{target}-gfortran
518 %attr(755,root,root) %{arch}/bin/%{target}-gfortran
519 %attr(755,root,root) %{gcclibdir}/f951
520 %{gcclibdir}/finclude
521 %{gcclibdir}/libcaf_single.a
522 %{gcclibdir}/libcaf_single.la
523 %{gcclibdir}/libgfortran.dll.a
524 %{gcclibdir}/libgfortran.la
525 %{gcclibdir}/libgfortran.spec
526 %{gcclibdir}/libgfortranbegin.a
527 %{gcclibdir}/libgfortranbegin.la
528 %{_mandir}/man1/%{target}-gfortran.1*
529
530 %files -n crossmingw32-libgfortran-static
531 %defattr(644,root,root,755)
532 %{gcclibdir}/libgfortran.a
533
534 %files -n crossmingw32-libgfortran-dll
535 %defattr(644,root,root,755)
536 %{_dlldir}/libgfortran-3.dll
537
538 %files -n crossmingw32-libquadmath
539 %defattr(644,root,root,755)
540 %{gcclibdir}/libquadmath.dll.a
541 %{gcclibdir}/libquadmath.la
542
543 %files -n crossmingw32-libquadmath-static
544 %defattr(644,root,root,755)
545 %{gcclibdir}/libquadmath.a
546
547 %files -n crossmingw32-libquadmath-dll
548 %defattr(644,root,root,755)
549 %{_dlldir}/libquadmath-0.dll
550
551 %files java
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_bindir}/%{target}-gcj
554 %attr(755,root,root) %{_bindir}/%{target}-jcf-dump
555 %attr(755,root,root) %{arch}/bin/%{target}-gcj
556 %attr(755,root,root) %{arch}/bin/%{target}-jcf-dump
557 %attr(755,root,root) %{gcclibdir}/jc1
558 %attr(755,root,root) %{gcclibdir}/jvgenmain
559 %{_mandir}/man1/%{target}-gcj.1*
560 %{_mandir}/man1/%{target}-jcf-dump.1*
This page took 0.1579 seconds and 2 git commands to generate.