]> git.pld-linux.org Git - packages/crossmingw32-gcc.git/blob - crossmingw32-gcc.spec
3536a4a345119d33e47b34e4a279e3407e71957f
[packages/crossmingw32-gcc.git] / crossmingw32-gcc.spec
1 #
2 # TODO:
3 # - openmp
4 #
5 # Conditional build:
6 %bcond_with     bootstrap       # bootstrap build (using binary w32api/mingwrt)
7 #
8 Summary:        Cross MinGW32 GNU binary utility development utilities - gcc
9 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW32 gcc
10 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW32 gcc
11 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW32 - gcc
12 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW32 gcc
13 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW32 gcc
14 Name:           crossmingw32-gcc
15 Version:        4.6.3
16 Release:        4
17 Epoch:          1
18 License:        GPL v3+
19 Group:          Development/Languages
20 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
21 # Source0-md5:  773092fe5194353b02bb0110052a972e
22 %define         apiver  3.17
23 Source1:        http://downloads.sourceforge.net/mingw/w32api-%{apiver}-2-mingw32-dev.tar.lzma
24 # Source1-md5:  c3a86ffa6b8c21de868df54e4e38f05e
25 %define         runver  3.20
26 Source2:        http://downloads.sourceforge.net/mingw/mingwrt-%{runver}-mingw32-dev.tar.gz
27 # Source2-md5:  2d2f5c8165ff9c29661a5be96336a4f7
28 # svn diff -x --ignore-eol-style svn://gcc.gnu.org/svn/gcc/tags/gcc_4_6_1_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_6-branch > gcc-branch.diff
29 Patch100:       gcc-branch.diff
30 Patch0:         %{name}-buildsystem1.patch
31 Patch1:         %{name}-buildsystem2.patch
32 Patch2:         %{name}-lfs.patch
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  bison
36 BuildRequires:  crossmingw32-binutils >= 2.15.91.0.2-2
37 BuildRequires:  flex
38 BuildRequires:  libmpc-devel
39 %if %{without bootstrap}
40 BuildRequires:  crossmingw32-runtime >= 3.5
41 BuildRequires:  crossmingw32-w32api >= 3.1
42 %endif
43 BuildRequires:  mpfr-devel
44 BuildRequires:  perl-tools-pod
45 BuildRequires:  texinfo >= 4.2
46 %if %{with booststrap}
47 BuildRequires:  tar >= 1:1.22
48 BuildRequires:  xz
49 %endif
50 Requires:       crossmingw32-binutils >= 2.15.91.0.2-2
51 Requires:       gcc-dirs
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         target          i386-mingw32
55 %define         sysprefix       /usr
56 %define         arch            %{sysprefix}/%{target}
57 %define         gccarchdir      %{_libdir}/gcc/%{target}
58 %define         gcclibdir       %{gccarchdir}/%{version}
59 %define         _dlldir         /usr/share/wine/windows/system
60
61 %define         _noautostrip    .*/lib.*\\.a
62
63 %define         _enable_debug_packages 0
64
65 # functions with printf format attribute but with special parser and also
66 # receiving non constant format strings
67 %define         Werror_cflags   %{nil}
68
69 %define         _ssp_cflags     %{nil}
70
71 %description
72 crossmingw32 is a complete cross-compiling development system for
73 building stand-alone Microsoft Windows applications under Linux using
74 the MinGW32 build libraries. This includes a binutils, gcc with g++
75 and objc, and libstdc++, all cross targeted to i386-mingw32, along
76 with supporting Win32 libraries in 'coff' format from free sources.
77
78 This package contains cross targeted gcc.
79
80 %description -l de.UTF-8
81 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
82 anderem Rechner Code für Win32 zu generieren.
83
84 %description -l pl.UTF-8
85 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
86 pozwalającym budować aplikacje MS Windows pod Linuksem używając
87 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
88 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
89 z bibliotek w formacie COFF.
90
91 Ten pakiet zawiera gcc generujące skrośnie kod dla Win32.
92
93 %package -n crossmingw32-libgcc-dll
94 Summary:        libgcc DLL library for Windows
95 Summary(pl.UTF-8):      Biblioteka DLL libgcc dla Windows
96 Group:          Applications/Emulators
97 Requires:       wine
98
99 %description -n crossmingw32-libgcc-dll
100 libgcc DLL library for Windows.
101
102 %description -n crossmingw32-libgcc-dll -l pl.UTF-8
103 Biblioteka DLL libgcc dla Windows.
104
105 %package c++
106 Summary:        MinGW32 binary utility development utilities - g++
107 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - g++
108 Group:          Development/Languages
109 Requires:       %{name} = %{epoch}:%{version}-%{release}
110
111 %description c++
112 crossmingw32 is a complete cross-compiling development system for
113 building stand-alone Microsoft Windows applications under Linux using
114 the MinGW32 build libraries. This includes a binutils, gcc with g++
115 and objc, and libstdc++, all cross targeted to i386-mingw32, along
116 with supporting Win32 libraries in 'coff' format from free sources.
117
118 This package contains cross targeted g++ and (static) libstdc++.
119
120 %description c++ -l pl.UTF-8
121 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
122 pozwalającym budować aplikacje MS Windows pod Linuksem używając
123 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
124 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
125 z bibliotek w formacie COFF.
126
127 Ten pakiet zawiera g++ generujące kod pod Win32 oraz bibliotekę
128 libstdc++.
129
130 %package -n crossmingw32-libstdc++-static
131 Summary:        Static standard C++ library - cross MinGW32 version
132 Summary(pl.UTF-8):      Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32
133 Group:          Development/Libraries
134 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
135
136 %description -n crossmingw32-libstdc++-static
137 Static standard C++ library - cross MinGW32 version.
138
139 %description -n crossmingw32-libstdc++-static -l pl.UTF-8
140 Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32.
141
142 %package -n crossmingw32-libstdc++-dll
143 Summary:        libstdc++ DLL library for Windows
144 Summary(pl.UTF-8):      Biblioteka DLL libstdc++ dla Windows
145 Group:          Applications/Emulators
146 Requires:       crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
147 Requires:       wine
148
149 %description -n crossmingw32-libstdc++-dll
150 libstdc++ DLL library for Windows.
151
152 %description -n crossmingw32-libstdc++-dll -l pl.UTF-8
153 Biblioteka DLL libstdc++ dla Windows.
154
155 %package objc
156 Summary:        MinGW32 binary utility development utilities - objc
157 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - objc
158 Group:          Development/Languages
159 Requires:       %{name} = %{epoch}:%{version}-%{release}
160
161 %description objc
162 crossmingw32 is a complete cross-compiling development system for
163 building stand-alone Microsoft Windows applications under Linux using
164 the MinGW32 build libraries. This includes a binutils, gcc with g++
165 and objc, and libstdc++, all cross targeted to i386-mingw32, along
166 with supporting Win32 libraries in 'coff' format from free sources.
167
168 This package contains cross targeted objc compiler.
169
170 %description objc -l pl.UTF-8
171 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
172 pozwalającym budować aplikacje MS Windows pod Linuksem używając
173 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
174 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
175 z bibliotek w formacie COFF.
176
177 Ten pakiet zawiera kompilator objc generujący kod pod Win32.
178
179 %package -n crossmingw32-libobjc-static
180 Summary:        Static Objective C library - cross MinGW32 version
181 Summary(pl.UTF-8):      Statyczna biblioteka Objective C - wersja skrośna MinGW32
182 Group:          Development/Libraries
183 Requires:       %{name}-objc = %{epoch}:%{version}-%{release}
184
185 %description -n crossmingw32-libobjc-static
186 Static Objective C library - cross MinGW32 version.
187
188 %description -n crossmingw32-libobjc-static -l pl.UTF-8
189 Statyczna biblioteka Objective C - wersja skrośna MinGW32.
190
191 %package -n crossmingw32-libobjc-dll
192 Summary:        libobjc DLL library for Windows
193 Summary(pl.UTF-8):      Biblioteka DLL libobjc dla Windows
194 Group:          Applications/Emulators
195 Requires:       crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
196 Requires:       wine
197
198 %description -n crossmingw32-libobjc-dll
199 libobjc DLL library for Windows.
200
201 %description -n crossmingw32-libobjc-dll -l pl.UTF-8
202 Biblioteka DLL libobjc dla Windows.
203
204 %package fortran
205 Summary:        MinGW32 binary utility development utilities - Fortran
206 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - Fortran
207 Group:          Development/Languages
208 Requires:       %{name} = %{epoch}:%{version}-%{release}
209 Requires:       crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
210 Obsoletes:      crossmingw32-gcc-g77
211
212 %description fortran
213 crossmingw32 is a complete cross-compiling development system for
214 building stand-alone Microsoft Windows applications under Linux using
215 the MinGW32 build libraries. This includes a binutils, gcc with g++
216 and objc, and libstdc++, all cross targeted to i386-mingw32, along
217 with supporting Win32 libraries in 'coff' format from free sources.
218
219 This package contains cross targeted Fortran compiler.
220
221 %description fortran -l pl.UTF-8
222 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
223 pozwalającym budować aplikacje MS Windows pod Linuksem używając
224 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
225 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
226 z bibliotek w formacie COFF.
227
228 Ten pakiet zawiera kompilator Fortranu generujący kod pod Win32.
229
230 %package -n crossmingw32-libgfortran-static
231 Summary:        Static Fortran library - cross MinGW32 version
232 Summary(pl.UTF-8):      Statyczna biblioteka Fortrana - wersja skrośna MinGW32
233 Group:          Development/Libraries
234 Requires:       %{name}-fortran = %{epoch}:%{version}-%{release}
235
236 %description -n crossmingw32-libgfortran-static
237 Static Fortran library - cross MinGW32 version.
238
239 %description -n crossmingw32-libgfortran-static -l pl.UTF-8
240 Statyczna biblioteka Fortrana - wersja skrośna MinGW32.
241
242 %package -n crossmingw32-libgfortran-dll
243 Summary:        libgfortran DLL library for Windows
244 Summary(pl.UTF-8):      Biblioteka DLL libgfortran dla Windows
245 Group:          Applications/Emulators
246 Requires:       crossmingw32-libquadmath-dll
247
248 %description -n crossmingw32-libgfortran-dll
249 libgfortran DLL library for Windows.
250
251 %description -n crossmingw32-libgfortran-dll -l pl.UTF-8
252 Biblioteka DLL libgfortran dla Windows.
253
254 %package -n crossmingw32-libquadmath
255 Summary:        GCC __float128 support library - cross MinGW32 version
256 Summary(pl.UTF-8):      Biblioteka do obsługi typu __float128 - wersja skrośna MinGW32
257 License:        GPL v2+ with linking exception
258 Group:          Development/Libraries
259 Requires:       %{name} = %{epoch}:%{version}-%{release}
260
261 %description -n crossmingw32-libquadmath
262 This package contains cross MinGW32 version of GCC support library
263 which is needed for __float128 math support and for Fortran REAL*16
264 support.
265
266 %description -n crossmingw32-libquadmath -l pl.UTF-8
267 Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GCC do obsługi
268 operacji matematycznych na zmiennych typu __float128 oraz typu REAL*16
269 w Fortranie.
270
271 %package -n crossmingw32-libquadmath-static
272 Summary:        Static GCC __float128 support library - cross MinGW32 version
273 Summary(pl.UTF-8):      Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna MinGW32
274 License:        GPL v2+ with linking exception
275 Group:          Development/Libraries
276 Requires:       crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
277
278 %description -n crossmingw32-libquadmath-static
279 Static GCC __float128 support library - cross MinGW32 version.
280
281 %description -n crossmingw32-libquadmath-static -l pl.UTF-8
282 Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna
283 MinGW32.
284
285 %package -n crossmingw32-libquadmath-dll
286 Summary:        DLL GCC __float128 support library for Windows
287 Summary(pl.UTF-8):      Biblioteka DLL GCC do obsługi typu __float128 dla Windows
288 License:        GPL v2+ with linking exception
289 Group:          Applications/Emulators
290 Requires:       wine
291
292 %description -n crossmingw32-libquadmath-dll
293 DLL GCC __float128 support library for Windows.
294
295 %description -n crossmingw32-libquadmath-dll -l pl.UTF-8
296 Biblioteka DLL GCC do obsługi typu __float128 dla Windows.
297
298 %package java
299 Summary:        MinGW32 binary utility development utilities - Java
300 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - Java
301 Group:          Development/Languages
302 Requires:       %{name} = %{epoch}:%{version}-%{release}
303
304 %description java
305 crossmingw32 is a complete cross-compiling development system for
306 building stand-alone Microsoft Windows applications under Linux using
307 the MinGW32 build libraries. This includes a binutils, gcc with g++
308 and objc, and libstdc++, all cross targeted to i386-mingw32, along
309 with supporting Win32 libraries in 'coff' format from free sources.
310
311 This package contains cross targeted Java compiler.
312
313 %description java -l pl.UTF-8
314 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
315 pozwalającym budować aplikacje MS Windows pod Linuksem używając
316 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
317 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
318 z bibliotek w formacie COFF.
319
320 Ten pakiet zawiera kompilator Javy generujący kod pod Win32.
321
322 %prep
323 %setup -q -n gcc-%{version}
324 %patch100 -p0
325 %patch0 -p1
326 %patch2 -p1
327
328 %if %{with bootstrap}
329 # note: "winsup" dirs below are special, handled by gcc's configure
330 install -d winsup/{mingw,w32api}
331 tar xf %{SOURCE1} -C winsup/w32api
332 tar xf %{SOURCE2} -C winsup/mingw
333 %endif
334
335 # override snapshot version.
336 echo %{version} > gcc/BASE-VER
337 echo "release" > gcc/DEV-PHASE
338
339 %build
340 rm -rf builddir && install -d builddir && cd builddir
341 %if %{with bootstrap}
342 install -d %{target}/winsup
343 ln -sf ../../../winsup/mingw/lib %{target}/winsup/mingw
344 ln -sf ../../../winsup/w32api %{target}/winsup/w32api
345 WINSUPDIR=$(cd ..; pwd)/winsup
346 %endif
347
348 CC="%{__cc}" \
349 CFLAGS="%{rpmcflags}" \
350 CXXFLAGS="%{rpmcxxflags}" \
351 TEXCONFIG=false \
352 ../configure \
353         --prefix=%{sysprefix} \
354         --bindir=%{arch}/bin \
355         --libdir=%{_libdir} \
356         --includedir=%{arch}/include \
357         --libexecdir=%{_libdir} \
358         --infodir=%{_infodir} \
359         --mandir=%{_mandir} \
360         %{!?with_bootstrap:--with-headers=%{arch}/include} \
361         --with-libs=%{!?with_bootstrap:%{arch}/lib}%{?with_bootstrap:${WINSUPDIR}/mingw/lib} \
362         --with-build-time-tools=%{arch}/bin \
363         --with-dwarf2 \
364         --with-gnu-as \
365         --with-gnu-ld \
366         --with-mangler-in-ld \
367         --with-long-double-128 \
368         --enable-threads \
369         --enable-languages="c,c++,fortran,java,objc" \
370         --enable-c99 \
371         --enable-long-long \
372         --enable-fully-dynamic-string \
373         --enable-libstdcxx-allocator=new \
374         --enable-version-specific-runtime-libs \
375         --enable-shared \
376         --disable-nls \
377         --disable-symvers \
378         --disable-sjlj-exceptions \
379         --disable-win32-registry \
380         --disable-multilib \
381         --disable-libssp \
382         --target=%{target}
383
384 cd ..
385 %{__make} -C builddir all-host
386 patch -p1 <%{PATCH1}
387 %{__make} -C builddir
388
389 %install
390 rm -rf $RPM_BUILD_ROOT
391 install -d $RPM_BUILD_ROOT%{_bindir}
392
393 %{__make} -C builddir install \
394         DESTDIR=$RPM_BUILD_ROOT
395
396 # host (ELF) library
397 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libiberty.a
398
399 mv $RPM_BUILD_ROOT%{gcclibdir}/include-fixed/{limits,syslimits}.h $RPM_BUILD_ROOT%{gcclibdir}/include
400 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/include-fixed
401 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/install-tools
402
403 # these must be symlinks: gcclibdir is calculated relatively to real binary path
404 ln -sf %{arch}/bin/%{target}-gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
405 ln -sf %{arch}/bin/%{target}-g++ $RPM_BUILD_ROOT%{_bindir}/%{target}-g++
406 ln -sf %{arch}/bin/%{target}-cpp $RPM_BUILD_ROOT%{_bindir}/%{target}-cpp
407 ln -sf %{arch}/bin/%{target}-gcov $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov
408 ln -sf %{arch}/bin/%{target}-gcj $RPM_BUILD_ROOT%{_bindir}/%{target}-gcj
409 ln -sf %{arch}/bin/%{target}-jcf-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-jcf-dump
410 ln -sf %{arch}/bin/%{target}-gfortran $RPM_BUILD_ROOT%{_bindir}/%{target}-gfortran
411
412 # DLLs
413 install -d $RPM_BUILD_ROOT%{_dlldir}
414 mv -f $RPM_BUILD_ROOT%{gccarchdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
415 mv -f $RPM_BUILD_ROOT%{gcclibdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
416 if [ ! -f $RPM_BUILD_ROOT%{_dlldir}/libgcc_s_dw2-1.dll ]; then
417         echo "libgcc DLL not installed?"
418         install builddir/i386-mingw32/libgcc/shlib/libgcc_s_dw2-1.dll $RPM_BUILD_ROOT%{_dlldir}
419 fi
420
421 %if 0%{!?debug:1}
422 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
423 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{gcclibdir}/lib*.a
424 %endif
425
426 # for pretty-printers see native gcc
427 %{__rm} $RPM_BUILD_ROOT%{gcclibdir}/libstdc++.dll.a-gdb.py
428 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gcc-%{version}/python/libstdcxx
429 # no plugin development for mingw32 (at least for now)
430 %{__rm} $RPM_BUILD_ROOT%{gcclibdir}/liblto_plugin.la
431 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/plugin
432 # already in native gcc
433 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
434 # common FSF man pages
435 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man7/{fsf-funding,gfdl,gpl}.7
436 # programs not packaged
437 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/%{target}-{aot-compile,gc-analyze,gcj-dbtool,gij,grmic,jv-convert,rebuild-gcj-db}.1
438
439 %clean
440 rm -rf $RPM_BUILD_ROOT
441
442 %files
443 %defattr(644,root,root,755)
444 %attr(755,root,root) %{_bindir}/%{target}-gcc
445 %attr(755,root,root) %{_bindir}/%{target}-cpp
446 %attr(755,root,root) %{_bindir}/%{target}-gcov
447 %attr(755,root,root) %{arch}/bin/%{target}-gcc
448 %attr(755,root,root) %{arch}/bin/%{target}-gcc-%{version}
449 %attr(755,root,root) %{arch}/bin/%{target}-cpp
450 %attr(755,root,root) %{arch}/bin/%{target}-gcov
451 %attr(755,root,root) %{arch}/bin/gcc
452 %dir %{gccarchdir}
453 %dir %{gcclibdir}
454 %attr(755,root,root) %{gcclibdir}/cc1
455 %attr(755,root,root) %{gcclibdir}/collect2
456 %attr(755,root,root) %{gcclibdir}/lto-wrapper
457 %attr(755,root,root) %{gcclibdir}/lto1
458 %attr(755,root,root) %{gcclibdir}/liblto_plugin.so*
459 %{gcclibdir}/libgcc.a
460 %{gcclibdir}/libgcc_eh.a
461 %{gcclibdir}/libgcc_s.a
462 %{gcclibdir}/libgcov.a
463 %{gcclibdir}/crtbegin.o
464 %{gcclibdir}/crtend.o
465 %{gcclibdir}/crtfastmath.o
466 %dir %{gcclibdir}/include
467 %{gcclibdir}/include/*.h
468 %{_mandir}/man1/%{target}-cpp.1*
469 %{_mandir}/man1/%{target}-gcc.1*
470 %{_mandir}/man1/%{target}-gcov.1*
471
472 %files -n crossmingw32-libgcc-dll
473 %defattr(644,root,root,755)
474 %{_dlldir}/libgcc_s_dw2-1.dll
475
476 %files c++
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_bindir}/%{target}-g++
479 %attr(755,root,root) %{arch}/bin/%{target}-c++
480 %attr(755,root,root) %{arch}/bin/%{target}-g++
481 %attr(755,root,root) %{arch}/bin/c++
482 %attr(755,root,root) %{arch}/bin/g++
483 %attr(755,root,root) %{gcclibdir}/cc1plus
484 %{gcclibdir}/libstdc++.dll.a
485 %{gcclibdir}/libstdc++.la
486 %{gcclibdir}/libsupc++.la
487 %{gcclibdir}/libsupc++.a
488 %{gcclibdir}/include/c++
489 %{_mandir}/man1/%{target}-g++.1*
490
491 %files -n crossmingw32-libstdc++-static
492 %defattr(644,root,root,755)
493 %{gcclibdir}/libstdc++.a
494
495 %files -n crossmingw32-libstdc++-dll
496 %defattr(644,root,root,755)
497 %{_dlldir}/libstdc++-6.dll
498
499 %files objc
500 %defattr(644,root,root,755)
501 %attr(755,root,root) %{gcclibdir}/cc1obj
502 %{gcclibdir}/libobjc.dll.a
503 %{gcclibdir}/libobjc.la
504 %{gcclibdir}/include/objc
505
506 %files -n crossmingw32-libobjc-static
507 %defattr(644,root,root,755)
508 %{gcclibdir}/libobjc.a
509
510 %files -n crossmingw32-libobjc-dll
511 %defattr(644,root,root,755)
512 %{_dlldir}/libobjc-3.dll
513
514 %files fortran
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_bindir}/%{target}-gfortran
517 %attr(755,root,root) %{arch}/bin/%{target}-gfortran
518 %attr(755,root,root) %{arch}/bin/gfortran
519 %attr(755,root,root) %{gcclibdir}/f951
520 %{gcclibdir}/finclude
521 %{gcclibdir}/libgfortran.dll.a
522 %{gcclibdir}/libgfortran.la
523 %{gcclibdir}/libgfortran.spec
524 %{gcclibdir}/libgfortranbegin.a
525 %{gcclibdir}/libgfortranbegin.la
526 %{_mandir}/man1/%{target}-gfortran.1*
527
528 %files -n crossmingw32-libgfortran-static
529 %defattr(644,root,root,755)
530 %{gcclibdir}/libgfortran.a
531
532 %files -n crossmingw32-libgfortran-dll
533 %defattr(644,root,root,755)
534 %{_dlldir}/libgfortran-3.dll
535
536 %files -n crossmingw32-libquadmath
537 %defattr(644,root,root,755)
538 %{gcclibdir}/libquadmath.dll.a
539 %{gcclibdir}/libquadmath.la
540
541 %files -n crossmingw32-libquadmath-static
542 %defattr(644,root,root,755)
543 %{gcclibdir}/libquadmath.a
544
545 %files -n crossmingw32-libquadmath-dll
546 %defattr(644,root,root,755)
547 %{_dlldir}/libquadmath-0.dll
548
549 %files java
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_bindir}/%{target}-gcj
552 %attr(755,root,root) %{_bindir}/%{target}-jcf-dump
553 %attr(755,root,root) %{arch}/bin/%{target}-gcj
554 %attr(755,root,root) %{arch}/bin/%{target}-jcf-dump
555 %attr(755,root,root) %{gcclibdir}/jc1
556 %attr(755,root,root) %{gcclibdir}/jvgenmain
557 %{_mandir}/man1/%{target}-gcj.1*
558 %{_mandir}/man1/%{target}-jcf-dump.1*
This page took 0.115667 seconds and 3 git commands to generate.