]> git.pld-linux.org Git - packages/crossmingw32-freetype.git/blobdiff - crossmingw32-freetype.spec
- updated to 2.4.9 (fixes CVE-2012-1144, SA48320)
[packages/crossmingw32-freetype.git] / crossmingw32-freetype.spec
index 8fde50aa701cbc8ecf0cf651f7fee08777457168..b9ea3bb3c6167967dda92fe865feeb451c3e3909 100644 (file)
@@ -1,27 +1,22 @@
 #
 # Conditional build:
-%bcond_without bytecode        # without TT bytecode interpreter
-#               (patents pending in USA, Japan etc., but now it includes
-#                also patent-free hinting workaround)
-%bcond_without lcd             # disable filters reducing color fringes when
-#                 subpixel rendering for LCD (only used with a new 2.3.0 API;
-#                 patents pending)
+%bcond_without lcd             # without LCD subpixel color filtering (Microsoft patents in USA)
 #
-%define                _realname   freetype
-Summary:       TrueType font rasterizer - Mingw32 cross version
-Summary(pl.UTF-8):Rasteryzer fontów TrueType - wersja skrośna dla Mingw32
-Name:          crossmingw32-%{_realname}
-Version:       2.3.5
+%define                realname   freetype
+Summary:       TrueType font rasterizer - MinGW32 cross version
+Summary(pl.UTF-8):     Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
+Name:          crossmingw32-%{realname}
+Version:       2.4.9
 Release:       1
-License:       GPL or FTL
+License:       GPL v2 or FTL
 Group:         Development/Libraries
-Source0:       http://savannah.nongnu.org/download/freetype/%{_realname}-%{version}.tar.bz2
-# Source0-md5: 65234327c5ac46ee00ebda15995d4c1c
+Source0:       http://downloads.sourceforge.net/freetype/%{realname}-%{version}.tar.bz2
+# Source0-md5: 77a893dae81fd5b896632715ca041179
 URL:           http://www.freetype.org/
 BuildRequires: crossmingw32-gcc
-BuildRequires: crossmingw32-zlib
+BuildRequires: crossmingw32-zlib >= 1.2.3-2
 BuildRequires: python
-Requires:      crossmingw32-zlib
+Requires:      crossmingw32-zlib >= 1.2.3-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                specflags_ia32  -fomit-frame-pointer
@@ -32,15 +27,22 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                target                  i386-mingw32
 %define                target_platform         i386-pc-mingw32
-%define                arch                    %{_prefix}/%{target}
 
 %define                _sysprefix              /usr
 %define                _prefix                 %{_sysprefix}/%{target}
-%define                _pkgconfigdir           %{_libdir}/pkgconfig
+%define                _libdir                 %{_prefix}/lib
+%define                _pkgconfigdir           %{_prefix}/lib/pkgconfig
 %define                _dlldir                 /usr/share/wine/windows/system
 %define                __cc                    %{target}-gcc
 %define                __cxx                   %{target}-g++
 
+%ifnarch %{ix86}
+# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
+%define                optflags        -O2
+%endif
+# -z options are invalid for mingw linker
+%define                filterout_ld    -Wl,-z,.*
+
 %description
 The FreeType engine is a free and portable TrueType font rendering
 engine. It has been developed to provide TrueType support to a great
@@ -71,16 +73,16 @@ demonstracyjnych.
 Ten pakiet zawiera wersję skrośną dla Win32.
 
 %package static
-Summary:       Static freetype library (cross mingw32 version)
-Summary(pl.UTF-8):     Statyczna biblioteka freetype (wersja skrośna mingw32)
+Summary:       Static freetype library (cross MinGW32 version)
+Summary(pl.UTF-8):     Statyczna biblioteka freetype (wersja skrośna MinGW32)
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description static
-Static freetype library (cross mingw32 version).
+Static freetype library (cross MinGW32 version).
 
 %description static -l pl.UTF-8
-Statyczna biblioteka freetype (wersja skrośna mingw32).
+Statyczna biblioteka freetype (wersja skrośna MinGW32).
 
 %package dll
 Summary:       DLL freetype library for Windows
@@ -96,11 +98,10 @@ DLL freetype library for Windows.
 Biblioteka DLL freetype dla Windows.
 
 %prep
-%setup -q -n %{_realname}-%{version}
+%setup -q -n %{realname}-%{version}
 
 %build
 CFLAGS="%{rpmcflags} \
-%{?with_bytecode:-DTT_CONFIG_OPTION_BYTECODE_INTERPRETER} \
 %{?with_lcd:-DFT_CONFIG_OPTION_SUBPIXEL_RENDERING}" \
 %configure \
        --target=%{target} \
@@ -110,59 +111,14 @@ CFLAGS="%{rpmcflags} \
 
 %{__make}
 
-# link shared library
-cd objs/.libs
-%{__cc} \
-       --shared *.o -llualib50 -llua50 -lm -o libfreetype.dll \
-       -Wl,--enable-auto-image-base -Wl,--out-implib,libfreetype.dll.a -lz
-cd ../..
-
-cat << "EOF" >> libfreetype.la
-# libfreetype.la - a libtool library file
-# Generated by ltmain.sh - GNU libtool 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
-
-# The name that we can dlopen(3).
-dlname=''
-
-# Names of this library.
-library_names='libfreetype.dll.a'
-
-# The name of the static archive.
-old_library='libfreetype.a'
-
-# Libraries that this one depends upon.
-dependency_libs=' -lz'
-
-# Version information for libfreetype.
-current=9
-age=3
-revision=16
-
-# Is this an already installed library?
-installed=yes
-
-# Should we warn about portability when linking against -modules?
-shouldnotlink=no
-
-# Files to dlopen/dlpreopen
-dlopen=''
-dlpreopen=''
-
-# Directory that this library needs to be installed in:
-libdir='%{_libdir}'
-EOF
-
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install libfreetype.la $RPM_BUILD_ROOT%{_libdir}
-
 install -d $RPM_BUILD_ROOT%{_dlldir}
-install objs/.libs/libfreetype.dll $RPM_BUILD_ROOT%{_dlldir}
-install objs/.libs/libfreetype.dll.a $RPM_BUILD_ROOT%{_libdir}
+mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
 
 %if 0%{!?debug:1}
 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
@@ -176,13 +132,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc docs/{CHANGES,FTL.TXT,LICENSE.TXT,PATENTS,TODO,formats.txt,raster.txt}
-%{_bindir}/freetype-config
+%doc docs/{CHANGES,FTL.TXT,LICENSE.TXT,TODO,formats.txt,raster.txt}
 %{_libdir}/libfreetype.dll.a
 %{_libdir}/libfreetype.la
 %{_includedir}/freetype2
-%{_includedir}/*.h
-%{_pkgconfigdir}/*.pc
+%{_includedir}/ft2build.h
+%{_pkgconfigdir}/freetype2.pc
 
 %files static
 %defattr(644,root,root,755)
@@ -190,4 +145,4 @@ rm -rf $RPM_BUILD_ROOT
 
 %files dll
 %defattr(644,root,root,755)
-%{_dlldir}/libfreetype.dll
+%{_dlldir}/libfreetype-*.dll
This page took 0.166041 seconds and 4 git commands to generate.